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INTRODUCTION
Microsoft Excel is a data analysis and representation application for fabricating a large number of
data, expenditure and income, predictions, and many accounting-related activities. The application
can be used in areas such as accounting, finance, and calculation operations. Excel comes with an
interesting User Interface; graphics and it is also widely popular.

Microsoft Excel 2022 also comes with interesting features and new options that make data entry,
analysis, representation, and visualization easy and comprehensive. With charts, shapes, icons, and
various formatting options made available, Excel can be used to customize your data to whichever
format is desired and suitable for your use.

Understanding a program like Excel is essential to every professional, worker, student, and
anyone who seeks some sort of order, from the simplest to the most complex operations.

In the following chapters, we will develop a series of information based on concepts,
methodologies, functions, and formulas that will help both a beginner and an expert understand the
benefits of this spreadsheet born from the hand of Dr. Charles Simonyi in 1985.

There are dozens of spreadsheet applications and software similar to Microsoft Excel on the
market. However, these alternatives do not seem to be at the same level as this program since it has
become clear that Excel has calculation graphic design using tables and pivot tables.

Microsoft's popular spreadsheet program, Excel, has long been at the forefront of this technology
and is expected to maintain its dominance for the foreseeable future. That is precisely what this book
is about.

It is a program that allows you to optimize data processing time, improving the effectiveness and
efficiency of anyone. It simply saves the investment of time in pencil calculations and facilitates
programming directly on a spreadsheet on a computer.

Therefore, those who consider themselves inexperienced should start working on it right away,
and this is precisely what the information compiled in the following 16 chapters is all about.

16 chapters, and that will possibly turn you into an expert





Chapter 1: Excel history on Microsoft
Multiplan was the first spreadsheet program marketed by Microsoft back in 1982. It was originally
designed and incorporated in CP/M systems, but its popularity was much lower on MS-DOS systems
compared to its rival: Lotus 1–2–3.

For this reason, Microsoft was forced to create Excel for Mac and publish it for the first time in
1985. For Windows, the first version was released in November 1987 and numbered 2–05 in line
with the Mac, which had a Windows environment runtime package.

The official origin of Excel is the Microsoft Office application, put on the market on August 1,
1989. It was originally conceived as a tool for Apple Macintosh computers and could later see the
light of day on the Windows operating system.

This was how Microsoft could be the standard-bearer among the leading developers of computer
spreadsheet software because Lotus was slow to bring 1–2–3 for Windows, an area in which it was
also far superior to another rival of the time: Quattro Pro from Borland.

By 1993, the lawsuits of others represented a huge challenge for Microsoft. On this occasion, the
axis of the judicial conflict was a company that replicated its software and marketed it under the
same name of "Excel."

The use of the tool for the financial sector was such that it was very profitable to market the
licenses. This lawsuit resulted in the Excel designed by Microsoft should be named "Microsoft
Excel" in all press releases and legal documents. Over time, Microsoft has not fully complied with
this legal provision, and the same company expressed its intention to acquire the other trademark to
eliminate any difficulty or confusion.

Subsequently, the same organization proposed the use of the letters "XL" as the abbreviation for
the program, in addition to a more stylized redesign of the program's icon.



Excel Developer
Although Excel is a software patented and marketed by Microsoft, the initiative would never have
prospered if it had not been for the idea of Dr. Charles Simonyi, the original creator. Simonyi, in
1985, decided to sell the rights to this idea of Word and Excel and thus was born as the company's
original product.

At the time, Excel was a gold mine for developers and the corporation in general as it was the
first spreadsheet with which the user could set the appearance of fonts, character attributes, and
boxes. The inclusion of special features such as intelligent recomputing of boxes, updating data, and
working in separate cells with automatic formulas made it a unique tool.



Why Excel Is Different
Interface

The interface that Microsoft developed for the Excel user is unique and has been replicated by
multiple competitors over the years. It has become a worldwide reference in terms of spreadsheet
features, maintaining the essence of certain structures such as the boxes organized in rows and
columns called cells (intersection of rows and columns), and in each of the cells, you can manage
data or formulas with relative, absolute and mixed references.

Visual Basic
Visual Basic (VBA) applications have been incorporated in Excel since 1993. It is a

programming language with the ability to automate Excel tasks and process user-defined functions in
worksheets. VBA is the application that allows the creation of forms and keeps the controls in the
worksheet communicating with the user.

Formats
The default format of the Microsoft Excel application is .xls. Some variations in the formats

according to the version of the program can be:
-  Files are saved in .xls format for versions earlier than or equal to Excel 2003.
-   The workbooks are saved in .xlsx format for versions older than or equal to Excel 2007.
-   Macro-prepared workbooks are saved under the .xlsm extension for versions greater than or

equal to Excel 2007.
-   Binary Excel workbooks are saved under the .xlsb format for versions later than or equal to

Excel 2007.
Calculation Control
This VBA function provided by VBA caused many problems for the corporate area. The problem

was that it made Excel a target for macro viruses. As the risk was great, Microsoft took measures and
incorporated the option to disable or automatically execute macros when opening an Excel file.
Subsequently, the problem was solved with the rise of the antivirus market, which allowed immediate
detection.

Customization
At the time, Excel was the first spreadsheet application to include functions for customizing the

appearance and modification of cells independently so that they could be updated immediately



after modification. A great novelty for the time.
In addition to that typical interface of its type that maintained the premises of VisiCalc, it also

organized cells with data or formulas with relative, absolute, or mixed references and distributed
them to other cells.



Versions of Excel
Microsoft Excel became so popular because, before its release, no other computer software could offer
both simple and advanced functions. Spreadsheet work became easier, leading the way in data
management and accounting technology.

The technological giant's constant strategy in program updates made it possible to perfect every
action. Nowadays, years go by, and it is still possible to discover different uses and applications of
Excel in several fields. That is why, when talking about Excel versions that precede the most current
one, it is worth mentioning:

First Attempts

VisiCalc and Lotus 1–2–3 are the "pillar" programs of the Excel that is known today. VisiCalc
earned a reputation as the first functional spreadsheet program, so useful that it eliminated the need for
other spreadsheet applications on computers.

While Lotus 1–2–3 led the spreadsheet market in the 1980s, a decade in which it recorded huge
sales for IBM computers and gave it market dominance for a long time.

Excel 1
The graphical user interface and the mouse were two unique elements available in this operating

system. To avoid direct competition with Lotus 1–2–3, the market leader at the time, Microsoft released
the first version of Excel for Macintosh systems in 1985.



Excel 2 and 3
After the success of Excel 1, Excel 2 was officially released in 1987 along with its Windows

operating system. For this, the developers had the advantage of a previous version, and for this newer
edition, they took the same functionalities and features of the Macintosh interface, such as drop-down
menus and point-and-click mouse interaction, and achieved a truly graphically optimized version.

Excel 4 and 5
With these two versions, Excel officially became part of the Microsoft Office suite in 1992. The

software appeared together with Windows 3.1, a range of new features for users that made it
irremediably displace its competition and become the market leader. In 1993 an improved version,
called Excel 5, was launched, with other enhanced options.

Excel 95–2003
The great redesign of the Microsoft operating system was Windows 95 in 1995. On that occasion,

as in the previous edition, improved functions were advanced for all the Office platform programs,
including a version known as Excel 95.

It was followed by versions of the program that continued improving and giving recognition to the
line of Office applications, such as Excel 97, Excel 2000, Excel 2002, and Excel 2003, all of them
keeping the original design with which Excel 95 had positive results.

Excel 2007
Excel 2007 was one of the last versions to present important changes in the interface, where ribbons

and tabs replaced the traditional drop-down menu; and in functionality. It was launched together with
the Windows Vista operating system and included many of its visual elements.







CHAPTER 2 - WELCOME TO
MICROSOFT EXCEL



LEARNING HOW TO USE EXCEL'S
FEATURES

Microsoft Excel particularly finds application in accounting, finance, and
calculation operations. The majority of companies tailor and fabricate a
large number of their expenditure and income, predictions, and all
accounting-related activities on Excel worksheets.

Although Excel is said to be a management house for data, however, the
type of data most usually and frequently controlled in Excel is financial
data. Other numerous software applications exist that can also perform
basic and financial operations as Excel. An advantage Microsoft Excel has
over its rivalries is its interesting User Interface, graphics, and yes, its
popularity.

Additional functions and applications of Excel are:



•  Data entry
•  Management of data
•  Accounting
•  Financial analysis
•  Design of charts and graphs
•  Programming
•  Designing time management schemes
•  Designing task management schedules
•  Financial documentation

Microsoft Excel can be used on any form of data that needs to be
processed and organized.



RECENT UPGRADES IN MICROSOFT
EXCEL 2022 Joint Spreadsheet Editing

Multiple employees can work on a worksheet or spreadsheet
simultaneously. This feature is known as Co-authoring. The coauthoring
process makes joint editing easy and quick.

The co-authoring feature also comes with the recognition of who works
with you and effects changes in a worksheet.

Easy Navigation
Excel introduces XLOOKUP which facilitates easy navigation through

rows, columns, and tables.
The LET Function
This function allows the assignment of names of results from

calculations. It helps to save values and defines formulas in calculations.
Excel also introduces the feature of having a resulting array from the

input of a formula. This feature is called Dynamic Array.
Quick Search
Excel 2022 helps make searching and getting a quick result of a

particular data-position easier. With the XMATCH feature, including this in
formulas help users find exact positions of searched data.

Customized Viewing of Worksheets
Microsoft Excel now allows you to determine how worksheets are



viewed.
Enhanced Performance
Operation speed is now improved with the introduction of functions

such as SUMIF, COUNTIF, and AVERAGEIF. You can also now unhide
and hide multiple sheets at a go.

Workbook Summary
In cases of big data, Excel 2022 provides a tab called Workbook

Statistics which provides a summary of the entire data contained in the
workbook.

Excel files can also now be saved to OneDrive or SharePoint Online as
changes are being made to your data.



IMPROVING YOUR KNOWLEDGE OF
WORKSHEETS AND WORKBOOKS

Worksheets in Excel are single pages of sheets or work areas contained in a
file known as workbooks. Workbooks however are made up of a
combination of multiple worksheets. Launching Microsoft Excel opens a
workbook that contains a minimum of three worksheets.

Worksheets in Excel comprise of 1,048,576 rows, 16,384 columns and
17,179,869,184 cells.

WORKSHEET NAVIGATION AND USING THE EXCEL
RIBBON



Navigating a Worksheet Using a Keyboard
•  Ctrl + W can be used to exit a workbook
•  Ctrl + O is used to open an existing workbook
•  Alt + H is for navigating to the Home tab
•  Use Ctrl + S when saving a workbook
•  Use Ctrl + C to copy data in cell(s)
•  Ctrl + V can be used to paste copied data
•  Use Ctrl + Z to undo actions
•  Pressing the Delete key cleans up the data in a cell
•  Use keys Alt + H to select a color to fill the desired cell



•  Ctrl + X keys cut data snippets

•  Alt + N keys are used to navigate to the tab for inserting additional
features

•  Use Ctrl + B keys to write text or numbers on bold fonts

•  Pressing keys Alt + A, then Alt + C edit input to be placed centrally
in cells

•  Keys Alt + P are used to navigate to the layout option for pages
•  Pressing keys Alt + A takes you to the Data pane
•  Alt + W keys open the View pane
•  Use keys Alt + H, then Alt + B to include borders in your cells
•  Use key combination Alt + H + D + C when deleting columns
•  Alt + M keys navigate to the Formula section
•  Use Ctrl + 9 keys to hide a set of highlighted rows
•  Use Ctrl + 0 keys to hide a set of highlighted columns
•  Use Ctrl + Tab keys to navigate around current Excel
workbooks.

•  Use Ctrl + Page Down keys to navigate to subsequent worksheets in
a workbook.

•  Use Ctrl + Page Up keys to navigate to preceding worksheets in a
workbook.

•  The Ctrl + Arrow Keys can be used to control the cursor in all
possible directions

•  The Ctrl + Home keys are for moving to the topmost cell on the left
of the worksheet.

•  The Ctrl + End keys are for moving to the last cell used in the
worksheet.

•  Keys Alt + Page Down helps navigate a full view in the right
direction of the worksheet.

•  Keys Alt + Page Up helps navigate a full view in the left direction of
the worksheet.



Using a Mouse to Navigate a Worksheet
The mouse can easily be used to highlight and move through cells as
desired. Every pane on the Ribbon can also be accessed with a simple click
of the mouse. The scrollbar can also be moved in all directions either by
clicking on the arrows present at the edges or by simply dragging the scroll
box itself.



MAKING USE OF THE RIBBON PANE
The ribbon pane in Microsoft Excel is an array of accessible menus and
icons that can be found on top of the Excel screen. It makes it easier to
locate, comprehend and make use of simple functions to perform simple
operations.

The Ribbon pane in Microsoft Excel is in four categories:



•  The Ribbon Tabs: These are made up of numerous functions that are
further divided into groups known as the Ribbon groups.

•  The Ribbon Group: This is made up of similarly related functions
that are implemented when carrying out bigger operations.

•  The Dialog Launcher: This is a little arrow icon present at the right-
hand edge of the ribbon group. This arrow icon opens additional related
functions.

•  The Command Button: This is the button to be clicked when
carrying out specific operations.

Contents of the Ribbon Pane
•  File: The file tab makes it easy to access a menu that shows necessary

functions and options that can be used to manipulate files and workbooks.
•  Home: This tab house commands that are most commonly

implemented. Some of these commands include Copy, Paste, Sort, Filter,
Format, etc.

•  Insert: Use the insert tab to include various images and objects in
your worksheet. These objects can be charts, equations, tables, links,
symbols, headers, footers, etc.

•  Draw: The draw tab offers drawing tools that enable you to insert
self-drawn characters in your worksheet. The options in the draw tab are
however is dependent on the type of device being used.

•  Page Layout: This menu helps you customize how your worksheet
looks when onscreen and in hardcopy. It also allows you to configure
settings such as themes, gridlines, margins, object alignment, etc.

•  Formulas: The formula tab makes it possible to input formulas,
specify names and decide how calculations are to be carried out.

•  Data: This menu contains functions used for configuring worksheet
data and also for the inclusion of data from external sources.



•  Review: This menu makes it possible to cross-check spellings, keep
track of edits, include comments, and also safeguard



worksheets and files.
•  View: This menu offers options for navigating around views in

worksheets, locking panes, and also helps determine how multiple
worksheets are displayed and arranged.

•  Help: The help tab is a quick menu that provides you with easy
access to the Microsoft support page. It enables you to quickly report errors
and acquire needed tutorial videos.

•  Developer: The developer tab first needs to be enabled by a user as it
is not visible by design in Microsoft Excel. This menu allows you to
implement the advanced programming language in Excel, which is the
VBA (Visual Basic for Applications) macros, the ActiveX, Form
configurations, and also XML functions.

•  Add-ins: This menu is only visible when an older workbook is
opened, or an add-in that changes the view of the toolbars or menus is
loaded.

The Contextual Menu
The Contextual menu, also called the Tool Tabs, can only be made

visible and accessible when particular objects are selected. Example of
items that brings up the contextual menu includes tables, charts, shapes, and
picture. For instance, clicking on a chart automatically brings up Design
and Format options under a menu called Chart Tools.



COMMAND TYPES PRESENT ON THE
RIBBON MENU

•  Commands that Executes in a Click

This command is a very common one in the Excel Ribbon. Clicking on
these commands initiates a corresponding action immediately after they are
clicked. For example, the Increase Font Size command immediately
initiates a font increase when clicked on.



•  The Toggle Commands

The toggle commands in Excel Ribbon exist in dual states. The
command is developed such that a click on the Toggle command changes
the icon color to indicate that the command is currently turned on. Another
click on the command turns it off and removes its effect. A good example is
a Bold command.

•  The Split Commands

The split commands are those buttons having a drop-down option in the
Excel Ribbon. Buttons with the split command feature are found to possess
a little down-arrow at their ends. A click on these buttons themselves



initiates default or previously selected commands, while a click on the
down-arrow displays additional options on the drop- down menu. An
example is the Underline command.

•  The Drop-down Commands



These commands are those buttons having a drop-down arrow in the
Excel Ribbon. A click on the present down-arrow displays additional
options on the drop-down menu. An example is the Conditional
Formatting option.

•  The Rich Menu Commands

These commands are also like the drop-down commands in Excel
Ribbon, but they give additional details concerning a menu or an item.
Further information helps to know better how these menus or item operates.
An example is the Freeze Panes option.



•  The Gallery Drop-down Commands

In Excel Ribbon, these commands display more available functions than
the usual drop-down menus. Objects in a gallery drop-down previews how
the selection of one of the items would affect the available data. Hovering
your cursor over an option in the gallery drop-down applies it on your open
Worksheet without necessarily selecting it. An example is the Cell Styles
option.



•  The Check Box Commands

The check box commands in Excel ribbons also exist in dual states like
the toggle commands. These commands are implemented for configurations
that are only available in either “ON” or “OFF” options. An example is the
Formula Bar option.



IMPLEMENTING

SHORTCUT MENUS IN EXCEL
Shortcut panes display commands and settings that are mostly used

when working with a particular item in a worksheet. Note however that
these options depend on context, i.e. the object being configured. The
shortcut options that are displayed in these contexts are also determined by
the position of the cursor.

Shortcut options are not the total list of options or commands available
for items in Excel; therefore, some needed functions may not be seen
among the displayed options.

Shortcut menus can be accessed by right-clicking on your mouse while
the cursor is placed at specific positions. Keyboard keys Shift

+ F10 can also be used to bring the menu on display.



CONFIGURING THE QUICK ACCESS TOOLBAR
The Microsoft Excel Quick Access Toolbar is a configurable tab

housing a combination of settings that stand apart from the menus on the
ribbon. The position of the Quick Access Toolbar can be changed; even
buttons and commands can be added and removed.

To display or hide the Quick Access Toolbar:
•  In the top left corner atop the ribbon, make a right-click to select to

either display or hide the toolbar.



To adjust the positioning of

the Quick Access Toolbar:
•  Click on the option to configure the Quick Access Toolbar after

clicking on the related icon.
•  From the subsequent menu, click on the tab to either display the

toolbar at the bottom or the top of the Ribbon.
To add commands to the Quick Access Toolbar:
•  Select a desired command from the ribbon and make a right-click on

it to display an additional menu. Select the option to include the command
in the quick access toolbar.



•  Also, if the desired command that you want to add to the quick access
toolbar is not available on the ribbon, select the option to configure the
Quick Access Toolbar after clicking on the related icon.

•  Click on the option to access more commands.

•  Select the tab to choose commands not present on the ribbon from the
Choose commands from option

•  Click on Add after locating the desired command.

To delete commands from the Quick Access Toolbar:
•  Highlight the command to be deleted and make a rightclick on it.

Select the option to remove it from the toolbar from the pop-up menu.
•  To rearrange how commands are displayed on the Quick Access

Toolbar:
•  Select the option to configure the Quick Access Toolbar after clicking

on the related icon.
•  Highlight commands to be moved and choose either to move them up

or down.
To Revert the Quick Access Toolbar to default:
•  Select the tab to reset to default and then click on the option to only

reset the toolbar.
USING DIALOGUE BOXES IN EXCEL There are two types of

dialogue boxes available in Excel, these are:
•  Typical Dialogue Boxes: these dialogue boxes discontinue further

activities and actions on the worksheet unless the dialogue box is dismissed.



•  Modeless Dialogue Boxes: users can continue their activities on
worksheets when these dialogue boxes are open. An example of this is the
Find and Replace dialogue box.



Navigating through Dialog Boxes
Moving through dialogue boxes is as easy as it comes. Simply click on

necessary and desired commands to configure as you wish.
Implementing Tabbed Dialogue Boxes
Tabbed dialogue boxes are those which consist of multiple possible

setups grouped in tabs. Simultaneous editing of various aspects of an item is
made possible with tabbed dialogue boxes. Clicking on the OK button after
all configurations affects immediate changes.



WORKING WITH TASK PANES
Making use of some commands or inserting particular items in a worksheet
immediately launches a task pane for the specific command. Working with
pictures or images for example launches the task pane to immediately
format the picture. Clicking on the close button on task panes after using
them removes them from the display.



BUILDING YOUR WORKBOOKS IN
MICROSOFT EXCEL

Acquiring your first workbook in Microsoft Excel is a very easy task; you
only need to follow these steps:

•  Double click on the Excel icon on your computer to launch the
application

•  Click on the option to create a blank workbook or press Ctrl +
N

keys
To use a workbook from a predefined template:

•  Click on File
•  Click on New
•  Select a template from available options



USING YOUR WORKSHEET
Entering Months of the Year in your Worksheet Using Autofill

•  Either on rows or columns, enter the first-month value:

January
•  Place your cursor at the right-hand of the bottom of the cell you

entered the previous value.
•  Drag down or sideways to the desired cell when the Autofill icon

becomes visible while pressing down the left button of your mouse.

•  Let go of the mouse button to see the Autofill result



•  To enter months in intervals, enter the preceding two months in the
desired sequence to enable Excel to compute the interval

•  Repeat drag process



Inputting Sales Data

•  First, put your sales data in a comprehensive format and enter it in
your worksheet as shown below:

•  This data shows weekly sales entries for four months along with the
total sales.

Editing Number Formats

•  Navigate to the Home tab

•  Click on Numbers and select the Number Format option. Pick the
desired number format.



Customizing Data Entry in a Worksheet
This process gives color and pops to your worksheet to make it

attractive to viewers. Simply highlight desired columns or rows and colors
and borders from the ribbon menu.



Performing Addition Operations on the Sales Data
Using the AutoSum command is the easiest and simplest procedure to

carry out summing operations in Excel. Simply highlight the rows or
columns containing the numbers to be summed up, and then click on
AutoSum present on the Home tab.

Simple formulas can also be used. All you have to do is to note the ID
for the row or column where the data to be summed up is contained, e.g.
cells B3 - B6. Then in the formula bar enter the expression:

=SUM(B3:B6)
Place the cursor on the desired cell where you want the result to be

displayed.
Creating a Chart for the Sale Data

•  Select all cells containing data on your worksheet



•  Select the Insert option on the ribbon menu



•  Click on Charts and select the option to input a clustered column
chart in your worksheet

Publishing or Printing the Worksheet
The fastest way to print your worksheet is to use the keyboard shortcut

keys of Ctrl + P keys. This action launches the Print configuration tab.



Here, you can decide what to print, either the complete workbook or just the
selected worksheet.



An alternative procedure to this is
to click on File and select the Print option in the available menu.



Saving your Workbook
•  Use keyboard keys Ctrl + S to save your workbook.

•  Type in a suitable name for the workbook to facilitate easy access in
the pop-up dialogue box.

•  Select the Save button.

You can also navigate to File and then select the Save or Save As
option.

Summary
This chapter provided a step-by-step procedure on how you can easily

create your first workbook with adequate functionalities after first
introducing Microsoft Excel and explained the purpose and application
areas of the software. The new features in Excel 2022 were discussed along
with workbooks, worksheets, and how users can navigate through them
using either a mouse or a keyboard. The



essence of the Ribbon menu and its commands with available shortcut menus, the Quick Access
Toolbar, and how it can be configured were also examined.





Chapter 3: Understanding the Spreadsheet

The well-known spreadsheet is a very useful tool for people to work with numbers and perform
operations with them. This spreadsheet allows anyone to work with a large amount of data and numbers,
and it has a wide range of functions that integrate it and with which you can perform mathematical,
statistical, technical, and financial calculations.

To talk about the importance of the Excel spreadsheet, it is necessary to highlight some aspects of the
computer tool that currently has a huge field of application.

Another point to rescue to highlight its importance is the multitude of professionals who benefit from
this tool. It can be assured that this program is a great ally for administrators, inventory managers,
accountants, scientists, students, enterprising communicators, and thus, a diversity of professions that
have no relation to mathematics take advantage of this tool and its ability to automate tasks.

This software is completely versatile and adaptable to different needs, relevant for decision making,
as it allows to see the effect that changes in the variables cause in the desired result.



Know the Structure of the Spreadsheet
As you can see, the function of the spreadsheet is to organize and store data and information in a
work area in the form of a matrix, similar to a sheet of graph paper.

When you open a document in the program, you can see that it is made up of a certain number of
rows and columns, which in turn are identifiable.

It is important to recognize and understand that the columns are represented by letters at the top,
while the rows are named with numbers on the left side. The intersection of the rows and



columns gives shape to the cells.



What Is a Spreadsheet for?
Before going into detail about each function, it is of great relevance to know why the Excel
spreadsheet has multiple functions that benefit any professional and person in a certain trade. It is
simple:

The software facilitates the task of organizing and managing huge amounts of data. It allows
you to sort lists and data sets by applying established criteria, saving, and printing them.

It is intelligent and can apply basic or advanced formulas to obtain results. It graphs the
information in different ways and simply presents them.

Automates routine and repetitive tasks.



How to Use an Excel Spreadsheet?
First of all, it is important to download any version of the Microsoft Excel program. The latest
versions are recommended) to start using Excel spreadsheets, create charts, its built-in formulas,
work with data, numbers, pivot tables, and formatting options.

This spreadsheet as a computer program allows you to calculate and protect data. Once they are
entered, it is possible to perform operations, analyses, and later display graphs.

Any type of data, usually numeric or text, can be inserted into the cells.
Note: A single cell can contain 32,767 numeric or alphabetic digits.
Cells can hold information in text format, numerical data in different formats, and an infinite

number of formulas.
Normally, Excel formulas perform some specific operation based on the type of data stored in the

cell or a combination of data stored in a range of cells.
The results of a formula are qualified as dynamic and give the option to change if the content of

the cells or range of cells is modified.
These spreadsheets are very useful in the business world as they are used to present monetary

information, accounting, budgets, invoicing, tax calculations.
They are an excellent tool for presenting a summary and presenting the information in different

ways, always according to the user's interest.
These sheets allow you to interact with other sheets, take and refer to their values, or deliver

results.
The spreadsheet has the advantage of being able to interact with other applications to import or

export data, analysis, and results.
The information can also be sorted, filtered, and presented in a summarized or illustrated form

through graphs.
It allows the presentation of information through different graphs such as trends, scatter, bars or

pies.



Using an Excel document, it is possible to present summaries and flexible reports through its
dynamic tables.

It automates excessively repetitive computations.



Basics of an Excel spreadsheet

Sheet and Workbook
When you open an Excel document, the first thing you will find is the main sheet, where the work area

is defined. With several sheets related to each other, a workbook is formed.
Normally, when you open a blank Excel document, it immediately loads a sheet by default, and the

user can add sheets as needed.
The Excel sheets can be customized, giving them a name, a color or protecting them with a password.

Title Bar
The title bar is located at the top of the screen and contains the name of the Excel file. In the case of

opening an Excel document, by default, it will have the name Book1. This will change once the file has
been saved and named.

Title Bar in Excel



On the right side, we have the “close,” “minimize,” and “maximize” buttons. Also, you can see the
name of the user account linked to Microsoft. On the left side, you will find the shortcut toolbar. You can
customize it according to the functions you constantly perform.

The quick access toolbar helps to save time in actions that are usually done. Once they are identified,
instead of navigating through the menus to perform a specific action, you can have it available in this
section so that with just one click, it can be executed.

This is how you can start to be more efficient in the management of the Excel spreadsheet.

Menu Bar or Ribbon
Among the options that have several menus, this bar is located specifically under the title bar, where

you can generally find options such as File, Home, Insert, Page Layout, Formulas, Data, Review, View,
and Developer (Programmer).

Each time we click on a menu, the options related to that selection are displayed. For example, in the
Insert menu, we can find options to insert a table, an image, a chart, etc.

Name Box



You can identify the name of the cell or table selected or where the cursor is located from the name
box.

It is important to remember that the Excel program is made up of columns, which are named by
letters, and rows, which in turn are made up of numbers. At the intersections of rows and columns, the
cells are formed.

Every time we click on a cell, it is activated, and therefore, in the name box, it will show or identify
the name of that cell, placing the letter of the column and the number of the row, such as A1.

Toolbar
Several toolbars in the program provide quick and easy access to frequently used commands. You will

automatically see the standard toolbar and the formatting toolbar when you open Excel.
In the case of the standard toolbar, there are widely used options for handling files such as Open, Save,

Print, Copy, Cut, Paste, Undo, Sort, Insert, etc.
The formatting toolbar contains commands to apply a certain kind of formatting to the cell or cells you

are working on. Also, you can find options such as Font, Style, Size, Alignment, Borders, Color, etc.
Formula Bar



The formula bar facilitates the editing of data entered in the spreadsheet. Generally, this bar displays
the information or formulas present in the active cell. This information is necessary to give some editing
of the data or formulas contained in the cell or cells.

Workspace of the Spreadsheet
The work area is the main area where data, text, images, graphics, formulas, etc., are to be entered and

formatted.
In essence, it is that grid area made up of rows and columns, and in turn, of cells where you work with

data, numbers, text, etc.
Status Bar
The status bar is located at the bottom of the Excel window and allows you to control what is

happening in Excel and with certain basic arithmetic operations.
Different options appear in this bar that you can customize by right-clicking and then selecting the

options you want to appear.
Options displayed in the status bar:
Cell mode.

Fast fill in blank cells. Fast fill in modified cells. Signatures.
Information management policy. Permissions.



Caps Lock. Num Lock.
Fixed number of decimal places. Overwrite mode.

End mode. Macro recording. Selection mode. Page number.
Average. Count.
Numerical count. Minimum.
Maximum. Sum.
Load status. View shortcuts. Zoom slider.

Zoom.
Customize status bar.

Note: It is possible, and the user should be aware that some functions may not be available depending
on the version of Excel installed.

The information contained in a spreadsheet can be copied to other software packages within the suites,
such as the word processing package:

Open Office Calc as part of the Apache Open Office suite. Libre Office Calc variant of Open
Office.

Gdocs Spreadsheet.
Numbers, as an application integrated into Apple iWork.
KSpread, the spreadsheet integrated into the KOffice Suite, known as the free Linux package.
Corel Quattro Pro, from the Canadian Corel, integrated into the WordPerfect Suite.
Gnumeric from The GNOME Project as part of GNOME Office.

Old or outdated spreadsheets:
BCL or IBM's Business Computer Language, original 1963.
VisiCalc, for some the first business application spreadsheet, original 1979. US Railway

Association PLDOT modeling language from 1976.
Bell Canada and AT&T's LAMPAR spreadsheet compiler, dating from 1969. Autoplan

programming language & Autotab GE from 1968.
Lotus 1–2–3 from Lotus Development Corporation for IBM, released in 1983.



StarOffice Calc, formerly Oracle Open Office integrated into StarOffice.





CHAPTER 4 - INPUTTING AND
CUSTOMIZING DATA ENTRIES IN

WORKSHEETS IN MICROSOFT
EXCEL



GETTING FAMILIAR WITH DATA
TYPES IN EXCEL

•  Numbers or Numeric Values

The Numeric data type simply refers to numbers. It can be in decimal,
percentage, fraction, dates, or a specified currency. Note however that Excel
only supports input of fifteen (15) digits in its cells.

•  Texts or Alphabets Data Types

This data type primarily consists of alphabets. Microsoft Excel detects
letters, numbers, and symbols, e.g. ampersand (&), percentage (%), as well
as whitespaces and tabs as supported text inputs. Excel however has the
limitation of only being able to display 1,024 characters in its cells.

The text data type can also be used for data labels, categorizing data,
and as data titles or headings.

•  Logical (True/False) Data Type

The results of operations carried out with this data type can only yield a
True or a False. The logical data type is implemented when comparing data,
defining conditions or criteria, and then putting these conditions to tests,
and also for verifying data contained in cell locations. They are otherwise
known as Boolean functions.

•  The Error or Invalid Data Type

This data type occurs when Excel detects an error in data entry.

•  Formulas

Formulas are expressions in Excel that carry out specific mathematical
operations. Formulas in Excel usually begin with the equality sign “=” sign.



INSERTING TEXTS AND VALUES IN
WORKSHEETS

•  Inserting Numbers

Numbers can be entered manually in cells by placing your cursor on the
desired cell. Autofill can also be used to automatically populate cells when
dealing with sequential numbers or data. Just as for entering months of the
year as discussed in Chapter One, the



Autofill feature can also be used to populate rows or columns with
sequential numbers.

•  Inserting Texts

Placing your cursor on a cell and typing in alphabetical characters is the
simplest way to insert texts in your data entry.

Also, using the Insert option present in the ribbon, click on Text and
then choose the Text box option. Highlight the inserted text box and drag it
to the desired position in your worksheet.

•  Employing the Enter Mode

The enter mode in Excel makes a cell-active for you to enter data.
Double-clicking on a cell activates the Enter mode.



INSERTING TIME AND DATES IN
WORKSHEETS

•  Dates and Times

A very easy shortcut to inserting current dates and time in Excel is as
follows:

•  Rest your cursor on the cell you want the date to appear
•  Use the following keyboard shortcut to insert the current date;

Ctrl + ;

•  To insert the current time, use the following keyboard shortcut

Ctrl + Shift + ;
Both date and time can also be entered in a single cell; simply ensure to

enter a space after using the first command, (Ctrl + Shift + ; SPACE Ctrl +
;). Any of these can be entered first.

Inserting Dates and Time That Can Update Itself
This involves writing an expression or a formula in the Formula bar.

Dates and times that can update themselves are essential when dealing with
data that requires whose time of occurrence is required to be updated in
real-time.

•  Highlight the cell where the date would be entered
•  Type in this expression into the formula bar



=TODAY()
•  For time and date that updates itself:



=NOW()
Note that the date and time do not keep updating when the worksheet is
closed; the update only occurs when the worksheet is opened again or
recalculated.



EDITING THE CONTENTS OF A CELL
Erasing and Overwriting Data Written in a Cell



•  Select the cell to allow Excel to immediately highlight the data in that
cell.

•  Press the Backspace key on your keyboard or type in the correct text
to be in the cell to carry out an overwrite procedure.

•  If multiple cell data is to be deleted, click and highlight these cells,
and press the Backspace key.

Fine Tuning Cell Data

•  Select the cell to be edited or highlight the data in that cell

•  Use the ribbon menu to perform edits such as fonts, font sizes, border
settings, etc.



NECESSARY PROCEDURES TO
KNOW WHEN ENTERING DATA IN

CELLS
Changing Cells Automatically After Entering Data Ensure to press the
Enter key on your keyboard after entering data in a cell to allow Excel to
highlight the next cell for you.

How Excel selects the next can be customized:

•  Go to File
•  Select the tab for Options
•  Select Advanced from the left menu
•  Ensure to check the box for the move selection after pressing
Enter
•  Customize the movement direction in the next dropdown menu

Highlighting Numerous Cells Before Entering Data
•  Set your mouse cursor to the starting point of the cells to be

highlighted

•  Drag your mouse to the desired stop.



Multiple cell highlights allow you to customize a large number of cells
at once.



USING KEYBOARD KEYS CTRL +
ENTER FOR INSERTING DATA IN

MULTIPLE CELLS AT ONCE
•  Highlight the cells to be used
•  Type in the data or formula in the top active cell
•  Press the Ctrl + Enter keys

This action helps to avoid the stress of repeated copying and pasting of
data, especially if similar data is to be entered in more than one cell.

SWITCHING BETWEEN MODES OF CELL IN EXCEL The
current modes of a cell can be seen in the status bar, present at the

bottom of the Excel Window.
Three cell modes exist in Excel:
•  The Ready Mode: This indicates a cell as dormant, awaiting being

activated or selected.
•  The Enter Mode: This mode defines the cell as active to accept

input.
•  The Edit Mode: This mode is initiated when a cell already

containing data is selected.



AUTOMATIC WAY TO INSERT
DECIMAL POINTS IN DATA

•  Navigate to the File tab on the ribbon menu
•  Select Options

•  From the menu on the left, choose Advanced from the Options window
•  Tick the box indicating whether to include decimal places in your data

•  Set the number of decimal points to be included



IMPLEMENTING AUTOCOMPLETE
WHEN ENTERING DATA

AutoComplete simply means Excel gives you a/the suggestion of the word
you are typing while still typing. Common examples occur when typing
days of the week, or months, etc. AutoComplete suggestions also come up
when Excel detects duplication of a word or number already entered
previously. However, do not accept



AutoComplete suggestions in cases of duplication if that same particular
data will no longer be entered.

Implementing this feature can be done by pressing Enter on your
keyboard when Excel brings up the suggestion. The AutoComplete feature
can either be turned on or off by navigating to the Advanced tab from the
File tab.



CUSTOMIZING THE APPEARANCE
OF TEXTS ON NEW LINES IN A CELL

This procedure is also called line breaking. It can be executed by either
selecting the Wrap Text option on the Home tab or by using keyboard keys
Alt + Enter where you want the line breaks to be.



IMPLEMENTING AUTOCORRECT
Numerous options and configurations exist in Excel for AutoCorrect actions
depending on necessity and the type of data being handled. All of these can
be accessed and configured by navigating to the Proofing tab from File
options.

The simplest form of implementing AutoCorrect in Excel works like the
Find and Replace process. What certain inputs are replaced with can be
decided and what suggestions are brought up for them when entering data.



INSERTING FRACTIONS IN EXCEL
CELLS

•  Highlight the cells where these fractions would be entered
•  Select the Dialogue Box for numbers icon in the ribbon menu
•  Choose Fractions from the Number tab on the window that
appears



•  Choose the desired fraction type to be implemented



IMPLEMENTING FORMS WHEN
ENTERING DATA

Using a form to enter data in Excel requires you to first include it in the
Quick Access Toolbar.

•  Make a right-click on any icon on the toolbar and select the option to
customize the toolbar.

•  Select the option for All Commands and click on Forms. Click on
the add button to include it in the toolbar.

•  Select any cell in your worksheet where you want the form action to
take place. Select the Form icon recently added on your Quick Access
Toolbar.





FORMATTING NUMBERS IN EXCEL
The Automatic Number Formatting Option

•  Highlight cells containing the numbers to be formatted
•  Click on the icon for AutoFormat in the Quick Access Toolbar
•  Select the desired template to be applied and select OK



Using the

Ribbon Menu to Format Numbers

•  Highlight the cells to be formatted
•  Select the Dialogue Box icon for numbers in the ribbon menu

•  Choose number formatting option to be applied from the Number tab
window

This process is also how to use the dialogue box known as Format
Cells to determine number formats. The tab to format numbers is housed by
the Format Cells window.

Shortcuts on Keyboard to Format Numbers The Number tab window
can be launched by pressing keys Ctrl + Shift + Number key (any number
at the top of the keyboard).

Also, particular keys can apply certain number formats, e.g.:

•  Ctrl + Shift + ~ keys to apply the General number format
•  Ctrl + Shift + 1 keys to apply the Number format
•  Ctrl + Shift + 2 keys to apply the format for Time
•  Ctrl + Shift + 3 keys to apply the format for the date.



Including Your Custom Numbers in Excel
•  Navigate to the Format cells window and select Custom Numbers

from the Number tab

•  Enter the format type in the box provided and click on OK



An example of a custom format type is
as follows:

Generally, the number formatting types in Excel are of four
components:

•  The POSITIVE component
•  The NEGATIVE component
•  The ZERO component and,
•  The TEXT component

These components are denoted in the above image. Summary
This chapter explained the input types present in Excel and how these

can be customized and formatted. How forms can be used to easily enter
data was discussed, as well as the use of custom numbers to aid data entry.
The cell modes in Excel were also examined and how to work around the



contents of cells using AutoComplete and Autofill which saves time when
entering data having multiple duplication instances were also examined.





CHAPTER 5- CARRYING OUT SIMPLE
OPERATIONS IN YOUR

WORKSHEET



BASICS OF EXCEL WINDOWS
Basic operations that should be known about Excel windows include how
their sizes can be adjusted, movement of the window, how these windows
can be switched and then closed.

Changing Size and Moving the Excel Window
Resizing the Excel window can simply be done by taking your mouse

cursor to the extreme top right of the window and then clicking on the
Minimize icon (usually the middle icon). Clicking on this icon again
maximizes the window.

An Excel Window can be moved about after being minimized by
holding down and dragging the title bar of the window with the left button
of your mouse.

Switching Among Multiple Excel Windows
Before you can switch windows or workbooks in Excel, these windows

must first be opened. A simple keyboard shortcut is all you need to perform
this switching operation:

Use Ctrl + Tab or Ctrl + F6.



Navigating to the View tab and then selecting the drop-down option to
switch between windows can also be used.



Closing Excel Windows
Move your mouse cursor to the Close icon at the top far right of the

workbook.



ACTIVATING EXCEL WORKSHEETS
The VBA module in Excel can be used to activate worksheets. Press key
Alt + F11 to open the VBA code editor window. While in the window, enter
the following code:

Sub Activate_Sheet() Worksheets(“Project1”).Activate ‘Or
Sheets(“Project1”).Activate End Sub
This code activates Excel sheets based on the name of the sheet. You

can also activate the sheet by referring to the sheet number with this code:
Sub Activate_Sheet_BasedOnIndex()
Worksheets(1).Activate ‘Or
Sheets(1).Activate
End Sub INCLUDING ADDITIONAL WORKSHEETS IN YOUR

WORKBOOK
Above the status bar in the Excel Window, click on the + icon beside

the default available sheets to create new sheets. As many sheets as wanted
can be added to your workbook.



The Insert menu can also be used in the Home tab. Just select the
Insert drop-down menu and choose the option to insert new sheets.



DELETING
EXCESS OR

UNWANTED WORKSHEETS
Make a right-click on the worksheet to be deleted and select the delete

option. You can also navigate to the Delete menu in the Home tab and then
select the option to remove the sheet. Ensure that you’re on the sheet to be
deleted when using the Delete menu option.



CHANGING THE NAME OF
WORKSHEETS IN EXCEL

•  Make a right-click on the worksheet to be renamed and select
the

Rename option

•  Enter the desired name

You can also make double-click on the sheet number above the status
bar to perform the renaming process.



REARRANGING SHEET
ARRANGEMENT IN A WORKBOOK

•  Make a right-click on the worksheet to be moved

•  Select the Move option and then select a desired direction from the pop-
up dialogue box.

Another method is to simply hold and drag the desired sheet with your
mouse to your wanted position.



SHOWING AND HIDING
WORKSHEETS

•  Right-click on the desired sheet and select the option to either hide or
unhide the worksheet.

The Format tab in the Home menu can also be used. Select the option
to hide or unhide from the menu and select appropriately from the next
attached menu.



ADJUSTING
THE EXCEL WINDOW RESOLUTION

OR VIEW
Increasing the View Size of Your Workbook

•  Excel workbooks and windows can be made larger by zooming in on
the screen. At the bottom of the window, beside the status bar is a zoom bar
that can be dragged to zoom in and out of the window.

•  The View tab can also be used where you can enter zoom values in
the Zoom box, or select options from the dropdown menu.



Making Worksheets Visible in Several Windows

•  First, open a workbook and then navigate to the View tab

• 

Select the option to open a new window.
•  Select the worksheet to be opened in every new window you
open

•  Select the option to arrange these windows in the View tab after opening
all desired worksheets

•  Pick a suitable view arrangement

Checking Worksheets in a Side-by-Side View

•  First, open a workbook and then navigate to the View tab
•  Select the option to open a new window.
•  Select the worksheet to be opened in every new window you
open



•  After opening all worksheets, select the option to open these
worksheets beside each other.

•  You can also scroll through both of the worksheets by turning
on



the option to scroll synchronously. Dividing Worksheets Windows
into Sections First highlight the cell where the splitter would start from,
then go to the View tab and select the Split option

Freezing Actions in Excel Worksheets
Rows, panes, and columns in Excel can be frozen to retain their view

and content. Simply select the option for freezing panes in the View tab and
select the desired option.



Using the
Watch Window
•  Choose the cell to be watched and then navigate to the
Formula

tab

• 

Select the option for watching a window



•  Select the option to add a watch to the desired cells
•  Choose these cells in the dialogue that appears and select Add



USING ROWS AND COLUMNS
Inputting Columns and Rows in Worksheet

•  Select the point where the new row or column is to be inserted

•  Navigate to the Insert menu in the Home tab and select a suitable
insert option

Erasing Columns and Rows in Worksheet
•  Highlight the row or column to be deleted and make a rightclick click

•  Select the Delete option



Alternatively, navigate to the Delete
menu in the Home tab and choose a suitable delete option. Adjusting the
Size of Columns and Rows in Worksheet

•  Take your cursor to the edge of the column or row to be resized and
ensure the cursor changes to the scaling arrow

•  Drag the row or column to the desired size

The Format menu in the Home tab can also be used. Select this menu
and choose a suitable option to adjust or AutoFit row and column size.

Showing and Hiding Columns and Rows in Worksheet

•  Highlight the row or column to be removed or put into view

•  Navigate to the Format menu and select the appropriate option for
hiding or viewing rows and columns



You can also make a right-click on any row and column to either
remove or put them in view.

Summary
This chapter discussed and itemized how basic and easy operations can

be carried out in Excel to help understand better how to navigate



around worksheets and workbooks. Also, multiple options and
procedures on customizing your worksheet view, rows, and columns to
decide what you see and how you see them were examined.





CHAPTER 6- USING RANGES AND
TABLES IN EXCEL CELLS AND

RANGES SELECTION
Selecting cells in ranges or blocks makes simultaneous input of data into
these cells possible. This selection can easily be done by a continual press
of your mouse’s left button to drag and select desired cell ranges.
Alternatively, the Shift key can be pressed down while you use the arrow
keys or mouse to select a cell in any direction.



Highlighting Full Rows and

Columns
Two ways exist to do this, you can either:

•  Click on the row number or the column letter

•  Use the name box to enter the row number or the column letter to be
selected e.g. C:C to select column C, 2:2 to select row 2, B:F to highlight
columns B to F, etc.

Highlighting Cells Having Ranges That Are Noncontiguous or Non-
adjacent

Highlight the first set of cell ranges you need, hold down the Ctrl key
on your keyboard and then use your mouse to select the next ranges of cells.



The complete workbook can also be highlighted by clicking on the
corner icon beside the row and column.

Highlighting Ranges in Multiple Worksheets
•  Navigate to the tab where you have your sheets listed in the Excel

window. This tab is usually just above the status bar.
•  Press down the Ctrl key on your keyboard and use your mouse to

select additional sheet(s)
•  In the currently opened sheet, select desired cell ranges. This action

highlights this cell ranges both on the opened sheet and on the previously
selected worksheets.

Highlighting Particular or Special Cells The Conditional
Formatting menu is used to highlight specific cells in Excel.

•  First, select the cell ranges to which the formatting would be applied
(this is usually your data area).

•  Navigate to the Conditional Formatting menu in the Home
tab
•  Select the option for highlighting rules in cells
•  Select the option to specify text rules to be checked for

•  Type in the word Excel should look for to highlight the cells
containing such word in the pop-up box

•  Select OK

•  A customized rule for formatting can also be defined by selecting the
New Rule option in the Conditional Formatting menu.

Highlighting Cells by Search Action



•  Highlight the cells or data where this action will be applied
•  Navigate to the Conditional Formatting menu in the Home
tab
•  Select the option to create a new custom rule

•  Select to implement a formula for the formatting operation in the
dialogue box that appears

•  Enter the corresponding formula related to your previously selected
cell, e.g. =A4=$B$1

•  Select the Format button and then define how the formatting



would be displayed in the next tab

•  Click on OK

You can now type and search keywords in the B1 cell. Corresponding
cell search results would then be highlighted as configured.



MOVING AND COPYING ACTIONS
FOR CELL RANGES

Using the Ribbon Menu for Copying
•  First, highlight the ranges of the cell containing the data to be copied
•  Navigate to the Home tab on the ribbon menu and select the copy

icon

•  Select the cells where you want the copied data to appear
•  Select the option to paste on the ribbon menu

Using Shortcut Keys for Copying
•  First, highlight the ranges of the cell containing the data to be copied

•  Hold down key Ctrl + C on your keyboard
•  Select the cells where you want the copied data to appear
•  Press Ctrl + V keys on your keyboard to paste the data

Employing Shortcut Menu Commands for Copying Data
•  First, highlight the ranges of the cell containing the data to be copied

•  Make a right-click to bring up the shortcut menu
•  Select the Copy option



•  Select the cells where you want the copied data to appear
•  Make a right-click on these newly highlighted cells and select
the

Paste option
Using the Drag Arrow Technique for Copying

•  Highlight the ranges of the cell containing the data to be copied

•  Place your mouse cursor at the edge of the highlighted cells for the
move cursor to come into view

You can then drag and drop the cells in the desired destination



Copying Data to Adjacent Cells Simply select the destination cells
and use keys Ctrl + R



Data Copying Actions from Cell Ranges to Another Sheet
•  Highlight the ranges of the cell containing the data to be copied and

copy them using any desired technique
•  Navigate to the tab containing the sheet list and select the destination

worksheet

•  Paste the copied data in any location on the opened worksheet

Using the Clipboard for Pasting Action
A simple way to carry out this process is by using Ctrl + V to paste

previously copied data in the Clipboard to desired cells. But to use multiple
copied data in the Clipboard:

•  Navigate to the Home tab and
select the Clipboard icon to open its dialogue box



•  Select the data needed in the Clipboard list

Pasting Data with Unique Techniques
•  The unique or special pasting option in Excel copies every attribute of

the selected cell. It pastes data along with every formatting



previously applied.
•  After selecting and copying your data to the clipboard, navigate to the

Paste button in the Home tab
•  Select the drop-down icon below the button to see additional paste

options to configure how your data gets pasted
•  You can then also select the option to paste your data in special forms.

Keyboard shortcut Alt + E + S + V can also be used.
These actions open the Excel dialogue box for special pasting

configurations.



PASTING DATA
WITH THE PASTE DIALOGUE BOX



Executing Mathematical Operations without Formulas
•  Highlight the cells containing the data on which a mathematical

operation is to be performed
•  Open the dialogue box for pasting using either the ribbon menu or the

keyboard shortcut

•  Select any needed mathematical operation from the dialogue
box



How to Skip or

Ignore Copied Blank Cells and Spaces
In the paste dialogue box, select the box indicated to ignore blanks and

choose the OK button
Transposing Ranges
This gives the inverse of copied data. It can be expressly seen when

dealing with Boolean results. To transpose copied ranges; in the paste
dialogue box, select the box indicated to transpose ranges and choose the
OK button.



APPLYING
NAME ATTRIBUTES IN RANGE

OPERATIONS
Giving names to ranges of cell help to point to them when executing
formatting or mathematical operations.



HOW TO ASSIGN NAMES TO RANGES
Using the Name Box



•  Highlight the ranges to be named

•  Navigate to the box for names beside the formula bar and type in your
desired name

•  This name is applied to the entire workbook for that cell range.

Employing the Dialogue Box for Assigning New Range Names
•  To restrict range names to only a particular worksheet, use this option

to define a range name in the Formula bar.
•  First, select the cell range to be named and navigate to the option to

define a name in the Formula bar
•  In the dialogue box that appears for new names, enter an appropriate

name and set a restriction level for the name

•  Select the Ok button

Using the Dialogue Box for Selection

•  Highlight the whole data you have on your worksheet
•  Navigate to the option to create a selection in the Formula bar

•  When the dialogue box for “Create Names from Selection” is
opened, select where a name should be chosen from in the highlighted data



This technique chooses names for ranges from what you have on your
worksheet. Range names do not support blank spaces; they are usually
replaced with underscores.



WORKING WITH NAMES IN RANGES



In case you have a lot of range names already created in your worksheet,
these names can be edited and managed using the Manager for Names in
the option for defined names found in the Formula tab. Keyboard keys
Ctrl + F3 can also be used to access this Manager.

While in this Manager, you can select to add new names, edit existing
names, or even delete them. Select the OK button to save all changes.



GIVING COMMENTS IN CELLS
To include comments in your cells in Excel, simply right-click on that cell
and select the option for inserting comments.

Formatting Cell Comments

•  Right-click on the particular having the comment to be
formatted
•  Select the edit option

•  Highlight specific words in the comment to be formatted or select the
edge of the box housing the comment to format the entire comment.



Configuring the Shape

of the Comment Box

•  Right-click on the particular having the comment to be
formatted
•  Select the edit option



•  Select the edge of the box housing the comment

•  Choose the option to edit shape in the Quick Access Toolbar and
select the desired shape

•  Make a click outside the comment box to apply changes

Reading Cell Comments

•  Navigate to the Review tab on the ribbon menu

•  Select the option to show every comment. This option displays all
available comments in the entire workbook.

•  To remove these comments from view, click again on the previous
option.



Hiding and Un-hiding Cell

Comments

•  Right-click on the particular cell having the comment
•  Select the option to either hide or show the comment

Editing Cell Comments Following the
procedure for formatting cell comments, you can use the font menu on the
ribbon tab to make all edits to comments.

Erasing Cell Comments Right-click on the particular having the
comment and select the option to delete the comment



USING TABLES IN YOUR
WORKSHEET

Excel tables can be quite tricky because the worksheet itself already looks
like a table. After paying careful attention, however, users find out
implementation of Excel tables is not tasking.

Getting Familiar with the Layout of the Excel Table Header Rows
in Excel Table

The header row in the Excel table is present at the top row of the table.
It holds the name of the table column. Header rows can be easily created by
freezing these panes on the View tab. It is good practice to add color to your
header rows to set them apart from the body of the table.



The header row can also be hidden or shown by selecting the table and
navigating to the Design tab in the Table Tools menu. Select the option for
this configuration.

The Table Body This is the area below the header rows where you can
enter your data.

The Row for Summing Operations
A row to perform summing operations can be added to your table by

navigating to the Design tab in the Table Tools menu. Select the box to
include this in your table.



Changing the Size of

Tables
Selecting the table and placing your mouse cursor on the enclosing line

for adjusting the size of the table is all you need to do. Simply ensure your
cursor changes to the double-edged arrow before dragging the resizing box.



CREATING EXCEL TABLES
•  Highlight a cell as the starting point of the table



• 

Navigate to the Insert tab and select the option for tables
•  Determine the range of cells across which the table would span
•  Indicate if your table contains headers

•  Select OK when done



ADDING DATA TO YOUR CREATED
TABLE

Select cells and enter your data. Both texts and number values can be
inserted.



FILTERING AND SORTING
OPERATIONS IN EXCEL TABLES

Sorting Operations in Tables

•  Select the drop-down icon for filtering and sorting in the Home
tab
•  Select a sorting option in the available menu



Filtering Operations in

Tables

•  Select the drop-down icon for filtering and sorting in the Home
tab
•  Select the Filter option

This selection puts an arrow beside your column headings. Click on this
arrow to perform filtering operations according to the provided menu.

Performing Filtering Operations Using Table Slicers
•  Navigate to the Design tab in the Table Tools menu and select the

option to insert a table slicer
•  Tick the boxes containing your table header to select the fields to be

filtered.



•  Click on OK when done

Configuring the Appearance of Your Table
Select specific areas or fields in your table to edit the font or add a

background or font color. These changes can be made on the Home tab.

Summary



This chapter explained the operations that can be carried out in Excel
cells according to ranges. Various techniques of selecting and copying data
in cell ranges, the addition of comments, how they can be edited and
configured were also discussed. Creation of Excel



tables, their layouts, and how simple operations such as filtering,
sorting, editing the table appearance was examined.





CHAPTER 7 -FORMATTING YOUR
WORKSHEETS

Formatting Worksheets Using Tools from the Home Tab
The ribbon menu of the Home tab is the most common way to format

worksheets. Numerous formatting options are accessible in this tab.

Formatting Worksheets Using the
Mini Toolbar



The shortcut menu that comes up by right-clicking on cells or items
holds some formatting options for your worksheet.

This mini toolbar holds the following tools for formatting:

•  Font tools
•  Alignment tools
•  Number tools
•  Clipboard tools

The Quick Access toolbar also holds formatting tools for your
worksheet. Not all commands are however present by default on this
toolbar, leaving you to manually add them when needed.

Formatting Worksheets Using the Dialogue Box for Formatting
Cells



The dialogue box for cells formatting can be accessed by selecting the
option for cell formatting in the Home tab. This dialogue box holds several
tabs to format numbers, alignment, font, etc.



CARRYING OUT FORMATTING
OPERATIONS IN YOUR WORKSHEET

Changing Fonts in Your Worksheet
Select any desired font from any of the tools previously highlighted.

Font style and font sizes can both be formatted. You can also make your
texts bold or italicize them during this formatting process.



Formatting Text

Alignments
This formatting operation allows you to decide how you want your data

to appear and how they are arranged.
Alignment in Horizontal Direction
Three options exist for horizontal alignment of worksheet text or data:

•  Left alignment
•  Center alignment
•  Right alignment



Alignment in Vertical Direction Three options also exist for vertical
alignment of worksheet text or data:

•  Alignment to the top
•  Alignment to the middle
•  Bottom alignment

Text Wrap Formatting
This can simply be done by selecting the option to wrap texts in the

Excel Home tab. This formatting option allows all text to be made visible
in a cell.

Worksheet Merge Formatting First,
select the cells to be merged and then navigate to the merge option drop-
down menu in the Home tab



Aligning Texts to Angles

Select the drop-down menu to change text orientation. This menu gives
you options to rotate your worksheet texts in directions suitable to your
data.



ADDING
COLORS AND SHADES TO YOUR WORKSHEET

You can add color to your worksheet background or fonts. Select the
appropriate color icon under the font menu. The additional color option can
also be used to get access to a variety of colors.



INSERTING
BORDERS AND LINES IN YOUR

WORKSHEET
•  Highlight the cells to which the borders or lines would be added

•  Select the drop-down menu for borders and select a desired border option
from the displayed list. You can add colors to borders by selecting the
added border and then clicking on the icon for Fill.





IMPLEMENTING CONDITIONAL
FORMATTING IN WORKSHEETS

Defining the Conditional Formatting to be Applied
•  First, highlight the ranges of the cell to which the rule will be applied

•  Select the menu for Conditional Formatting in the Home tab

•  Select any rule as suitable for your data

Implementing the Conditional Formatting Rule for Graphics The
Data Bars

•  Highlight the cells where the formatting rule will be applied.

Ensure not to highlight cells for summing operation.
•  Navigate to the Conditional Formatting menu and select the option

for Data Bars

•  Select the desired fill for your bar



The Scales for Color
•  Highlight the cells where the formatting rule will be applied

•  Navigate to the Conditional Formatting menu and select the option
for scales for color

•  Select the desired fill for your scale

The Sets of Icon

•  Highlight the cells where the formatting rule will be applied

•  Navigate to the Conditional Formatting menu and select the option for
scales for color



•  Select the desired icon for your data

DEFINING FORMULA FORMATTING RULES Formulas can
be defined for conditional formatting by selecting the New Rule option

in the Conditional Formatting menu. Relative and Absolute Cell
References

•  Relative: This method of referencing cells causes a change in the
formatting with reference to the location of the row or column. It is defined
without the dollar sign, e.g.: B1.

•  Absolute: This method of referencing cells does not cause a change
in the cell formatting with reference to the location of the row or column. It
is defined with the dollar sign, e.g.: $B1.



EXAMPLES OF FORMULAS IN
CONDITIONAL FORMATTING

Formula to Select Weekends



•  Highlight the cells where the formatting rule will be applied, usually a
date data

•  Navigate to the New Rule option in the Conditional
Formatting

menu

•  In the resulting dialogue box, select the option to implement formulas
for cell formatting

•  Type in this formula with respect to the cell ranges highlighted:



=WEEKDAY(C3,2)>5



•  Select the Format option and configure how the formatting results
would be displayed

•  Select OK when done



Selecting Rows Depending on Values

•  Select the option to implement formulas for cell formatting in
the

New Rule dialogue box

•  Type in this formula with respect to the cell ranges highlighted:

=$C2=“Bob”
•  Select the Format option and configure how the formatting results

would be displayed

•  Select OK when done



Using Shading for Alternate-rows

•  Select the option to implement formulas for cell formatting in
the

New Rule dialogue box

•  Type in this formula with respect to the cell ranges highlighted:

=MOD(ROW(),2)
•  Select the Format option and configure how the formatting results

would be displayed

•  Select OK when done



Inserting Shading for

Checkerboards

•  Select the option to implement formulas for cell formatting in
the

New Rule dialogue box

•  Type in this formula with respect to the cell ranges highlighted:

=OR(AND(ISEVEN(ROW(A1)),ISEVEN(COLUMN(A1))),AND(ISO
DD(ROW(A1)),ISODD(COLUMN(A1))))

•  Select the Format option and configure how the formatting results
would be displayed

•  Select OK when done



Formatting a Set of Rows to be Shaded
•  After entering your data, you will have to include a cell to denote odd

and even cells to form groups

•  Select the option to implement formulas for cell formatting in
the

New Rule dialogue box

•  Click on Ok and enter this formula in the respective box

=ISEVEN($E2)



=ISODD($E2)

•  Select OK

These formulas are to be entered one at a time.





MANAGEMENT OF RULES FOR
CONDITIONAL FORMATTING

Navigate to the option to manage your formatting rules in the
Configuration Formatting menu. Select the rules to be managed and save
accordingly.

Pasting and Copying of Cells with Rules for Conditional
Formatting

•  Highlight and copy formatted cells, then select the option to paste the
data in a special form



•  Select the Formats option in the resulting dialogue box and select



OK



Erasing

Conditional Formatting Rules
Navigate to the formatting rules manager and select the rule to be

deleted. You can also use the option for clearing rules in the Conditional
Formatting menu.



Identifying Cells

Having Rules for Conditional Formatting
•  Select any cell in your worksheet. You can also select a cell having a

particular formatting rule to find that particular rule
•  Navigate to the Go To option in the Find tab which can be found in

the Edit menu

•  Select Special and then choose the option for Conditional
formats



APPLYING DEFINED STYLES FOR
FORMATTING

Applying the Styles
Styles for cells can be selected and applied from the group for styles in

the ribbon menu. Clicking the drop-down menu icon shows additional style
options.

Configuring Custom Cell Styles



•  In the drop-down menu for additional style options, select the option
to create a new style

•  Supply a name for the new style and set other necessary
configurations

•  Select OK when done

Changing a Style’s Configuration
Make a right-click on the style to be modified and select the appropriate

option



Combining Styles from Various

Workbooks
•  First, keep the specific workbook having the desired cell styles

opened

•  Go to the workbook where these styles would be pasted or
merged

•  Select the drop-down menu for styles and click on the option to merge
the styles



•  Select the appropriate workbook for the styles in the resulting
dialogue box



•  Select OK

Using Templates for Managing Cell Styles
Worksheet templates or themes determine how cell styles appear on

your worksheet. It is therefore of good practice to first apply your
worksheet template before using cell styles.



WORKING WITH THEMES FOR
YOUR WORKBOOK

Employing Themes in your Worksheets
Navigate to the tab for Page Layout and select the option for
Themes or Colors



Creating Your

Customized Theme Colors

•  Select the option for you to configure colors in the Colors menu



•  Select your desired colors and click on Save



Summary

Formatting your worksheet helps you to create simultaneous customized
editing. You can determine specific cells to be highlighted based on
formulas or any criteria, even how the highlights appear can be configured
with the Conditional Formatting feature. This chapter explained how you
can do these, along with defined cell styles and worksheet themes. How
styles in multiple workbooks can be merged to further create an appealing
worksheet was discussed and how you can accurately copy cells having
formatting rules with the special pasting feature.





CHAPTER 8 - FILES AND TEMPLATES
IN EXCEL

OPENING NEW WORKBOOKS Use the File menu and select New.
Keyboard key Ctrl + N can also be used for opening new workbooks.



OPENING A SAVED WORKBOOK
Use the File menu and select Open. This opens a window where you can
select saved workbooks from your File Manager. Keyboard keys Ctrl + O
also open this window.

Filtering Name of Files This process can be done using Power Query.
The Power Query can be accessed on the Data tab.



• 

Enter the file path of your folder or use the Browse button
•  Using the window for previewing files, you can select the Load

option to view more file results in your workbook



•  Use the option for transforming data to delete or modify them before
they are inserted into your worksheet

•  When you’re done with necessary modifications in the Power Query
window, select the close button on the ribbon menu.



Selecting Which Files are Displayed
•  Navigate to the Open pane in the File menu to view the list of files

opened recently
•  Select the file you would like to always be on display and right- click

on it
•  Select the option to pin the file from the menu that appears Pinned

Files can also be removed by right-clicking in the file to be removed and
selecting the option to remove them



IMPLEMENTING AUTO-RECOVERY
Recovering Current Workbook Versions

• 

Navigate to the File menu and click on Info from the left menu
•  Select the option for managing the workbook and select the

Restore option, or rather select Compare.



Recovering Unsaved Workbook Instances

•  Navigate to the File menu and click on Info from the left menu

•  Select a version of the autosaved workbook from the Version History
tab



The tab for managing workbooks can also be used to view unsaved



versions of the workbook
Customizing the Auto Recovery Feature

•  Go to the Options tab in the File menu and select the Save
option

•  Select the Minutes section to define time intervals within which
Excel AutoSaves your workbook





USING PASSWORDS TO SECURE
YOUR WORKBOOKS

•  Navigate to the Review menu and select the option for workbook
protection.

•  Enter your password, click on OK
•  Confirm password and select OK

ORGANIZING WORKBOOK FILES Several ways exist to group
and section your workbooks in Excel, among these are:

•  Implement Excel workbook template for easy organization

•  Create a worksheet that holds all crucial data of the workbook. This
avoids the stress and time it would take to filter or search for these data.

•  Implement data sorting

•  Include additional sheets in your workbook to prevent bombarding
and cramming large data into worksheets. Separate data analysis into
different worksheets when necessary.

•  Additional but unneeded data can be kept hidden and then displayed
when called for

•  Use hyperlinks for easy navigation in your worksheet when you have
a large data

•  Employ formula correctly, default functions in Excel can be
implemented.



ADDITIONAL INFORMATION WHEN
USING WORKBOOKS

Additional Options to Protect Your Workbook



1.  

Protection options for files include:

•  Encryption of the file to prevent the opening of the file

•  You can set a password to prevent file modification or access to the
file

1. The protection option for the workbook involves restricting access to
modify the structure of the workbook by specifying a password.

2. Protection for the worksheet involves limiting what users can modify
within the sheet. Worksheets are protected using protection for

worksheets.

Looking Up Glitches or Errors
The error checker in Excel can be accessed in the Formula menu. This

checker enables you to turn on background checking of errors among other
aspects. You can also check for workbook issues by using the issues
checker tab in the Info section under the File menu.



Options for Managing Your Workbook
You can switch between worksheets and workbooks by selecting your

desired sheet from the sheet menu above the status bar, or using the File
menu for opening other saved files. Navigation around the worksheet is also
possible with keyboard keys or the scroll bar.

Worksheets can also be made hidden, named, added, etc. The
application of conditional formatting further helps to customize how your
workbook appears.

Workbook Appearance in Browsers
Navigating to the options for view in browsers in the File menu gives

you multiple options for how your workbook would appear in a browser
during sharing. Some of the view options include:



• 

The gallery display
•  The workbook display

•  The web for Excel display



The Mode for

Compatibility Section
The mode for compatibility in Excel ensures that versions of the

workbook are retained, especially if the opened file was created with a
different Excel version. This mode can be excited by selecting the Convert
option in the Option section under the File menu.

You can also run checks on compatibilities by using the issues checker
tab in the Info section under the File menu.



IMPLEMENTING
EXCEL TEMPLATES IN YOUR

WORKBOOK
Walking Through Templates in Excel

Using default templates in Excel enables you to create consistent and
identical files because you are not the one in charge of some basic
structures of the worksheet. Excel templates already come with some
formatting rules, functions, macros, etc.

Accessing Excel Templates
Selecting the New option in the File menu takes you to the template

gallery. You can also search for a template online. Click on the Create
button to download and use a template. Excel automatically creates a
workbook for you with your selected template.



Editing Excel Templates

•  Navigate to Open in the File menu and select to open your

Documents folder

•  Navigate to the folder for Custom Office Template
•  Select the template you want to modify, make your desired

changes, and then save
MAKING USE OF EXCEL BUILT-IN TEMPLATES Changing



Default Structure of Your Workbook with Excel Templates Inserting
templates in your workbooks automatically changes the structure of your
worksheet.

Reverting Workbooks to Default Structure Excel can be reverted to
its default settings by using the Trust Centre option.



•  Select Options under the File menu and select the settings for

Trust Centre
•  Select the Add-in option on the left menu and tick the box to disable

application add-in

•  Select OK to save changes





CUSTOMIZING YOUR WORKBOOK
TEMPLATES

Designing Your Excel Template

•  First, open a new workbook
•  Select the Save As option in the File menu and click on
Browse

•  Enter a name for the template file and choose to save it as an Excel
template



•  Click on the Save option

Storing Your Created Templates After clicking on Save, you can find
the template you created in this file location on your PC: C:\Users\
<username>\Documents\Custom Office Templates



Implementing Your Created Template in a Workbook

•  Select to open a new workbook
•  Navigate to the Personal tab and select the template



Summary
Templates and the management of Excel files were discussed in this

chapter. You can set passwords or file encryptions to secure your worksheet
or workbook and prevent access and unwanted modifications. Excel
templates also allow you to work with already formatted worksheets and
cells, you also have the freedom to edit and create your templates.





CHAPTER 9 PRINTING OPERATIONS
IN YOUR WORKBOOK CARRYING

OUT SIMPLE PRINTING OPERATIONS
Simply navigate to the Print option in the File menu or use key Ctrl

+ P. When in the print window, make necessary selections and
configurations.

ADJUSTING HOW YOUR WORKBOOK IS VIEWED Default
View



This is the view your workbook possesses by default as a result of a
selected template. This view is chosen as the optimized option for your
workbook by Excel itself.

This default or normal view can be initiated on the View tab by
selecting the Normal button in the ribbon menu.



View Options from

Page Layout Menu
The Page Layout menu holds several options to configure how Excel

displays your workbook. Select the option for Orientation and select
between Landscape and Portrait.

Page margins can also be selected and inserted by clicking on the
corresponding menu in the Page Layout pane. You can also customize your
margins by selecting the appropriate option.

The Preview for Page

Breaks
The button to preview page breaks can be found at the base of the Excel

window, beside the slider for zoom. Select this button and go to your
worksheet to highlight the cell where the page break would be initiated.

Go to the Breaks menu and select the option to insert a page break in
your worksheet. This same menu can be used to remove page breaks.



EDITING SETTINGS FOR PAGE
SETUP

Selecting a Printer



Use the option for formatting printers to select a printer.

Indicating Print Content Select the
menu for the area to be printed in the Page Setup section or use the settings
menu while in the print section. Just click on the

menu labelled for printing sheets that are active to access further
options.



Changing Print Orientation for

Pages
You can change the orientation for pages in the Page Setup section, or

when in the print window.
Indicating Size of Paper Click on the menu indicated Letter to see

additional options for paper size.



Printing Numerous Copies of a File
Indicate the number of copies in the box provided.



Editing Page Margins Select

the margin menu.



Printing Excel Titles

Select the tab to print titles and select the rows and columns to be
repeated.



Scaling

Printing Output
Select the menu labelled for scaling and select an option.



Printing Gridlines Tick the box for

Gridlines in the Excel Page Setup dialogue box.



Printing

Headings of Row and Columns
Tick the box for headings in the Excel Page Setup dialogue box.
Using Background Images

•  First, navigate to Shapes on the Insert menu

• 

Right-click on this shape and select to format
•  Select the option for picture and choose the Insert button in the



resulting dialogue box
•  After inserting, use the slider for Transparency to adjust the picture



USING HEADERS AND FOOTERS IN
YOUR EXCEL FILE

Inserting Excel Defined Headers and Footers Navigate to the Header
and Footer option in the Insert menu. This action opens the Design menu.

When in the Design menu, select between
Header and Footer and choose a header to your taste from available
options.

What Headers and Footers Contain The information in headers
and footers include elements such as:

•  the page number
•  the title of the worksheet
•  exact time and date
•  total page number
•  the workbook file path
•  the name of the workbook
•  a picture that can be resized to a logo



Additional Options in Headers and Footers 1. You can create your
custom headers and footers following these steps:

•  First, select the Header and Footer option in the Insert menu

•  Select the header box and enter the name of your workbook where
indicated

•  Enter the number of the current page in the specified box. To allow
the word Page itself to be shown, right-click on the box and type in Page,
including an ampersand (&).

•  Select the Picture option in the ribbon menu and browse your File
Explorer, insert the needed picture. Excel immediately puts the appropriate
picture code in the header to support your picture.

2.



The Page Setup dialogue box can also be used to add headers and
footers in your worksheet:



• 

Click on the corresponding icon to launch the dialogue box

•  Make necessary configurations in the box, or select a ready-made option

1. You can also close the header and footer by navigating to

Normal view in the View menu.

1. Headers and footers can be deleted by selecting none for both the
header and footer in the Page Setup dialogue box.





ADDITIONAL OPTIONS FOR
PRINTING YOUR WORKBOOK

Using Similar Page Setup Configurations in Multiple Worksheets
Select all these worksheets by holding down the Ctrl key and

highlighting the sheets, then navigate to the Page Setup menu and make
your configurations.

Marking Off Cells during Printing
Removing some cells from printing can be done in any of the following

two ways:

•  Hide these cells

•  Format these cells to blend with your worksheet background, e.g. if
you have a white background for your worksheet, select a white font for the
content of these cells

Marking Off Pictures during Printing
•  Right-click on the picture and select the option for properties and size.



•  Deselect the print box in the Properties menu of the picture.
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Designing

Customized Views for Your Worksheets

•  Navigate to views for your workbook in the View menu

• 

Select the option to add a customized view

•  To apply your customized view, navigate to the corresponding option for
self-built views and select. These views can also be deleted by right-
clicking on them and selecting the Delete option.

Saving Your Workbook as a PDF File

•  Select the Save As option in the File menu

•  In the box indicating the format in which the workbook will be saved,
select the drop-down menu and choose the option for a PDF format.



Summary
Defining and setting how your worksheet appears before and during

printing helps to get the best results for your printed worksheets or
workbooks. This chapter explained how this can be done using both the
View and Page Layout menu. You can also select which cells and pictures
get printed, fit your worksheet to a page for easier comprehension and also
save your workbook in PDF format to facilitate sharing.





CHAPTER 10- REDESIGNING THE
USER INTERFACE IN EXCEL

Customizing both the Quick Access Toolbar and the ribbon menu is a quick
and easy way to upgrade the user interface in Excel. This action puts more
menu, tools, and options within easy reach when working in worksheets.



REDESIGNING THE RIBBON MENU



The ribbon menu can be configured so that menus that tab that you
often use are brought closer, or you hide those settings you don’t use.
Customization of the ribbon allows you to rearrange menus and tabs; you
can also import or customize ribbons. Note that any customization done on
the ribbon menu in Excel is only limited to the application, they are not
applied in other applications such as Word, etc.



CONFIGURATIONS NOT SUPPORTED
IN THE RIBBON MENU

The size of the ribbon, the font, the font size, and the icons cannot be
edited. Slight changes can only appear in these aspects when you adjust the
resolution of your display.



POSSIBLE CUSTOMIZATIONS IN THE
RIBBON MENU

Adding Tabs
•  Right-click on a blank space in the ribbon and select the customize

option

•  Select the option to customize the ribbon the resulting window
•  Select the option to add another tab and click on OK when
done

Adding Groups
•  Right-click on a blank space in the ribbon and select the customize

option

•  Select the option to customize the ribbon the resulting window
•  Select tabs to be added to the new group



•  Select the option for a new group and rename the group by right-
clicking on it

Rearranging the Ribbon Tabs
When in the window to customize the ribbon, select the tabs to be

rearranged and click on the provided arrows.



Resetting the Ribbon to

Default
When in the window to customize the ribbon, select the Reset
option.
Importing and Exporting Custom Ribbon Menu When in the

window to customize the ribbon, select the option to import or export a
custom ribbon.

Summary
Customizing the ribbon menu puts your necessary and frequently used

tab with easy reach. This chapter explained how to configure the ribbon
menu to your taste, and also to revert to the default settings of the ribbon
menu.





CHAPTER 11- INTRODUCTION TO
CHARTS IN EXCEL

Charts are graphic visualization of data. They help you to visualize data as a
diagram, which enhances analysis and also human comprehension.

Format for Excel Charts
Before charts can be created, there must first be input data. After

entering data, you can then select to input any style and type of chart to
convert the data to a graphical representation. Note that editing the data
produces a corresponding change in the chart.

Embedded Charts
Most charts in Excel are embedded. They come on display on a special

drawing layer that can be moved, formatted, and resized. These charts can
be configured by clicking on any part of the chart



and a menu that is contextual comes up from which changes can be
made.

Charts Sheets
These look like a worksheet itself. Only a chart is found in a chart sheet,

and they are labeled like sheets are named, e.g. Chart 4, Chart 7, etc.

Embedded sheets can be moved to chart sheets and vice versa;



•  Select the chart and choose the option to Move the chart from
the

Location menu found in the Design tab under Chart Tools



•  In case of moving embedded charts, choose the option for another
sheet in the Move dialogue box. Provide a new name for the chart if
appropriate

•  For moving chart sheet, choose the Object option and select a
worksheet

•  Click on OK

Elements of Excel Charts

•  Axes
•  Legend
•  Title of the Axis
•  Title of the Chart
•  Labels for data
•  Table of the data
•  Bars for error
•  Gridlines
•  Trend lines, etc.

Limitations of Charts



One main limitation of charts is that they mostly are not as precise about
the data they represent as the raw data itself. Although they make data
visualization easier, they help see how some factors affect events. With the
inclusion of trend lines, viewers can make close to accurate predictions.
They still however can produce wrong information which can mislead
users. Rectifying this to make charts as precise as possible results in the
charts being complex and crowded.



Creating Charts in Excel
After entering your data, navigate to the Insert menu and select the

option for Charts. Here, you can select any chart type that is suitable for
your data by clicking on the option to view all available chart types.

Interchanging Rows and Columns in Charts Click on the chart and
select the option to switch the row and column on the Design menu

Changing Type of Charts Select the
option to change the chart type from the Design menu and select another
chart.

Inserting Chart Layouts
Select a chart layout from the chart group or click on the dropdown icon

for More in the chart menu to access additional options for chart layouts.



Changing Chart

Styles
While in the Design menu, the group for Chart Styles can be selected

from. Likewise, the drop-down icon to view more options can be selected.

Including and Removing Chart Elements

•  Select the chart and click on the + icon

•  Tick any box to include any chart element and untick a box to remove
the element

Formatting Elements in a Chart
Click on the chart element to be formatted and make necessary

configurations either from the shortcut menu that appears on right- clicking,



or use options from the ribbon menu.



EDITING AND
CONFIGURING CHARTS

Resizing and Changing Chart Positions
Click in the chart and take your mouse cursor to the enclosing line

borders around your chart. When the double-edged cursor for resizing
appears, drag with your mouse to the desired size. Likewise, the position of
the chart can be changed by letting the cursor change to the four corner
arrow with which the chart can be dragged to any position.

Copying Charts
Select the chart and use Ctrl + C or right-click and select the copy

option. The chart can then be pasted in any location. Deleting Charts

•  Highlight the chart
•  Navigate to the Home menu



•  Select the
Clear option and click on the option to erase all.



Copying Formatting Rules Applied to a Chart When pasting copied
charts



that are formatted, the Paste Special option can be used to retain all
configurations. Renaming Excel Charts

•  Select the chart and navigate to the Layout menu

•  A box labeled Chart Name would be seen at the edge of the ribbon.
Enter your desired chart name in the box.



Printing

Excel Charts

•  Select the chart to be printed and press Ctrl + P to open the
Print

menu

•  Under Settings, select the option to print the highlighted chart



TYPES OF
CHARTS IN EXCEL

Column Charts
These charts represent data with vertical bars. They are used when

comparing groups of data. To use column charts:



•  Highlight your data

•  Select the option for Columns and then Clustered Columns in the
chart menu.

Bar Charts
They are also used for comparing a group of data. They differ from

column charts because they represent data with horizontal bars. To use
column charts:

•  Highlight your data set

•  Select the option for Columns and then Clustered Bars in the chart
menu.



Line Charts
These are used for showing data progression or trends. To use line

charts:

•  Highlight your data
•  Select the option for Lines and then select any style for the
chart.



Pie
Charts



These are used for showing data in sections. To use pie charts, highlight
your data and then select the option for Pie Charts.

Scatter Plots or XY Charts



These are used when finding how X affects Y in a data series. To use
scatterplots, highlight your data and select the option for Scatter.



Area Charts

These represent data in filled colored areas. They can be inserted by
selecting the Line chart option and then choosing Area under area for 2-D
options.



These charts are used to compare multiple items in 2-D representation
in a data set. They are otherwise known as Spider Charts. Radar charts can
be added to your worksheet by selecting the option for additional charts in
the Insert menu and choosing appropriately after highlighting your data.



Surface Charts

These represent your data in clear 3-D formats. They can be inserted by
selecting the option for additional charts in the Insert menu and choosing
appropriately after highlighting your data.



Stock Charts
Just as the name implies, they are best used for representing stocks in a

data set. They can be inserted into your worksheet following the same
procedure as Surface charts.

Bubble Charts
Highlight your data and select the option for additional charts and select

Bubble charts.



OTHER TYPES OF CHARTS IN EXCEL

Histogram
This chart is used to show how often an event or item occurs in a data

set. Insert histograms by selecting the option for Static Charts on the
Insert menu and then choose the Histogram option. Do not forget to
highlight your data. You can format the bars by right- clicking on the chart
and selecting the format option.



Pareto Charts
These can be inserted by highlighting your data, selecting the option for

Static Charts on the Insert menu, and then choosing the Pareto option.
These charts are for showing important parts of a data set.

They contain a line graph and bars.
Waterfall Charts

•  Highlight your data
•  Select the option for Stacked Columns in the Insert menu
•  Right-click on the inserted chart and select the format option



•  Select the options to remove fill and borders in the Format

window
Waterfall charts show graphically how data flows in a data set



. Box

and Whisker Charts
These show specific values of your data. Insert box and whisker charts

by first highlighting your data, selecting the option for Static Charts on the
Insert menu, and then choosing the appropriate option.



Sunburst Charts



•  Highlight your data
•  Navigate to the option for charts which are Hierarchical
•  Select Sunburst charts

Treemap Charts



•  Highlight your data
•  Navigate to the option for charts which are Hierarchical
•  Select Treemap charts

Funnel Charts

•  Highlight your data
•  Navigate to the icon for Waterfall charts
•  Select Funnel charts



Map

Charts

•  Select your data
•  Navigate to the Maps option and select Filled Maps



Summary
Charts in Excel enhance visualization and representation of data in an easily
comprehensible format. This chapter discussed charts and their elements, as
well as how these charts can be customized,



modified, and managed. The various types of charts available in Excel
were examined, alongside how these charts can be inserted into your
worksheet.





CHAPTER 12- CREATING EXCEL
CHARTS WITH ADVANCED

TECHNIQUES



CHOOSING CHART ELEMENTS
Chart elements were introduced in the previous chapter. They are parts of a
chart that adds information when inserted. They can be added and removed.

•  With the Mouse

Chart elements can be selected with the mouse simply by clicking on
them. To confirm that the selection was done, a resizing box appears around
it. Also navigating to the chart element selection group in the Format menu
shows your current selection of a chart element. Also, hovering your mouse
over charts shows you the name of the chart element.

•  With the Keyboard

The arrow keys are all you need to select elements of a chart with your
keyboard. Selection can be confirmed using the chart element selection
group in the ribbon.

Controls of the Chart Elements
Right-clicking on a chart brings up the chart shortcut menu that contains

a drop-down menu of this list of the element present in the chart. It also
shows the current element selected. Use this drop-down menu to select any
of the present chart elements.



EDITING ELEMENTS IN A CHART
Using the Format Menu

•  Navigate to the Format menu

•  Select any element of your chart from the corresponding drop- down
menu in the chart element selection group.

•  Select the option to format the selection below this dropdown menu



Using Customization Buttons of the Chart These
buttons are present beside the chart. They provide a quick and navigation to
select chart elements and also format the chart.

Using the Ribbon Menu

•  Select a chart element
•  Navigate to the ribbon menu and select formatting options such
as

Fill, Outline, Effects, and also various styles for shape.

Using the Mini Toolbar
Make a right-click on a chart element and select the format option from

the pop-up menu.





CONFIGURING THE AREA OF A
CHART

•  Select the area of the chart either from the chart or from the

Format menu



•  Click on the option to format the selection and configure it as desired



CONFIGURING THE PLOT AREA OF
A CHART

•  Select the plot area of the chart either from the chart or from the

Format menu
•  Click on the option to format the selection and configure it as desired
EXCEL CHART TITLES Chart titles describe what a chart

represents. They can be added and removed.

•  Add chart titles by navigating to the Design menu

•  Select the layout option for charts and click to add elements to your
chart

•  Select the option for Chart Titles and type in a title in the box that
appears

Edit chart titles by right-clicking on the Chart Title box and selecting
the Format option.



Chart titles can be removed by deselecting them from the list of added
chart elements. You can also right-click on the chart title and then select the
Delete option.



EXCEL CHART LEGENDS
Legends add more details in charts. When multiple data are having similar
representations, legends are used to differentiate them, especially with color
codes.

Legends can be added and removed from your chart by selecting or
deselecting them on the chart element list. Their positions can also be
changed similarly. You can also use the Design menu to access and perform
these operations on chart legends. Further settings and configurations can
be done by selecting the tab for additional options.



GRIDLINES IN
EXCEL

CHARTS



Gridlines add more detail and precision to charts. They can be added
and configured by selecting them on the chart element list.





FORMATTING EXCEL CHART AXIS
Editing the Value and Category Axis To edit a chart’s X or category axis
values:

•  Make a right-click on the chart and choose the option to Select Data

•  Click on the button to Edit the horizontal axis in the resulting
dialogue box



•  Select or enter the cell range containing the new values for the axis
and click on the OK button

To edit a chart’s Y or series axis values:

•  Make a right-click on the chart and choose the option to

Select Data
•  Click on the button to Edit the values for the vertical series in the

resulting dialogue box
•  Select or enter the cell range containing the new values for the axis

and click on the OK button



To configure the axis

intervals:

•  Select and right-click on the axis to be edited
•  Select the option to Format the axis
•  Edit the values for the axis minimum and maximum entries



CHART DATA SERIES
Hiding or Removing a Data Series in Charts

•  Select the option to Filter your chart

•  In the Value menu in the resulting dialogue box, deselect the data you
wish to hide or remove



•  Click on the Apply button

Inserting Data Series in Charts The Select Data dialogue can be used
for this procedure as previously explained in how to edit the values for your
axis. SWITCHING SERIES DATA

Switching Data Range by Moving the Range Outline

•  Highlight the chart

•  Select the range of the new data and drag it to the chart Switching
Data Using the Dialogue Box for Editing Series and the Formula for
the Series

•  Make a right-click on the chart and choose the option to

Select Data
•  Click on the button to Edit the values for the vertical series in the

resulting dialogue box for the editing series



•  Select or enter the cell range containing the new values for the axis
and click on the OK button



The series formula can be edited in

this dialogue box:



SHOWING LABELS OF DATA IN
CHARTS



•  Select the chart
•  Navigate to the Layout menu and select the button for Labels

•  Click on this button and select a position for the label from the menu



MANAGING LOST DATA IN EXCEL
CHARTS

•  Make a right-click on the chart and choose the option to

Select Data
•  Select the option for Hidden Cells at the base of the resulting

dialogue box

Excel has three ways to manage omitted data, these are:

•  Gaps



• 

Zeros
•  Line connection of data points



ADDING
ERROR BARS AND TRENDLINES IN

EXCEL CHARTS

Error Bars:
Trendlines:



These can be
added by clicking on the Chart Element button or the + icon beside charts
and then selecting from the provided list.

To select Error Bars:



To select trendlines:



DESIGNING
COMBINATION CHARTS



These charts bring together different data sets in one chart for easy
comparison and visualization. To create combination charts:

•  Highlight your data

•  Navigate to the ribbon menu and select the option for a Combo
Chart

Existing charts can also be changed to combination charts following
these steps:

•  Select and right-click on your chart



• 

Choose the option to edit the series chart
•  Select the Combo option from the left menu
•  Tick the box beside the second drop-down menu

•  Select the second drop-down menu and select the option for a line chart

•  Click on OK



SHOWING TABLES OF DATA
•  Select your data for which the table of data would be created

•  Navigate to the What if button and select the option for a table of data

•  Enter the cell range where the table would be inserted

•  Select the OK button



DESIGNING
TEMPLATES

FOR EXCEL CHARTS
•  Right-click on the chart you create, customized, and wish to save as a

template

•  Select the option to save the chart as a template

•  In the Save dialogue box, enter a name for the template and select the
Save button.

Summary
This chapter explained the various ways to insert elements in your chart

and also modify them. Configuration of the chart and plot area, using chart
titles, legends, gridlines, and axis were also examined.



Editing the plotted data series, the inclusion of additional information in your chart, and also
turning your edited chart into a template you can use at any time can also be done with Excel charts





CHAPTER 13 - USING SPARKLINES IN
EXCEL

Sparklines are similar to trendlines. They look like simple lines without the
whole chart background, making them easy to include in



worksheets.



TYPES OF SPARKLINE
• 

Line sparkline
•  Column sparkling

•  Win or loss sparkline



HOW TO CREATE SPARKLINES
•  Highlight your data
•  Navigate to the Insert menu and select the Lines option in the

Sparklines group

•  Enter necessary cell ranges in the Sparkline dialogue box and select
the OK button.



CONFIGURING EXCEL SPARKLINES



Adjusting Size of Sparklines
•  Select the cell containing the sparkline and drag to cover additional

cells

•  Navigate to the ribbon menu and select the Merge option for a better
look

Managing Missing Data in Sparklines

•  Select the sparkline
•  Navigate to the Design menu and select the Edit option
•  Select the option for missing data on the drop-down menu

•  In the resulting dialogue box, select how you want the missing data to
be represented



Switching Sparkline Style
•  Select the sparkline

•  Navigate to the Design menu and select the style of sparkline desired



Switching Sparkline Type

•  Select the sparkline

•  Navigate to the Design menu and select the type of sparkline desired
Customizing Color and Weight of Sparklines
•  Navigate to the options list beside the Styles group and select the

color option
•  Select the option to configure the sparkline weight below the color

choices



Adding Markers to

Sparklines
Navigate to the group for Show in the Design menu and select any of

the boxes
Configuring the Sparkline Axis



•  Select the sparkline
•  Select the option for Axis in the Design menu
•  Choose the option to customize the axis values

•  Enter a value in the resulting dialogue box and click on the OK

button
Faking a Line of Reference in Sparklines
Select the option to display the axis in the Axis drop-down list from the

Design menu



Grouping and Un-grouping

Sparklines

•  Highlight multiple sparklines
•  Select the option to Group or Ungroup them in the Design
menu



Removing

Sparklines

•  Highlight the sparkline to be deleted
•  Select the option to clear the sparkline from the Design menu



INDICATING DATE AXIS IN
SPARKLINES

Select this option for the date axis in the Axis drop-down list from the
Design menu. The date axis is used for indicating inconsistent time ranges
in a data set.



SETTING
SPARKLINES

TO AUTO-UPDATE
Sparklines do not need any configuration to auto-update. They

immediately and automatically adjust themselves to correspond to input
data.



SETTING RANGES THAT ARE
DYNAMIC IN SPARKLINES

•  Navigate to the Axis drop-down list in the Design menu

•  Select the option to set identical axis values for both horizontal and
vertical options



Summary

This chapter focused on sparklines, how they can be added, styled, and
configured. Sparklines give additional and graphic details to data changes in
data sets. They are easier to visualize and understand as they can represent
single data in their respective columns.





CHAPTER 14 -DATA ANALYSIS USING
CUSTOMIZED SHAPES AND NUMBER

FORMATS
Number formats define and specify how Excel should treat your numeric
data. Rather than using plain numbers, number formatting indicates what
each number represents, percentage, currency, etc.



NUMBER FORMATTING IN EXCEL
Using Keyboard Shortcut Keys

Ctrl + Shift + ~ keys to apply the General number format
Ctrl + Shift + 1 keys to apply the Number format
Ctrl + Shift + 2 keys to apply the format for Time
Ctrl + Shift + 3 keys to apply the format for the date, etc.
Using the Dialogue Box for Formatting Numbers

•  Navigate to the Home menu and select the drop-down in the

Number menu group



•  The few quick available options below the drop-down can also be
used

•  The icon for the Number dialogue box can also be clicked to access
more options for configuration



ADDITIONAL FORMATTING
IN CUSTOM

NUMBERS
Configuring Numbers in Millions and Thousands When in the

dialogue box for formatting numbers, select the option for Custom
numbers.

In the provided box, enter the following:



•  0, “K” for formatting numbers in thousands
•  0,,“M” for formatting numbers in millions
•  0,,,“B” for formatting numbers in billions

Removing and Hiding Zeros

•  Navigate to the File menu and select Options from the left tab
•  Select Advanced



• 

Deselect the box to show zeros in the options for Display
•  Select OK

Applying Colors to Custom Numbers
A list of specified colors is provided in Excel to include when

configuring custom numbers, these are:
Black, Green, White, Blue, Magenta, Yellow, Cyan, Red
These colors must be in parenthesis when using them to format custom

numbers. An example includes:
[Blue]$#,##0.00; [Red]-$#,##0.00; [Black]”-“; [Magenta]@

Formatting Excel Date and Time Select the option for Date in the
dialogue box for formatting numbers.





INSERTING SYMBOLS IN DATA
•  Navigate to the Insert menu and select the option for Symbol in the
Symbols menu group

This opens the various available symbols and special characters you can
put in your data.

•  Click the OK button after selecting your needed symbol.



Also, the Alt key on your keyboard can be used with any of the
Number keys to insert common symbols.



INSERTING ICONS AND SHAPES FOR
DATA GRAPHICAL
REPRESENTATION

Inserting Shapes in Your Data
Navigate to the Insert menu and select the option to insert Shapes

Adding Graphics for SVG Icons
Icons can be easily added to your worksheet from the Insert menu. You

can also add SVG (Scalable Vector Graphic) files or icons to your
worksheet by selecting and inserting them from your PC’s File Explorer.
The technique of dragging and dropping the icons into your worksheet can
also be used.

Icon list can also be accessed from the Conditional Formatting
menu in the Home menu.



Editing Excel

Icons and Shapes

•  Select the icon or shape

•  Navigate to the Format menu where you can change colors, insert
and edit borders, etc.



IMPROVING REPORTS IN EXCEL
USING SHAPES

Designing Shapes with Containers
Add containers to your worksheet by selecting the Container option in

the Insert menu. The containers can also be formatted by selecting them
and using the Format menu

Shapes can be added to an empty container and vice versa. To add a
container to an existing group of shapes:

•  Select and right-click on any of the shapes

• 

Choose the option to insert a container

•  To make shapes one with the container, right-click on a shape and select
the option to include it in the container.

Layering and Grouping Shapes for Space Management Selecting
the shape

•  Navigate to the Format menu and select the Group option in
the

Arrange menu group

The Arrange menu group
holds various options for organizing your shapes to improve the
presentation of your worksheet. Designing Custom Infographics Using
Shapes



• 

Prepare your data and insert a clustered column chart

•  Select any cell in the worksheet that is empty and insert a shape either
from the Excel menu or from your File Explorer

•  Choose to format this shape by adding a fill color



•  Copy and paste this shape twice to make four shapes

•  Choose to format the newly pasted shapes and select the option not to
include a fill color

•  Copy the newly formatted shapes, select the bigger bars of your
clustered column chart and paste the copied shapes



•  Click twice on any of the newly pasted shapes to open the
Format

dialogue box



•  Edit the
width for the gap to zero



•  Copy and paste the fill colored shapes in the place of the shorter bars
on your chart

•  To format this paste action, click twice on any of the newly pasted
shapes

•  Select the option for stacking and scaling





•  To correct the resulting incomplete shape, click twice on the y axis in
your chart

•  Edit the Maximum and Minimum values for the axis to 1 and
0



•  Click twice again on the series and select the overlapping option for
the series to edit it to become 100% Following these steps gives to add
custom infographics to your worksheet.



DESIGNING DYNAMIC CUSTOM
LABELS IN EXCEL

•  Select the chart and make a right-click on it
•  Choose the option to include a label for your data

•  In the format dialogue box for labels, select the box to choose labels for
your data from cells in your worksheet

•  Select or enter the cell ranges and click on the OK button



DESIGNING
PICTURE

LINKS

•  Highlight the cells containing the picture and copy

•  Select the cell where you want the link to appear and rightclick on it

•  Select the Paste option from the ribbon menu
•  Choose the option for pasting as a picture
•  Select the option for a link



INSERTING WORDART AND
SMARTART

Basics of SmartArt

1. Inserting SmartArt

• 

Navigate to the Insert menu and select the SmartArt option
•  Choose a style in the gallery and enter your text

1. Adding and Deleting Shapes in SmartArt



•  Select your inserted SmartArt and navigate to the Design menu

•  Select the option to include a Shape under the group for creating graphics

1. Formatting SmartArt Colors

•  Select the SmartArt
•  Select the option for changing colors in the Style group, under
the

Design menu



Basics of WordArt

1. Inserting WordArt

•  Navigate to the Insert menu and select the WordArt option
•  Choose a style in the gallery and enter your text



1. Formatting WordArts

•  Select the WordArt

•  Navigate to the Format menu and select formatting options from the
tools for WordArt

•  You can add Fill or Borders to your WordArt and even change the
orientation



1. Changing WordArt Fonts

•  Select the WordArt
•  Navigate to the Home menu and select a font or font size

1. Deleting WordArts

Right-click on the WordArt and select the Delete option USING
ADDITIONAL TYPES OF GRAPHICS IN YOUR WORKSHEET

Excel Graphic Files
Various formats exist for graphics in Excel, among these are:

•  .bmp graphic files
•  .png graphic files
•  .jpg graphic files
•  .gif graphic files

You can also save your charts as pictures:

•  Select and copy the chart you want to save as a picture
•  Paste the chart in any picture editor of your choice and

then save
Adding Screenshots
•  You can copy the screenshot from your File Explorer and then paste it

into your worksheet

•  You can also select the Screenshot option in the Insert menu



SHOWING THE
BACKGROUND IMAGE OF YOUR

WORKSHEET
•  Select the worksheet
•  Navigate to the Page Layout menu and select the Background

option

•  Select an image of your choice and click the Insert button



IMPLEMENTING THE EDITOR
DIALOGUE BOX FOR EQUATIONS
•  Navigate to the Insert menu

• 

Select the option for Equation
•  Enter your equation in the editor that appears



Default equations can
also be inserted by clicking on the dropdown menu for Equations



Summary



Formatting your numbers present in a data set gives you more flexibility
to customize how you want your data to be displayed. It also aids quick
comprehension of the represented data. Inserting shapes, infographics, and
icons also improves your data visualization as explained in this chapter.
How to insert WordArts, SmartArt and screenshots were also discussed.



CONCLUSION
Microsoft Excel is an easy and common application for data entry and
representation. Excel can be used by novices and beginners to successfully
create data entries, simple charts and also apply basic and necessary
formatting or customization to represent their data. Support can also be
gotten from the Microsoft team when needed.





Part 2: EXCEL FORMULAS &
FUNCTIONS INTRODUCTION TO

EXCEL FUNCTIONS AND FORMULAS
Excel formulas and functions are used during calculations. They can be
implemented when handling both text and numeric data. When carrying out
calculations in Excel, you make use of either functions or formulas.
Example of a function and a formula include

=SUM(B1:B4) and =B1+B2+B3+B4 respectively. The two expressions
perform similar addition of cells B1 to B4. Every expression for calculation
in Excel begins with the equality sign (=).

Multiple ways exist to input formulas or functions in your worksheet,
among which are:

•  Directly in the cell, you wish the calculation result to be displayed
which gives a multiple suggestion list of possible functions:



•  Making use of the option for inserting functions from the ribbon
menu while highlighting a cell:



•  Choosing a formula or function from the Logical functions tab:
•  Employing the AutoSum tab:



•  Choosing formulas from a list of those you used recently:

• 

Using the bars for formulas:

Formulas and functions are introduced to enhance data analysis, data
search, and improved visualizations.





CHAPTER 15- THE EXCEL FORMULA
BAR

The formula bar is located beside the Name box at the top of your
worksheet, just at the base of the ribbon menu. It is used for entering or
editing cell contents and formulas. The formula bar can be hidden and
displayed as a user wishes. These steps should be followed to hide or
display the formula bar:

•  Navigate to the View menu

•  Select the box labeled Formula bar to either hide or display the bar



Increasing the Size

of the Formula Bar



When dealing with advanced and extremely long formulas, it could be
necessary to increase the size of the formula bar to aid the visualization of
the typed formula.

To increase the size of the formula bar:
•  Set your cursor on the lower edge of the bar for the adjustment cursor

to be displayed

•  Drag down your mouse to increase the size of the bar These same
steps can also be followed to reduce the bar’s size; simply drag up your
mouse instead.

Keyboard keys Ctrl + Shift + U can be used as a shortcut to both
increase and decrease the size of the formula bar. The vertical and
horizontal expansion buttons can be implemented as well.

The formula bar has the following parts:

•  The input space

•  Button for vertical expansion

• 

The Cancel and Enter button
•  Button for inserting functions





GETTING FAMILIAR WITH EXCEL
FUNCTIONS AND FORMULAS

Basics of Formulas in Excel

•  Implementing Operators in Your Formulas

Adding operators in your Excel operations makes Excel aware of what
you wish to be done. One or more operators can be added in an expression.

Operators in Excel are of the following category: Operators for
Arithmetic Operations

+ represents Addition operation. Example: =A9+B4
- represents Subtraction operation
Example: =A6–A21 or –C17
* represents Multiplication operation Example: =A21*B33
/ represents Division operation Example: =B39/A20
% represents Percent operation, i.e. division of numbers by 100.

Example: =B34%
^ represents Exponentiation operation Example: C16^7

•  Operators for Comparison Operations



These operators are used when checking for a condition. These results
are usually either TRUE or FALSE. The comparison operators include:

= represents ” Equal to“. Example: =A7=B31
> represents “Greater than” Example: =B36>A20
< represents “Less than” Example: =A2<D12
>= represents “Greater than or equal to“. Example: =B3>=A20
<= represents “Less than or equal to“. Example: =A12<=B23
<> represents “Not equal to” Example: =A22<>B13

•  Operator for Text Operations

The ampersand symbol (&) is used when combining two or more
different texts in different cells to give one text or sentence.

Example: =A32&” “&B31. This operation is referred to as
Concatenation.

•  Operator for Reference Operations

The Colon symbol (:) represents the Range operator for references cell
ranges.

Example: =SUM(C14:D37)
The reference and range operators also include:
The Comma (,) symbol represents the Union operator. It brings

numerous cell ranges into one.
Example: =SUM(A12,C4:D27,B13)
A Space represents an operator for Intersection that produces a cell

reference in similarity with two references.
Example: =SUM(C13:C16 C13:E16)
Precedence of Operators in Excel Formulas
When your Excel formula or expression is built from multiple operators,

Excel employs an order of precedence in dealing with such. Starting from
the left direction, the precedence of operators in Excel is as follows:

1. Negation
2. Percent
3. Exponentiation
4. Division and Multiplication



1. Subtraction and Addition
2. Concatenation
3. Comparison operations



ADDING FUNCTIONS TO FORMULAS
Sample Formulas that Implements Functions

Formulas are expressions that carry out operations on the data in cells.
They employ operators for their operations. Functions, however, are
predefined expressions. They are used to carry out quick operations, letting
you avoid the task of spelling out long formulas or repeating operators.

Common Excel Functions



•  SUM
This gives the summation of the indicated cell range. E.g.



=SUM(E14:E28)
•  MIN

This gives the minimum number in the indicated cell range. E.g.



=MIN(E14:E28)
•  MAX

This gives the maximum number of the indicated cell range. E.g.



=MAX(E14:E28)
•  AVERAGE

This calculates and gives the average of the indicated cell range. E.g.



=AVERAGE(E14:E28)
•  COUNT

This gives the number of cells indicated in a cell range. E.g.



=COUNT(E14:E28)
•  LEN

This function calculates how many characters are present in a string.
E.g. =LEN(B27)



•  SUMIF
This function carries out an addition operation only if the stated condition is
satisfied. E.g. =SUMIF(D24:D28,”>=900″,C14:C28)



•  AVERAGEIF
This function carries out an averaging operation only if the stated condition
is satisfied. E.g.

=AVERAGEIF(F24:F38,“No”,E14:E18)



•  DAYS
This function gives the days’ number present between dates. E.g.



=DAYS(D24,C24)
•  NOW



This function gives the present time and date of your device. E.g.



=NOW()
String or Text Functions



•  LEFT
This function gives the indicated characters present from the left of a text.
E.g. =LEFT(“WISDOM”,3) gives WIS



•  RIGHT
This function gives the indicated characters present from the right of a text.
E.g. =RIGHT(“WISDOM”,3) gives DOM



•  MID
This function gives the indicated characters present from the middle of a
text. E.g. =MIS(“WISDOM”,2,3) gives ISDO



•  ISTEXT
This function checks if the indicated value is a text and gives a result of
either False or True. E.g. =ISTEXT(“WISDOM1”)



•  UPPER
This function converts texts in lowercase to capital letters. E.g.



=UPPER(B12)
Time and Date Functions



•  DATE
This gives the particular number that represents the date in an entry.

E.g. =DATE(2022,9,12)



•  MONTH
This gives the particular number that represents the month in a date entry.
E.g. =MONTH(“2022/9/12”)



•  YEAR
This gives the particular number that represents the year in a date entry. E.g.
=YEAR(“2022/9/12”)



•  MINUTE
This gives the value representing minute in a time entry. E.g.



=MINUTE(“9:31”)
Arguments in Functions

Arguments are used by functions for carrying out their operations. They
are the values present in functions. Arguments in functions can also be
singular: UPPER(B12), or multiple: SUM(C13:C16 C13:E16). The
function =SUM(E14, E15, E16) has the following arguments:

E14, E15, E16
Some Excel functions do not require arguments, such as TODAY()
and NOW().



HOW TO INSERT FORMULAS IN
WORKSHEETS

•  Inserting Formulas Manually

You can manually insert formulas in your worksheet by selecting the cell
where you want the results to be shown, and then entering the formula. For
example, to perform an addition operation on cells A21 and B21, with the
result displayed in cell C21:

•  Select cell C21
•  Type in the formula =A21+B21
•  Press the Enter key

Inserting Formulas by Pointing
You can also select the individual cells to create your formula.

•  In cell C21, type the equality sign “=”
•  Select cell A21
•  Type the summation symbol “+” in C21
•  Select cell B21
•  Press the Enter key

Inserting Name of Ranges in Formulas

•  Highlight the cell where the name of the range would appear
•  On the ribbon menu, select the Formula tab

•  Navigate to the option to select what you can use in your formula and
select the choice to paste desired names



•  Pick from the existing name of ranges and click the OK button
•  Also, press the Enter key on your keyboard

Adding Functions to Formulas
•  Navigate to the Home tab and select the drop-down icon on the

AutoSum button



• 

You can also click to view additional available functions

•  Navigating to the Formulas tab and selecting the option to enter a
function can be used. This action brings up the dialogue box for inserting
formulas.

•  Any option from the Library of Functions group can be used

Pointers for Inserting Excel Functions
•  Ensure the cell where you want the function result to appear is first

highlighted
•  Add brackets to your formulas or functions to indicate which should

be first executed
•  When writing complex and long functions, start the different sections

of the function on a new line
•  The handle for filling can be used to duplicate formulas and functions

across multiple cells
•  Keyboard keys ALT + = can be used to automatically sum up cell

values:

•  Highlight the cell where the result would be displayed

•  Hold down the Alt key, type in +, and then = CHANGING
FORMULAS IN EXCEL

•  Select the cell where the formula was implemented
•  Use the bar for formulas to then edit the formula
•  You can also double-click on the cell itself to edit the formula



REFERENCING CELLS IN FORMULAS
Relative Cell Referencing

This type of cell referencing changes with the location of the cell. For
instance, if you copy the formula B2*D2 to another row, say row 14, the
formula changes to B14*B14. The relative cell



referencing for formulas can be copied and implemented using the drag
and fill procedure.

Absolute Cell Referencing
Here, the cell reference remains constant, regardless of the location.

They are indicated by adding the sign of dollar ($) in formulas. E.g.
=$B$3*$C$3*$E$1 Mixed Cell Referencing
This cell referencing includes both the relative and absolute cell

references. An example is =(B3*C3)*$E$1 where the value in cell E1
remains constant. They can be used to reference cells where values such as
discount, tax, etc. are entered.

Switching between Reference Types
The F4 key on your keyboard can be used to alternate the types of cell

references.
Referencing Cells in Other Worksheets

•  Navigate to the cell to be referenced
•  Take note of the worksheet name and the cell number
•  Open the worksheet where the referencing is to be done
•  Select the cell where the referencing result would be displayed
•  Type in a formula in this format

=’Worksheet_Name’!Cell_Number. E.g. = ‘Wisdom’!D2

•  Press the Enter key

A change of name of the referenced worksheet results in an automatic
update of the formula.

Referencing Cells in Other Workbooks
•  Type in a formula in this format in the cell where the referencing

result would appear [Name_of_Workbook]Name_of_Worksheet!Cell_ad
dress

•  E.g [Wisdom.xlsx]Writers!B2
•  Press the Enter key



IMPLEMENTING FORMULAS IN
EXCEL TABLES

Summarizing Table Data
The UNIQUE and SUMIF functions are used to create a summary data

table. The UNIQUE function works by indicating a range of cells from your
dataset.

E.g =UNIQUE(A12:A21)
After this list is done, the SUMIF function is then introduced to fill the

list created with the UNIQUE function. The Spill Operator is



used with the SUMIF function to create an array that is dynamic.
E.g. =SUMIFS($C$12:$C$21,A$12:$A$21,E7#)
Implementing Formulas in Tables

•  Select the table cell where the formula would be implemented
•  Type in =[

•  This brings up the list of available columns that can be included in
your formulas

•  Insert the @ symbol to indicate a reference to only the present
row
•  End the formula with ] and press Enter

An example of a table formula is as follows: =[@ Wisdom*@Writers]
Making Reference to Table Data

•  To reference a specific row:

=[@name_of_column]

•  To reference the complete data columns in the table:

=[name_of_column]

•  To reference data from another table:

=Table_Name[Column_Name]



•  To reference the complete table:

=[#All]

•  To reference every row of data:

=[#Data]

•  To reference the table headers:

=[#Headers]

•  To reference rows of summation:

=[#Totals]



RECTIFYING ERRORS IN FORMULAS
Rectifying Circular References

Circular referencing occurs in Excel formulas when the cell in which
the formula result would be displayed is entered as an argument in the
formula. For instance, cell D9 is the highlighted cell where the



calculation result would be shown, and the formula entered by a user is
=A3*D9.

Circular reference errors can be found and corrected using the Ribbon
menu.

•  Navigate to the Formula tab
•  Select the drop-down option for checking errors

•  Choose the option for Circular References and this would show a list
of cells having the error

The Status Bar can also be used. Excel shows present circular
references in the status bar.

Calculations Not Occurring in a Formula
This error can be easily corrected by switching your Excel calculation

mode. Navigate to the Formula menu and select the tab to choose an option
for your calculation. Choose the Automatic mode.



IMPLEMENTING
COMPLEX TECHNIQUES FOR

NAMING
Implementing Constant Names

•  Go to the Formula menu and select the option to define a name
•  This brings up the dialogue box to configure names.
•  Enter a name for your constant

•  In the Refer to bar, indicate what the constant name would represent



•  Click on OK when done

Implementing Formula Names
•  Navigate to the Formula menu and select the option to implement an

option in the formula
•  Select the name to be used and press Enter Implementing

Intersection in Ranges
Inserting a space between two cell ranges denotes a formula to find the

cell range intersection. Example is =C9:C13 A5:E5 or =B9:C13 B6:D6.
Adding Names to References

•  Highlight the ranges of the cell to be named
•  Enter a name in the box for names and press Enter

Likewise, the tab to define reference names from



the Formula menu can also be used.



USING FORMULAS
Preventing Hard-coding of Values

Hard-coding formula values refer to users inserting specific numbers in
their formulas. For example, = A1/B1 + 500. The presence of

+500 in the formula makes it hard-coded.
A better way to do this is to use absolute cell references. Also ensure

that cells either contain specific data or formulas, do not use both.
Making Use of the Formula Bar as a Calculator
The Formula Bar is one of the easy ways to insert formulas into your

worksheet. Simply type in your formula after setting your cursor on the cell
where the formula result would be displayed and then press Enter.

Duplicating Excel Formulas
The drag and fill procedure or the handle for filling can be used to make

exact duplicates of formulas. You can also use the usual copy and paste
technique.

Changing Formulas to Their Results

•  Select the cells containing the formulas to be changed
•  Use Ctrl + C key to copy them



•  Use Shift + F10 + V keys to paste just the formula results in the cells.
Summary
Operators, arguments, and functions make up formulas. They denote

specific operations that Excel is meant to carry out. Formulas can be
entered either manually or by clicking on specific cells. You can also
reference cells outside your present worksheet and workbook in your
formulas. This chapter further explained how you can use formulas in
tables, edit formulas, correct possible errors in your formula, change your
formula to its values, and also how to use complex naming techniques.





CHAPTER 16-APPLYING FORMULAS
IN REGULAR MATHEMATICAL

OPERATIONS PERCENTAGE
CALCULATIONS

Cells can be formatted into a percentage by highlighting the desired cell and
then selecting the percentage option from the group for numbers.
Percentages can be calculated either by division by 100 or by dividing a
part with the total.

Goal Percentage Calculations
This is an example of finding percentages by dividing a part by the

total. The formula for finding goal percent is as follows: Goal Percent =
Result / Goal

For instance, having a target of 10,000, but the achieved result is 9,000;
you can find the percentage of the goal achieved thus:

Goal Percent = 9000 / 10000
= 90%
The cell having the result and goal can simply be inserted as an

argument in your formula, e.g. G5/H5. The cell where this result would be
displayed must then be formatted to percentage.

Variance Percentage Calculations
The variance percent of a data set indicates the percentage difference

when recent data is compared with reference data. The formula is as
follows:

Variance Percent = (Recent Data - Reference Data) / Reference Data
Cells having the required data can simply be inserted as an argument in

your formula. The cell where the formula result would be displayed must
then be formatted to percentage.



Finding Variance Percent Using Negative Data
Using the Absolute function gives the required positive result when you

get a negative result for your variance percent. E.g. =(C14- B14)/ABS(B14)
A negative result usually occurs when the reference data is higher than

the recent data.
Distribution Percent Calculations
Distribution percent refers to the level at which a specific data is spread

across its sub-data. It simply involves dividing cell values by the complete
value. The cell holding the total value is usually referenced with an absolute
referencing. E.g. =D3/$C$7

Running Total Calculations
Running total calculations shows how additional data affects the

summation result of the previously added data. This can be done using the
drag and fill procedure.

•  Select the cell where the data cell begins and enter a formula of this
format:



• =SUM(B$2:B2)
•  Press Enter

•  Use your mouse to drag
and fill the next cells next to the additional data set



Including Increase or Decrease in Percentage to Excel Values
The formula format for this operation is as follows:
=existing_number*(1+percent)
The value of the percentage change can be included in cells that can be

referenced, such as =C15*(1+D15)



The existing number to be increased resides in cell C15 and the
percentage by which the number would be either increased or decreased
resides in cell D15.

Rectifying Errors of Division by Zero
Excel gives the error message #DIV/0! when an attempt is made to

divide a value by zero.

This error can be rectified by avoiding entering formulas having a
reference to cells having zero value.



ROUNDING NUMBERS
1. By Formulas

The following formula syntax is used for rounding operations in Excel:
=ROUND(number_to_be rounded,num_digits)
The first argument number_to_be_rounded denotes the cell reference,

the argument num_digits denotes the number of numeric digits to which
the first argument would be rounded.

E.g =ROUND(A7, 3)

1. With the Formula menu

•  Navigate to the Math tab drop-down menu and select any of
the

ROUND options.

•  Insert the number performed and the on which the operation is to be



resulting number of digits in the subsequent dialogue box

•  Click on OK when done

Rounding to Closest Penny
Currencies can be rounded to the nearest significant pennies by setting

the num_digits argument to zero. E.g. =ROUND(B5,0). The ROUNDUP
or ROUNDDOWN functions can also be used.

Assuming you are dealing with the Dollar currency, to round values to
the closest cent, set the num_digits argument to 2. E.g.



=ROUND(B5,2).
Rounding to Closest Whole Numbers

This is also done by setting the num_digits argument to zero.



CALCULATING THE NUMBER OF
VALUES IN A CELL RANGE

This is done using the COUNT function. E.g. =COUNT(B5:D9).
Other usable functions include COUNTA for counting both text and

numeric data and COUNTBLANK for counting empty cells in the
indicated range of cells.



IMPLEMENTING THE FUNCTIONS
FOR CONVERSION IN EXCEL

This function converts a data value from one SI unit to another. The syntax
for the formula is as follows:

=CONVERT (number_to_be_converted, from_unit, to_unit) E.g.
=CONVERT(42,“C”,“F”) or =CONVERT(G12,“C”,“F”)
Summary
How various percentage values such as percentage distribution,

variance, goal, etc. were examined in this chapter. The functions for
performing rounding operations were also discussed, alongside the



CONVERT function for changing data values from one unit to another.





CHAPTER 17 MANIPULATING EXCEL
TEXTS WITH FORMULAS

FUNCTIONS FOR TEXTS IN EXCEL
These functions are used in text data. Their presence in your formula allows
Excel to concatenate, switch text cases, find and extract certain parts of the
indicated text, etc.

Function to Combine Strings of Text
The CONCATENATE function is used for combining multiple strings

of texts in Excel. An example is =CONCATENATE(D1, F1).
The operator to perform a similar operation is the ampersand (&)

symbol.
Switching Texts to Sentence Cases
The function PROPER is used for this operation. Other functions to

switch text cases are the UPPER function for capital letters and the
LOWER function for small letters. Examples are:

=LOWER(D2)
=UPPER(D2)
=PROPER(D2)

Deleting Excess Spaces in
Strings of Text Excess spaces can be removed from your texts using the
TRIM function. E.g. =TRIM(D2)



Discovering Parts of a String of

Texts



Various functions are available to extract specific parts of your texts.
These include:

•  The LEFT Function

This function finds characters starting from the left side of your text.
The syntax for the formula is as follows:

=LEFT(cell_text, num_chars)
The cell_text argument denotes the cell holding the text, and
num_chars denotes the number of characters to be extracted. E.g:



=LEFT(D2,4)

•  The RIGHT Function

This function finds characters starting from the right side of your text. The
syntax for the formula is as follows:

=RIGHT(cell_text, num_chars)
E.g: =RIGHT(D2,4)

•  The MID Function

This function holds an addition argument to tell Excel where to start and
end its extraction operation.

=MID(text, starting_num, num_chars)
E.g: =MID(D2,6,3)
This formula above tells Excel to start its extraction from the 6th

character, and then to extract the next 3 characters.
Extracting Texts Before and After Particular Characters
The LEFT/RIGHT functions and the SEARCH function are used as

suitable.
For extracting texts before the character, use the following syntax for

your function:
=LEFT(cell_text, SEARCH(“char”, cell_text)-1)
The char argument denotes the character to be used as the reference

point. Example includes:



=LEFT(D2, SEARCH(“-“,D2)-1)



For extracting texts after the character, use
the following syntax for your function:

=RIGHT(cell_text,LEN(cell_text)-SEARCH(“char”,  cell_text)).
Example includes: =RIGHT(D2,LEN(D2)-SEARCH(“-“,D2))
Searching for Specific Text Characters in a String The SEARCH or

FIND functions are used for this operation. The syntax is as follows:
=FIND(find_character, within_text) or
=SEARCH(find_character, within_text).
For example: =FIND(“e”, “fine”) or =SEARCH(“wash”, “carwash”)
Searching for Second Occurrence of Specific Text Characters in a

String
This operation uses the FIND function. Where the specific character is

first found is indicated in the formula. E.g: =FIND(””,“POWER- 2-BIG”,
7)

This formula tells Excel to search for the “-” character, and then to
begin its search from the 7th character since the character is first found in
the 6th character.

Replacing Content of Texts
The SUBSTITUTE function is applied with the following syntax:
=SUBSTITUTE (cell_text, old_text, replacing_text). E.g:
=SUBSTITUTE(D5,“c”,“b”). This formula replaces every “c”

character with “b”.
If you want to only replace specific characters, you can add another

argument to denote this:
E.g: =SUBSTITUTE(D5,“c”,“b”, 2). This tells Excel to only replace

the second “c” character with “b”
Calculating the Number of Times a Character Appears in a Text
This operation uses the LEN and SUBSTITUTE functions. Example

includes:



=LEN(D2)-
LEN(SUBSTITUTE(D2,“A”,””)).



This formula calculates the number of times the character “A” appears in
the text.

Starting Lines of Formulas on New Lines
•  Place your mouse blinking cursor at the start of the argument where

the new line would begin

• 

Press keys Ctrl + Alt and press Enter

Erasing Unwanted Characters from Fields for Text Follow this syntax to
clean up unwanted characters in your texts:

=SUBSTITUTE (Cell_Text , “char_to_be_removed”,
“replace_with”).

E.g: =SUBSTITUTE(D3,”!”,” “)
This formula replaces the “!” character in cell D3 with a space.
Formatting Numbers by Adding Zeros
The TEXT function is used in this case. E.g.



=TEXT(B2,“0000000000”)
The dialogue box for customizing numbers can also be used.

•  Highlight the cells to be formatted

• 

Right-click on these cells and select the option to format them
•  Navigate to the option for Custom in the dialogue box
•  Type in multiple zeros as desired and select the OK button



Formatting Numeric Values in Strings of Text
This operation includes the concatenation operator and the TEXT

function for combining text and numeric values. Formatting the numeric
values follows the syntax:

=TEXT (cell_reference, required_formatting)
E.g. =B5&”: “&TEXT(C8, “$0,000”)
This formula combines the text in cell B5 and the formatted currency

value in cell C8.
Applying the DOLLAR Function
This function changes numeric values to text as mentioned in the

previous includes: section for formatting numbers in texts. Example
=DOLLAR(259.99) that gives a result of $259.99
Combined with text for instance,
=“Radio price is “&B6 would give a result of “Radio price is 99”

Including the DOLLAR function:
=“Radio price is “&DOLLAR(B6) would give a result of “Radio

price is $99.00”



Summary



How texts can be manipulated using text-related functions was
examined in this chapter. Joining, counting, replacement, and extraction
operations can all be done with the appropriate functions. Numeric values
can be formatted to text to improve their visualization when concatenated
with text using the DOLLAR function.





CHAPTER FOUR
APPLYING FORMULAS FOR DATES AND TIME

Serial Numbers for Dates
Dates are saved as sequential numbers in Excel to facilitate calculations.

The 1st of January, 1900 holds the first place in the serial number. The
DATEVALUE function is used for converting dates saved as texts to serial
values. The formula

=DATEVALUE(“1/1/2008”) would give a serial number of 39448 as
its result. This means the specified date is the 39448th time the First of
January occurred since the default start of 1900.

Inserting Dates in Your Worksheet
The TODAY or NOW functions can be used to insert recent dates that

can update themselves in your worksheet.
Serial Numbers for Time
An hour in Excel can be expressed serially as 1/24 or 0.41666’.

Minutes are 1/60 or 1/1440 with respect to a day, which is also serially
expressed as 0.00069444’. Seconds are expressed as 1/86400 or
0.0000115740740740741’ serially.

Inserting Time in Your Worksheet
The NOW function inserts recent time that can update itself in your

worksheet. The TIME function can also be used. This function has the
following syntax:

=TIME(hour, minute, second). Configuring Excel Time and Dates
•  Highlight the cells containing the time and date to be formatted or

configured

•  Right-click on the cells and select the Format option

•  Navigate to the option for Date or Time from the Category pane and
make necessary adjustments



•  Select OK when done

Excel Date Issues
The Leap Year Loophole
Excel serial numbering of dates includes 29th of February 1900 which

is incorrect. Excel treats the year 1900 as a leap year which is false; this
loophole has its source from Lotus 1-2-3.

The Dates before 1900
Dates before the year 1900 if entered in Excel are treated as text; they

cannot be converted into serial numbers as other dates.
Irregular Entries for Excel Dates
This issue can be solved by first clearing all formatting of the date cells.
•  Navigate to the Home menu and select the option to clear all

formatting from the group for Editing.

•  This action converts your date into their serial number values



•  Next, you can format the date cells using the Format dialogue box.
The tab for carrying out text formatting to columns can also be used.

•  First, highlight the cells

•  Navigate to the Data menu and select the option for text formatting to
columns

•  This action opens the corresponding columns wizard



• 

Select the box for Delimited and select Next
•  Tick the box for Space to be used as the delimiter and select
Next

•  Tick the box for Date and select your desired format in the drop- down
options



•  Click on Finish



IMPLEMENTING THE FUNCTIONS
FOR TIME AND DATE IN EXCEL

Dealing with Age
The date of birth should first be entered in a cell, say A7; then highlight

the cell where the present age would be displayed and type in this formula:



=INT((TODAY()-A7)/365)
The INT function is added to remove possible decimals in the calculation.

Dealing with Days Number between Dates The DAYS function is
used for this calculation. It follows this syntax:

=DAYS(ending_date, starting_date)
The two arguments present in the syntax can be made to be cell

references, such as



=DAYS(C3, D3)
You can use also directly use the dates:

=DAYS(“27-October2019”, “11-October2020”).
Dealing with Workdays between Dates
The NETWORKDAYS function is used in Excel for automatically

calculating weekdays. It follows the syntax:
=NETWORKDAYS(ending_date, starting_date)



Also, days for a holiday can be considered in the calculation. The
syntax then becomes =NETWORKDAYS(ending_date, starting_date,
days_for_holiday)

It is of good practice to make these arguments reference a cell. The
days_for_holiday argument can be a range of cells, e.g.



=NETWORKDAYS(D7,E7,C1:C9)
The NETWORKDAYS.INTL Function

This function also calculates Workdays, considers days for holidays,
and includes consideration for weekends to be specified. The syntax is as
follows:

=NETWORKDAYS.INTL( starting_date, ending_date, [weekend],
[holidays])

Excel has a predefined serial numbering for weekends as shown below:



An example of the

formula implementation is



=NETWORKDAYS.INTL(D7,E7,12,C1:C
9)

Generating Date Parts
Date parts in Excel that can be extracted along with their corresponding

functions are listed below:



Year: =YEAR(D7) Month: =MONTH(D7) Day: =DAY(D7)
Weekday: =WEEKDAY(D7)
Number of Weeks: =WEEKNUM(D7)
Deriving Number of Months and Years between Ranges of Date

Excel uses the DATEDIF function for this calculation. It follows the syntax
=DATEDIF(starting_date, ending_date, unit)
The unit argument lets you specify if you want the calculation in days,

years, or months. The defined unit annotations are as follows:
y for the number of completed years between the specified dates m
for the number of completed months
d for number of completed days
md for number of completed days, without considering the years and

months
ym for the number of completed months, without considering the years

and days
An example of how the formula can be implemented is
=DATEDIF(D7,E7, m)
Changing Dates to the Format for Julian Dates
The Julian date can consist of five or seven numbers, where the

preceding numbers denote the year, and the ending three numbers are
usually for days. For instance, the Julian date 17003 or 2017003 represents
3/1/2017 in a normal date format. Converting dates to Julian dates uses the
TEXT, DATE, and YEAR functions, along with the & operator. An
example of the formula implementation for a 5 digit Julian date is:

=TEXT(D7,“yy”)&TEXT(D7-DATE(YEAR(D7),1,0),“000”)
TEXT(D7,“yy”) represents the year value and and

DATE(YEAR(D7),1,0),“000”) caters for the date value. An example of the
formula implementation for a 7 digit Julian date is:



=TEXT(D7)&TEXT(D7-
DATE(YEAR(D7),1,0),“000”)

Calculating the Percentage of Year Remaining and Percentage Used
The YEARFRAC, YEAR, and DATE functions are used for year

percentage calculations. It follows the syntax:
=YEARFRAC(DATE(YEAR(date_cell),1,1),date_cell) “1,1” in the

formula denotes the first day of the first month, i.e. First of January. An
implementation of the formula is:



=YEARFRAC(DATE(YEAR(D7),1,1),D7)



Excel does this calculation using a value of 360 days. It assumes that each
month ends on day 30.

Deriving the Last Day of a Specific Month
Excel uses the EOMONTH function to calculate the last day of the

month. The syntax is as follows:
=EOMONTH(date_cell,0)
” 0” in the argument denotes that the calculation is to be carried out on

the currently specified month. Different values can be placed in the
argument signifying a calculation =EOMONTH(date_cell,1) signifying
that Excel should calculate for the next month. An implementation of the
formula includes:



=EOMONTH(D7,0)
Dealing with Quarters for a Calendar for Dates

The ROUNDUP and MONTH functions calculate the quarters of a
calendar from a specified date. The functions follow the syntax:

=ROUNDUP(MONTH(date_cell)/3,0).
The quarters in a calendar year are as follows:

•  Quarter 1: January, February, and March
•  Quarter 2: April, May, and June
•  Quarter 3: July, August, and September
•  Quarter 4: October, November, and December

Dealing with Fiscal Quarters for a Calendar for Dates
The fiscal year for various organizations differs, causing a difference in

the start of their fiscal quarters. The general fiscal quarter follows the series
1,1,1,2,2,2,3,3,3,4,4,4. Putting this in a formula and including the
CHOOSE and MONTH functions gives:

=CHOOSE(MONTH(date_cell),1,1,1,2,2,2,3,3,3,4,4,4)
But for a personalized calculation of your organization’s fiscal quarter,

these series can follow any orderly arrangement. Ensure however that these
numbers are not mixed up, such as 1,1,2 or such as
=EOMONTH(date_cell,-1)

for the previous month and 3,3,3,1,1,1; these formats are not allowed in
Excel fiscal quarter calculations. An illustration of a fiscal quarter
arrangement is shown below:

An implementation of an organisation’s applicable fiscal quarter is:



=CHOOSE(MONTH(D7),3,3,3,4,4,4,1,1,1,
2,2,2)

Dealing with Fiscal Months for a Calendar for Dates
As the regular year begins from January, fiscal months can start from

any month within the year. An illustration of a fiscal month arrangement is
shown below:

This calculation is done with the CHOOSE and MONTH functions;
=CHOOSE(MONTH(D7),7,8,9,10,11,12,1,2,3,4,5,6) 7 in this
formula denote January as the 7th fiscal month in the organization’s

fiscal year calendar.
Dealing with the Nth Date of the Weekday of a Month
The Nth date of the Weekday of a Month refers to days such as the third

Wednesday, fifth Monday of the month, etc. The WEEKDAY and DAY
functions are used in this calculation. The formula syntax to be used is as
follows:

=date-DAY(date_cell)+1+n*7-WEEKDAY(date DAY(date_cell)+8-
day_of_the_week)

The day_of_the_week argument is usually an integer to indicate the
day number in the week, e.g. Wednesday is day 4. Dealing with the Last
Date of the Weekday of a Month

This operation uses the WEEKDAY and EOMONTH functions.
functions. day_of_the_week) Generating Time Parts in Excel
The HOUR, MINUTE, and SECOND functions are used for extraction

and generation of time parts. Examples are:
=HOUR(D7)

=MINUTE(D7)



=SECOND(D7)
Dealing with Elapsed Time
The NOW function can be used for this operation. The formula follows

the syntax:



=NOW()-Starting_Time
The Starting_Time argument can be a cell reference, e.g. =NOW()- D7
Two cells containing the starting time and the ending time can also be

subtracted, e.g =D7-E7
Note that the cell where this result would be displayed would have to be

formatted to hold the time format.
Rounding Values of Time
Time in Excel can be rounded to the next, nearest and previous unit with

the CEILING.MATH, MROUND, and FLOOR.MATH
functions respectively.
To round time to the nearest value:
=MROUND(time_cell,TIME(0,1,0)) for minutes
=MROUND(time_cell,TIME(1,0,0)) for hour To round time to the

next value:
=CEILING.MATH(time_cell,TIME(0,1,0)) for minutes
=CEILING.MATH(time_cell,TIME(1,0,0)) for hour To round time to

the previous value:
=FLOOR.MATH(time_cell,TIME(0,1,0)) for minutes



=FLOOR.MATH(time_cell,TIME(1,0,0)) for hour



The TIME(1,0,0)

argument can hold any value between the normal time values.



Changing Decimal Minutes, Hours, or Seconds to Regular Time
MINUTE, HOUR, and SECOND functions are used.

=HOUR(time_cell)+MINUTE(time_cell)/60+SECOND(time_cel
l)/3600

Adding Seconds, Minutes, and Hours to Time The syntax to be used
is as follows:

=time_cell+TIME(1,0,0)
This formula allows you to perform both addition and subtraction of all

the time units.
Summary
This chapter examined how dates and times are treated in Excel.

Functions needed to manipulate and configure time and date such as time
format, fiscal year or month, year quarters, etc. were explained. How you
can work with Julian dates, add or subtract time units from your time
values, round time and also find the Nth day of a weekday were discussed.





CHAPTER FIVE
IMPLEMENTING FORMULAS WHEN DEALING WITH

CONDITIONAL ANALYSIS What is Conditional Analysis?
These are operations that depend on one or more conditions being met

before they can be successfully carried out. They are implemented when
carrying out logical analysis.

Ascertaining for Single Conditions Satisfaction
The IF function is the easiest to be used in these cases. Single condition

analysis simply aims to check for the result of a specified condition being
true or false. The function argument first checks the condition, then gives a
result if the condition is met or not. It follows the syntax:

=IF(conditional_test, [result_if_true], [result_if_false]) E.g.
=IF(D7>E7, “Good Job!”, “You can improve!”)
The arguments [result_if_true] and [result_if_false] can also be cell

references.
Ascertaining for Multiple Conditions Satisfaction The IF function

can be used alone and implemented as follows: =If(D7<35, “F”,If(D7<45,
“D”, If(D7<50,”C”,If(D7<70,”B”,”A”)

Implementing Conditional Logic in Cells
The AND or OR functions can likewise be used and implemented as

follows:



=IF(AND(D7>=40,E7>=60),”True”,”False”).
=IF(OR(D7>=40,E7>=60),”True”,”False”)
Remember the conditions for logical AND and OR:

•  AND can only be true when the present two conditions are true.

•  OR can only be false when both conditions are false; this means if
either of the two present conditions is true, then the result of the condition is
true.

Confirming Conditional Data
This refers to how users can decide the options present in a dropdown

menu based on the content of a different cell. Two sheets are needed to
validate conditional data. For instance, we will examine how to set different
options to appear when selecting Fruits or Vegetables:

•  Create two worksheets in your opened workbook
•  Name one sheet List and the other Data
•  Open the List sheet and enter the following data

•  Separately highlight each of the columns and carry out this formatting
procedure individually:

-  Navigate to the option to format columns into tables from the

Home menu
-  Select the box to indicate a header for your table in the resulting

dialogue box and select OK



- 

Your tables should appear like this:
•  Highlight the items you have in the first table, i.e. Produce

•  Go to the box for names and enter a reference, the most suitable being
Produce

•  Press the Enter key
•  Repeat this process for the other two tables



•  Open the Data worksheet and make the following entries:

• 

Format each of these cells to tables as done in the List worksheet
•  Select the cell where the first conditional data would appear in
the

Data worksheet

•  Navigate to the Data menu and select the option to validate
data

•  In the resulting dialogue box, select the second worksheet, List in the
drop-down option labeled Allow

•  Choose the =Produce source list as previously named in the
List

worksheet



•  Select OK



•  Highlight the next cell to the right of the previously selected cell; this
should be cell C3

•  Navigate to the Data menu and select the option to validate
data
•  In the box labeled Source, insert this formula



=INDIRECT(B3)
Cell B3 is referenced here because cell C3 has been highlighted

•  Click OK
•  Select the Yes option if Excel brings up an error message

•  Select cell B3, Excel displays $B$3 as the cell reference. Remove the
dollar sign to make the reference of the cell relative.



To initiate another row in
this table, the Tab key can be used. Using the VLOOKUP Function

•  Select the cell where the formula would be implemented
•  Navigate to the Formula menu and select the Lookup option

•  Choose VLOOKUP from the drop-down menu to launch the
corresponding dialogue box



•  Indicate the cell where the data to be searched for would be
entered

•  Indicate the value the VLOOKUP function would use when
searching

•  Indicate the appropriate column reference

•  Indicate if you desire only exact search matches to be found. This box
takes either a TRUE or FALSE value.

•  Click OK



CARRYING OUT CONDITIONAL
MATHEMATICAL CALCULATIONS

Adding Up Values Satisfying a Single Specified Condition
This involves summation operation based on conditions being met. The

SUMIF function is used. It follows the syntax:
=SUMIF(cell_range,condition,range_of_summation)
The range_of_summation argument denotes where the cells holding

the values are to be summed. The formula can be implemented in this form:



=SUMIF (C7:C17, “Check”, D7:D17)
Adding Up Values Satisfying Multiple Specified Conditions
This operation uses the SUMIFS function. It has the syntax:
=SUMIFS(range_to_be_summed,condition_range1,conditio

n1,condition_range2,condition2,.....)
It is implemented as follows:
=SUMIFS(D7:D11,A4:A11,“True”,B4:B11,”<100”)
Adding Up Non-zero Values
Use a formula such as:



=SUMIF(D7:D17,”>0”)
Adding Up Values within a Specific Range of Date Use a formula such
as:



=SUMIF (C7:C11,”>5/31/2022”, C7:D11)
The SUMIFS Function

This function is used for aggregating values based on multiple
conditions. Other functions for multiple condition operations exist such as
AVERAGEIFS, COUNTIFS, etc.



AGGREGATING NUMBER OF VALUES
MEETING SPECIFIED SINGLE AND

MULTIPLE CONDITIONS
The operation uses COUNTIF and COUNTIFS functions for single and
multiple condition satisfaction respectively. They follow the syntax:

=COUNTIFS((cell_range1,condition1,cell_range2,condition2
,.....)
=COUNTIF((cell_range,condition)
Checking for Characters that are Non-standard
A simple formula exists to check for non-standard characters in your

worksheet. However, for this formula to execute its operation, you first
need to enter a VBA code in your workbook module;

•  Use keyboard keys ALT+F11 to launch the VBA console
•  Enter the code below and save

Function ContainsSpecialCharacters(str As String) As Boolean For I = 1
To Len(str)

ch = Mid(str, I, 1) Select Case ch
Case “0” To “9”, “A” To “Z”, “a” To “z”, ” “
ContainsSpecialCharacters = False



Case Else ContainsSpecialCharacters = True Exit For
End Select Next
End Function
You can now use this formula to check if cells contain special characters

or not

=ContainsSpecialCharacters(D7)



AGGREGATING THE AVERAGE
NUMBER OF VALUES MEETING

SPECIFIED SINGLE AND MULTIPLE
CONDITIONS

The operation uses AVERAGEIF and AVERAGEIFS functions for single
and multiple condition satisfaction respectively. They follow the syntax:

=AVERAGEIFS((cell_range1,condition1,cell_range2,conditio
n2,.....)

=AVERAGEIF((cell_range,condition) Summary
Conditional analyses are operations that depend on one or more

conditions being met before they can be successfully carried out. Excel
handles both single and multiple conditions. These conditions can be
logical, comparison, or mathematical. Numerous functions exist to carry out
operations on conditional analysis which were covered in this chapter. You
can also check if your cell entries contain special characters with the
ContainsSpecialCharacters function after working on your VBA console
for the module of your workbook.



CHAPTER SIX
IMPLEMENTING FORMULAS FOR LOOKUPS AND

MATCHING
AN INTRODUCTION TO FORMULAS IN EXCEL LOOKUP
The function, LOOKUP in Excel, search an input argument from a

single column or row range and gives a result from a different single
column or row range. It follows the syntax:

=LOOKUP(value_to_lookup,single_column/row_cell_range,[
result_range]))

The [result_range] argument is optional. This argument can be
included to indicate where the LOOKUP formula should implement its
search. Inclusion of the argument initiates a search in the
single_column/row_cell_range and gives a result from a similar location
in the result_range, otherwise, Excel gives the first data column. An
implementation of the formula is as follows:



=LOOKUP(10251, D1:D7, E1:E6)
=LOOKUP(10251, D1:D7)

Other LOOKUP formulas include:

•  Vertical Lookup with the function VLOOKUP
•  Horizontal Lookup with the function HLOOKUP
•  MATCH function
•  INDEX function



IMPLEMENTING THE FUNCTIONS IN
EXCEL LOOKUP

•  LOOKUP Function for Exact Result from a Left Column

Looking up values from left columns in Excel can be done with the
VLOOKUP and CHOOSE functions. This can be done with the formula



=VLOOKUP(F5,CHOOSE({1,2},D1:D7,C
1:C7),2,0)

F5 is the value or cell content to be looked up, the cell range D1:D7
is the column being looked up, and C1:C7 holds the result value.

•  LOOKUP Function for Exact Result from Any Column

This uses the VLOOKUP and MATCH functions. This lookup
technique allows you to look up both rows and columns simultaneously.
The formula is as follows:



=VLOOKUP(I9,C3:D11,MATCH(I3,C2:D
2,0),0)

I9 denotes the value to be looked up on the row
I3 denotes the value to be looked up on the column



•  Using VLOOKUP

This function looks up table value in a vertical direction. It follows this
syntax:

=VLOOKUP (the_lookup_value, the_cell_range,
column_number_index, TRUE/FALSE)

The argument column_number_index denotes the table column where
the_lookup_value is present

Argument TRUE indicates an approximate or close search match

FALSE indicates an exact search match

•  Using HLOOKUP for Horizontal Lookup

This function looks up table value in an horizontal direction. It follows
the syntax:

=VLOOKUP(the_lookup_value,the_cell_range,column_numb
er_index,TRUE/FALSE)





HANDLING ERRORS RESULTING
FROM EXCEL LOOKUP

The IFERROR function is used to handle #N/A errors in Excel Lookup.
This function can be used to detect the errors and then give a value of your
choice. The syntax of this function is as follows:



=IFERROR(VLOOKUP(the_lookup_value,the_cell_range,colu
mn_number_index,TRUE/FALSE),“message”)

The message argument denotes what you want to be displayed when the
error occurs, e.g.

=IFERROR(VLOOKUP(F7,B2:B8,3,FALSE),“Value not

found”)



SEARCHING FOR THE CLOSEST
RESULT FROM A GROUP OF VALUES

•  Using the MATCH and INDEX Functions

The INDEX function is implemented when searching for the indicated
location of a value in a range of cells. Its syntax is as follows:

=INDEX(cell_range, row/column_number)
The MATCH function however gives the position of a value in a range

of cells without indicating in the input formula. The syntax of the formula is
as follows:

=MATCH(the_lookup_value,the_cell_range,column_number
_index,TRUE/FALSE)



The MATCH and INDEX functions can however be combined to
create a Lookup formula that is dynamic, such that;

=INDEX(result_range,MATCH(the_lookup_value,the_cell_ra
nge,column_number_index,TRUE/FALSE))

•  Searching Out Values from Numerous Tables

The syntax is as follows:
=VLOOKUP(the_lookup_value,IF(condition,cell_range1,cell_

range),column_number_index,TRUE/FALSE)
An example of the formula implementation is:



=VLOOKUP(D7,IF(B4<2,G3:H9,J3:K9),2,FALSE)
•  Searching Out Values of Two-way Matrixes This procedure uses

the VLOOKUP and MATCH functions. The syntax to be used is as
follows:

=VLOOKUP(vertical_lookup_value, cell_range,
MATCH(horizontal_lookup_value, row_cell_range,TRUE/FALSE),
TRUE/FALSE)

Note that the cell_range argument does not include rows or the headers
for your table, it should only cover the cells containing data.

•  Using Multiple Criteria for Searching Out Values This procedure
follows this syntax:



{=INDEX(cell_range1,MATCH(TRUE/FALSE,(the_lookup_val
ue1=cell_range2)*(the_lookup_value2=cell_range3)*(the_loo
kup_value3=cell_range4),TRUE/FALSE))}



USING SUMPRODUCT FUNCTION TO
GIVE TEXT RESULTS

This function is also used for looking up two conditions, both in row and
columns simultaneously. It follows this syntax:

=SUMPRODUCT(vertical_lookup_column_range=vertical_lo
okup_value)*(horizontal_lookup_row_range=horizontal_look
up_value),cell_range)

An operator known as the double Unary operator (-) can be included in
the formula when dealing with Boolean tests. The operator is a conversion
of the usual TRUE/FALSE argument.

Looking Up a Concluding Column’s Value
When dealing with large data and the last column needs to be retrieved,

Excel made it easy to carry out this retrieval using the LOOKUP function.
=LOOKUP(2,1/(cell_range<>””),cell_range)
The expression cell_range<>”” denotes that the indicated cell range is

not empty. An example of the formula implementation is as follows:



=LOOKUP(2,1/(D:D<>””),D:D)
Referencing the cell range in this manner considers the whole column D,
regardless of the presence of empty cells. This formula would give the data
input in the last occupied cell in column D.



To handle possible errors in case the last value is an error so that Excel
gives a result, you can include the NOT and ISBLANK functions.



=LOOKUP(2,1/(NOT(ISBLANK(D:D))),D
:D)

To obtain the row number that the last value falls in, you can include the
ROW function in your formula:



=LOOKUP(2,1/(D:D<>””),ROW(D:D))
To obtain another value related to the last value being looked up, you can
switch the formula to this form:



=LOOKUP(2,1/(D:D<>””),E:E)
Looking Up a Concluding Column’s Numeric Value

If the last cell in the column contains numeric data, use the
ISNUMBER function:



=LOOKUP(2,1/(ISNUMBER(D:D)),D:D)
Summary

This chapter discussed how you can search out and reference values in
your data entry. Numerous Lookup functions exist in Excel to help users
avoid the stress of searching through large data to obtain particular needed
data. Note, however, that arguments labeled cell_range can also be replaced
with named cell ranges, while input values to be looked up can be replaced
with the actual data rather than its cell reference.





CHAPTER SEVEN
HANDLING FINANCIAL ANALYSIS WITH EXCEL FORMULAS

Executing Traditional Financial Calculations 1. Gross Profit
Margin

This value is mathematically expressed thus:
Gross Profit Margin = (Total Income or Revenue - Total Sales) ÷

Total Income
Each of these parameters can simply be referenced by their cells, such

as:



=(E8-E9)/E8



2. Percentage of

Gross Profit Margin



The previous calculation can be converted to percentage following these
steps:

•  Highlight the cell containing the previous result
•  Navigate to the Home menu
•  When in the Number section, select the Percentage option



3.

Dealing with Operating Profit Margin
This margin includes expenses such as rent, marketing, machinery, etc.

It should be converted to a percentage after it is calculated. The formula for
this is as follows:

Operating Profit Margin = (Total Income or Revenue - Total Sales -
Cost of Operation) ÷ Total Income



1. Dealing with Net Profit

Margin
This margin includes expenses such as taxes and interest, etc. It should

be converted to a percentage after it is calculated. The formula for this is as
follows:

Net Profit Margin = (Total Income or Revenue - Total Sales Cost of
Operation - Tax - Interest) ÷ Total Income

1. Dealing with Markup

Markup is mathematically calculated as:
Markup = (Price of Goods - Cost) ÷ Cost



Each of these parameters can simply be referenced by their cells.
Markup price is the additional amount included in a goods cost price as a
remedy for making a profit.



GENERATING EBITDA AND EBIT
EBITDA stands for “Earnings before Interest, Tax, Depreciation, and
Amortization”. An organization’s EBITDA can be realized by summing up
its net revenue, tax, interest, etc. It shows an organization’s income before
certain dues are deducted.

Mathematically, it is visualized as:
EBITDA = Net Revenue + Interest + Tax + Depreciation and

Amortization
EBIT however is used for determining an organization’s profitability. It

is expressed as
EBIT = (Total Sales - Cost of Sold Goods - Cost of Operation) ÷

Total Sales
It can be expressed as a percentage. An alternative formula is to use the

Net Income;
EBIT = (Net Income + Interest + Taxes) ÷ Total sales

GENERATING THE COST OF SOLD GOODS
Cost of sold goods is the expenses incurred by an organization during a

product’s production process, such as production materials, labor, etc. It can
be expressed as:

Cost of Sold Goods = Start-of-year Inventory + Purchases
Inventory – End-of-year Inventory



GENERATING ASSETS RETURN
This measure is also used to determine the profitability of a company and
should be converted to a percentage. It can be calculated as follows:

Return on Assets (ROA) = Profit ÷ Assets GENERATING EQUITY
RETURNS

This is calculated and then converted to percentage in Excel using the
cell references holding these parameters:

Return on Equity (ROE) = Profit ÷ Capital of Equity
A key difference between ROA and ROE is that ROA enables investors

to decide how an organization manages and channels its resources and
assets to generate profit; while ROE enables investors to decide how well
their investments bring about profitmaking.

However, both are measures of an organization’s profitability.



GENERATING BREAK EVEN
Break-even denotes zero profits and loss. The organization neither gained
nor lost in the sales of its goods. The break-even point for a company
occurs when the summation of fixed expenses and variable expenses, such
as labor, amounts to the total revenue realized. This can be mathematically
expressed thus:

Fixed Expenses + Variable Expenses = Revenue
VARIATIONS OF BREAK-EVEN CALCULATION These can
be calculated in per unit, percentages, or as a total

•  Break-Even for Sales

This is calculated to enable a company to determine the needed cost to
keep the organization functional. It is calculated as follows: Break-Even
for Sales = Fixed Expenses ÷ Contribution Ratio Where the
Contribution Ratio is calculated as Variable Expenses

÷ Revenue

•  Break-Even for Sold Units

An organization implements this to determine the number of units that
are needed to be sold to attain a point of break-even. It is calculated as:

Break-Even for Sold Units = Fixed Expenses ÷ (Unit Price Unit
Variable Expenses)



USING GOAL SEEK FOR BREAK-
EVEN

•  Open a worksheet and enter necessary data as follows:

•  Use these formulas to fill in needed parameters Revenue = Unitary price
* Sold units

Variable Expenses = Unit cost * Sold units
Profit or Gain = Revenue - Variable Expenses Fixed Expenses

•  Navigate to the Data menu and select the option for analyzing

What-ifs

•  Select the Goal Seek option from the drop-down menu
•  Carry out the following indications in the resulting dialogue
box:
•  Enter the cell for Profit in the Set cell box
•  Type in 0 in the next box
•  The Cell Changing box should be set to the cell referencing

Unitary Price

•  Click on OK
•  Select OK in the next dialogue box

This action changes the Profit value to 0 because there is no profit
realized at break even. It also calculates the approximate price the



goods are required to be sold at for the indicated Sold Units.
GENERATING CUSTOMER CHURN

This measure indicates the number of buyers or customers that stop
purchasing a particular product over a certain period. It is otherwise known
as Rate of Attrition and calculated as follows:

Rate of Attrition = Number of Customer Churn ÷ Total Customer
in a Given Period

This calculation is essential in business analysis to prevent running into
excess loss due to a shortage of customers purchasing a product.



GENERATING ANNUAL RATE OF
CHURN

This is calculated by setting the value for Total Customer in a Given
Period to the customer number at the beginning of a year, i.e.

Rate of Attrition = Number of Customer Churn ÷ Total Customer
at Year Start



GENERATING THE AVERAGE VALUE
OF A CUSTOMER LIFETIME

This is the total amount received from a customer from starting period to
the time of churn. This value is calculated as follows: Average Customer
Value = Average Size of Transaction * Number of Purchases * Period of
Purchase



GENERATING TURNOVER OF
EMPLOYEES

Turnover of employees is similar to churn of customers. It describes the
unit or percentage of employees that left an organization within a period. It
can be calculated as follows:

Annual Turnover of Employees = Number of Departed Employees ÷
Total Average of Employees

Total Average of Employees = (Employee Number at the Start of
the year + Employee Number at the End of the Year) ÷ 2
IMPLEMENTING FUNCTIONS FOR FINANCIAL OPERATIONS
IN EXCEL

•  Calculating Rate of Interest

This can be done using the RATE function as follows:
=RATE(Time,Periodical_Payment,Principal)



•  Calculating Rate of Effectiveness Using FV

FV in Excel denotes Future Value. It generates the total amount accrued
over an investment, depending on a predefined rate of interest. The FV
syntax is as follows:

=FV(Rate,Time,Periodical_Payment,[Capital],[Type_of_Pay ment])
Capital and Type_of_Payment arguments are optional. The

Type_of_Payment argument denotes when the amount due is to be paid.
The argument takes two values:

-  0 denotes payment at the end of the specified period. It can be omitted
in the formula.

-  1 denotes payment at the beginning of the specified period.
DESIGNING A CALCULATOR FOR LOAN REPAYMENT

Generating a Schedule for Loan Amortization The functions
involved in designing this calculator are as follows:

-  PMT function for deriving the amount of total payments over the set
period

-  PPMT function for deriving the amount of principal for every
payment

-  IPMT function for deriving the interest on every payment Follow
these steps to design a schedule for loan amortization:

• 

Make a data entry such as this:
•  Enter a serial numeric order in the Period column



•  Highlight the first cell in the Payment column to calculate the amount of
total payments over the set period using this syntax:

=PMT((Annual_rate_of_interest ÷ Number_of_payment_periods),
(Loan_duration * Number_of_payment_periods),Amount_of_Loan)

Annual_rate_of_interest ÷ Number_of_payment_periods is for
generating the periodic rate

•  Ensure to use absolute referencing when writing your formula to
prevent changes in your cell values.

• 

Using the drag and fill procedure, autofill the Payment column

•  Highlight the first cell in the Interest column to calculate the interest on
every payment using this syntax: =IPMT(Periodic_rate, Payment_period,
(Loan_duration *



Number_of_payment_periods), Amount_of_Loan))
Note that the Payment_period argument is to be referenced relatively

so that the calculation is done based on the period value of each row.

• 

Using the drag and fill procedure, autofill the Interest column

•  Highlight the first cell in the Principal column to calculate the amount of
principal for every payment on every payment using this syntax:



=PPMT(Periodic_rate, Payment_period,(Loan_duration *
Number_of_payment_periods), Amount_of_Loan)

•  Using the drag and fill procedure, autofill the Principal column

•  To calculate the Balance of the loan for the first cell:

•  Highlight the first cell under the Balance column use this formula
with relative cell referencing:

Balance_for_Period1 = Amount_of_Loan + Principal_for_Period1
•  For subsequent Balance cells, implement this formula:

Balance_for_Period2 = Principal_for_Period2 Balance_for_Period3 =
Principal_for_Period3 Balance_for_Period4 = Principal_for_Period4
Balance_for_Period1 +

Balance_for_Period2 + Balance_for_Period3 +

•  This formula continues until the end of the 24-month period.



An amortization schedule can be easier created using the Excel built-in
Amortization template.

•  Launch Excel and navigate to New

•  Search and select the option for an Amortization Schedule from the
gallery for templates



•  Enter your beginning data in the appropriate spaces provided

•  Excel then uses this data to calculate every necessary data





COMPUTING DEPRECIATION
Computing Accelerated Depreciation

Accelerated depreciation occurs when the value of an asset reduces
faster than is expected. This form of depreciation does not obey the usual
steady straight-line principle. Excel uses the DDB function for this
calculation, which is known as Double Declining Balance. The syntax is as
follows:

=DDB (Asset_cost, Ending_salvage_value, Asset_life,
Depreciation_period, [Rate_of_depreciation])

The Rate_of_depreciation argument is optional in the formula. It
denotes the rate of reduction in the asset cost. Excel sets the default value at
2 if not specified.



COMPUTING CURRENT VALUES
Computing the Current Value of Future Payments

The PV function calculates the current value of payments. The syntax is
as follows:

=PV(Rate,Time,Periodical_Payment,[FP],[Type_of_Payment]  )
FP (future payment), Type_of_Payment arguments are optional.



COMPUTING NET CURRENT VALUE
Computing Negative and Positive Flow of Cash

The calculation of net current values using the NPV function employs a
rate of discount and a forecasted flow of cash. The syntax is as follows:

=NPV(Discount_rate,cash_flow_value1, [cash_flow_value2], ...)



The cash_flow_value argument is a reference to a range of cells.



COMPUTING INTERNAL RETURN
RATE

Computing Non-periodic Future Flow of Cash
Excel uses the XIRR function for this calculation. The function has the

following syntax:
=XIRR(cash_flow_value, cash_flow_dates, [Estimate IRR])
The Estimate IRR function is optional and denotes an estimated value

for the internal return rate. It is usually expressed as a percentage. Excel
assigns a default value of 10% or 0.1 if not specified.



CARRYING OUT FINANCIAL
FORECAST

Time-based historical data are needed for carrying out the financial forecast
in Excel. Financial forecasts help to predict income flow, trends, sales, etc.
When the option for a forecast is selected, Excel creates the forecast chart
in another worksheet, along with a forecast table containing the input data
and the forecasted values.

•  Open an Excel worksheet and create a data entry having dates or
times and values which correspond, such as sales

•  Highlight your input data and navigate to the Data menu



• 

Select the option for a Forecasting Sheet

•  Choose the type of chart desired, either a line or column chart in the
resulting dialogue box

•  Also, select an ending date for the forecast and then click on

Create



Summary
Excel has a provision for major financial operations that the user would

need to be executed in a straightforward and presentable format. This
chapter explained and discussed various financial analytic values, ranging
from EBITDA, profit margins, break-even, customer churn, and the



computation of future values, Excel provides easy representation and
formulas for these calculations.

Built-in functions such as NPV, DB, PV, FV, etc. also exist for easy



value computation. The stress of manually creating an Amortization
Schedule for Loan repayment is also taken care of by implementing a
corresponding Excel template.





CHAPTER EIGHT
HANDLING WEIGHTED AVERAGES Adding Moving

Averages to Your Data
The tool for Exponential Smoothing is used in Excel for handling

moving averages. The averaging weights of exponential smoothing are such
that current values are made to have more effect in the calculation of the
average, while the effect of the existing values is reduced. Computing the
averaging weights for moving averages using exponential smoothing
involves a constant for smoothing.

Follow these steps to compute the averaging weights for moving
averages:

•  Prepare your data such as this:

Navigate to the Data menu and select the option for Analysing Data

•  Select Exponential Smoothing in the resulting dialogue box and
click on the OK button

•  This action brings up the Exponential Smoothing dialogue box
•  Enter the cell range for your data in the box for range input

•  Specify a constant for the smoothing in the labeled box for
Dampening. Excel suggests using a value between the range of 0.2 to 0.3.
You can indicate higher values if desired.

•  Specify the cell range for your output data



•  If you desire a chart, select the corresponding box for the exponential
smoothing chart

•  Also, indicate to include the possible errors which are standard by
selecting the appropriate box. (These two previous steps are optional)

•  Select OK



CREATING DESCRIPTIVE
STATISTICS USING FORMULAS

The menu for analyzing data in Excel holds the option for performing
descriptive analysis. Values such as mean, mode, deviation, variance, etc.
can be easily calculated with a click.

Generating the Biggest, Smallest, Mean, Mode Values
(Summarizing Statistics)

•  Prepare your data in this format:



•  Navigate to the Data menu and select the option for Analysing Data

•  Select Descriptive Analysis from the available menu
•  This action brings up the Descriptive Analysis dialogue box

•  Enter the cell range for your data in the box for range input
•  Specify the cell range for your output data
•  Select the box for Summarizing Statistics



•  Select OK



Computing the

Kth Smallest and Largest Value
•  In the Descriptive Analysis dialogue box, select the box for Kth

largest or smallest value

•  Specify the cell range for your output data and select OK



The default value for the Kth largest or smallest is 1, but it can be
edited to any number of your choice. Entering 4 for instance would give
you the 4th largest or smallest value in your data. A change in the dataset
would require another procedure of the descriptive analysis.

Dividing Data into Percentiles
Percentiles can be calculated using the PERCENTILE function:
=PERCENTILE(data_range, percentile_value) percentile_value is

usually expressed in percentage, e.g.



=PERCENTILE(D2:D15, 0.4)
This formula calculates the 40th percentile.

Quartiles can also be calculated using the QUARTILE function:
=QUARTILE(data_range, quartile_value)
The quartile_value depends on the amount of data. Quartiles are

usually a division of four, i.e. it splits the data into four parts.
Relating Quartiles to Percentiles goes thus:

•  First Quartile = 25% Percentile
•  Second Quartile = 50% Percentile
•  Third Quartile = 75% Percentile
•  Fourth Quartile = 100% Percentile



Recognizing Interquartile Ranges in Statistical Outliers
This process follows these steps:

•  First, make a data entry such as this:

•  Compute the first and third quartiles using these formulas
respectively:

=QUARTILE(data_range, 1)

=QUARTILE(data_range, 3)
•  Compute the interquartile range using this formula Interquartile

Range = First Quartile - Second Quartile

•  Compute the lower boundary



LB = First Quartile - (Interquartile Range * 1.5)

•  Compute the upper boundary

UB = Third Quartile + (1.5 * Interquartile Range)



•  Compute the Outliers

Outliers are the values below the lower boundary and above the upper
boundary. The OR function is used to compute the outliers:

=OR(cell_reference<Lower_boundary,cell_reference>Upper
_boundary)
Ensure to set the Lower_boundary and Upper_boundary cell

references to absolute references. The result of this calculation is either
True or False.

GENERATING A FREQUENCY DISTRIBUTION A frequency
distribution can be generated using the FREQUENCY formula:
=FREQUENCY(cell_range, data_range) Alternative to

FREQUENCY Function
The COUNTIF function can also be used in place of the
FREQUENCY function for computing frequency distribution.
=COUNTIF(cell_range, cell_data)
Use the drag and fill method to fill up other cells. You can first use the

UNIQUE function to sort out the distinctly available data in the
distribution. These are called Bins.



=UNIQUE(cell_range)
Summary
This chapter explained weighted moving averages and how they can be

calculated using exponential smoothing. It also discussed descriptive
analysis, how the Data Analysis option in Excel easily computes these
values in a click, percentile, and then, the functions for computing
frequency distribution.





CHAPTER NINE
IMPLEMENTING FORMULAS IN TABLES AND CONDITIONAL
FORMATTING SELECTING CELLS SATISFYING INDICATED
CRITERIA

Excel allows you to highlight cells depending on the value of a separate
cell using conditional formatting.

•  Navigate to the Home menu and select the Conditional Formatting
option

•  Choose the option to define a rule



• 

Select the option as shown below in the resulting dialogue box

•  Enter your formatting condition in the formula bar This example chooses
to highlight cells having lesser values than that in cell B3, the formula
therefore used is as follows:



=E3<$B$3
•  Click on Format to determine how Excel highlights the cells

• 

Click on OK when done



HIGHLIGHTING DATA EXISTING IN
LIST 1 BUT ABSENT



IN LIST 2
•  When in the Conditional Formatting dialogue box, enter the

comparison formula below:



=COUNTIF($B$4:$B$16,E4)=0
This formula evaluates the cell values in cell E4 which is the cell the
formatting is to be applied and checks for similar values in the indicated
cell range. An absence of a similar value gives 0 which Excel then
highlights. Absolute referencing is used in referencing the cell range to
make its values static.

•  Apply your highlight formatting by selecting the Format

option and then clicking OK



HIGHLIGHTING SIMILAR VALUES IN
LIST 1 AND LIST 2

When in the Conditional Formatting dialogue box, enter the comparison
formula below:



=COUNTIF($B$4:$B$16,E4)>0
This formula evaluates the cell values in cell E4 which is the cell the
formatting is to be applied and checks for similar values in the indicated
cell range. Detection of a similar value gives a result greater than 0 which
Excel then highlights. Absolute referencing is used in referencing the cell
range to make its values static.

•  Apply your highlight formatting by selecting the Format option and
then clicking OK





HIGHLIGHTING VALUES DEPENDING
ON THE DATE

1. Highlighting the Days Present between Two Dates

•  When in the Conditional Formatting dialogue box, enter the comparison
formula below:



=AND(E3>=$B$3,E3<=$C$3)
This formula compares the dates in cells B3 and C3 with those in



E3.
•  Apply your highlight formatting by selecting the Format option and then
clicking OK.



1.  

Highlighting Dates Depending on Date Due

•  When in the Conditional Formatting dialogue box, enter the



comparison formula below:



=TODAY()-C4>90
This formula considers the current date and the next 90 days which is the
due date. If the date in cell C4 is greater than this date, Excel then
highlights the cell.

•  Apply your highlight
formatting by selecting the Format option and then clicking OK.



Summary

This chapter explained how conditional formatting can be applied in
Excel tables by using formulas to determine what cells to highlight.
Depending on the specified criteria, the cell(s) satisfying the indicated
condition is highlighted, making such values easier to locate and work with.

CHAPTER TEN
GETTING FAMILIAR WITH THE USE OF ARRAY FORMULAS
ARRAY FORMULAS
These arrays are of two forms which are as follows:

1. Multi-cell Formula Array

This formula gives a result in more than one cell at a time. It uses the
ROW function.

•  Highlight multiple cells that would hold the formula result
•  Enter this formula in the bar for formula



{=ROW(1:20)}
•  Press keyboard keys Ctrl + Shift + Enter

This formula enters a serial number of 1 to 20 in the highlighted cells. The
content of these cells cannot be edited; neither can cells be added because
they contain a similar formula. Also, to edit the formula, the entire cell
range must be selected.



Rows can be converted into columns using the TRANSPOSE
function as follows:

•  Prepare a data entry such as is shown below:

•  Highlight multiple cells which would hold the formula result. Ensure
the highlighted cell range would be equivalent to the transposed result

•  Press key F2 to initiate the mode for editing
•  Enter this formula with respect to your data cell range:



=TRANSPOSE($A$1:$D$5)
•  Press keyboard keys Ctrl + Shift + Enter
•  You should get a result like this:



1. Single Cell

Formula Array
This formula gives a result in a single cell. Just a cell is needed to be

highlighted when performing this operation. It uses the MAX function for
example as follows:



=MAX(cell_range1-cell_range2)

Press keyboard keys
Ctrl + Shift + Enter after entering your formula in the bar for formulas.



CREATING ARRAY CONSTANTS
Array constants are declared in curly braces {} in your array formula. They
are hard codes values for customizing multiple values simultaneously.
Including array constants in your formula usually gives multiple results, for
instance:



=LARGE(B3:B9,{1,2,3,4})
This formula gives a result of the four highest numbers in the data range.
These results can however be manipulated into one by introducing another
function, such as SUM;



=SUM(LARGE(B3:B9,{1,2,3,4}))
Note that cell references and functions cannot be entered as a parameter

in the curly braces.



ARRAY DIMENSIONS
1. One-dimensional Arrays



These are usually arranged data in a single line, either in a row or a column.
They are of two forms:

•  Horizontal One-dimensional Array

This type of array is also known as data arranged in a row. They are
created by separating the array constant with a comma, for instance:

=SEQUENCE(1,5) or {={1,2,3,4,5}}
Ensure to highlight adequate cells and then press keyboard keys Ctrl
+ Shift + Enter after entering your formula in the bar for formulas.

•  Vertical One-dimensional Array

This type of array is also known as data arranged in a column. They are
created by separating the array constant with a semicolon, for instance:

=SEQUENCE(5) or {={1;2;3;4 5}}
Ensure to highlight adequate cells and then press keyboard keys Ctrl
+ Shift + Enter after entering your formula in the bar for formulas.

1. Two-dimensional Arrays



These are also called matrices. They can span over multiple cell rows
and columns. Here, row data are separated with commas and column data
with a semicolon. For example:

{={“a”, “b”, “c”; 1, 2, 3}}
=SEQUENCE(3,4) signifying 3 columns and 4 rows. It can also be

written as:



{={1,2,3,4;5,6,7,8;9,10,11,12}}
Ensure to highlight adequate cells and then press keyboard keys Ctrl
+ Shift + Enter after entering your formula in the bar for formulas.



ASSIGNING NAMES OF ARRAY
CONSTANTS

•  Navigate to the Formula menu and select the option for defining names.
You can also use keyboard keys Ctrl + F3.

•  Select the option to define a New name
•  Enter a desired name in the appropriate box when the Name

dialogue box comes up

•  Enter your array constant in the provided box and select OK



You can use your named

constant as follows:

{=Days}
DEALING WITH FORMULAS FOR ARRAYS Entering
Formulas for Arrays
Type in your formula in the bar for formulas and then press keyboard

keys: Ctrl + Shift + Enter.
Highlighting Ranges of Formulas for Arrays
Highlighting as many cells as would accommodate your input array

formula. You can also use keyboard keys Ctrl + / to highlight the whole
array after entering it in your worksheet.



Making Changes to Formulas for Arrays
When highlighting array formula cell ranges for editing:

•  Select one of the cells in the array
•  Press keyboard keys Ctrl + / to highlight the whole array

•  Press key F2 to initiate the edit mode. You can then edit your array
formula in the bar for formulas

•  Press keyboard keys Ctrl + Shift + Enter after editing to effect the
changes

Adding or Removing from a Multi-cell Array To add cells to the
array:

•  Highlight the cells containing the array formula and also the
additional cells to be covered

•  Press key F2 to initiate the mode for editing

•  Expand the previous cell range to accommodate the additional
highlighted cells

•  Press keyboard keys Ctrl + Shift + Enter after editing to effect the
change

To remove cells from the array:

•  Highlight the cells containing the array formula
•  Press key F2 to initiate the mode for editing

•  Press keyboard keys Ctrl+Enter to initiate a mode to enter a similar
non-array formula in the selected cells

•  Edit the selected range to remove the excess cells
•  Press key F2 again to initiate the mode for editing

•  Press keyboard keys Ctrl + Shift + Enter after editing to effect the
change

Deleting Formulas for Arrays

•  Highlight the cell(s) containing the formula
•  Navigate to the Home menu and select the Find option in the



Editing tab

•  Select Go To and then choose Special
•  Select the option for the currently highlighted array
•  Select Delete



IMPLEMENTING FORMULAS FOR
MULTICELL ARRAYS

Generating Arrays from Range Values
This uses the ROW and INDIRECT functions with the following

syntax:
{=ROW(INDIRECT(start_range&”:”&end_range))}  E.g.:



{=ROW(INDIRECT(A2&”:”&B2))}



{=ROW(INDIRECT(“1:5”))}
This formula populates five rows in serial order
Generating Array Constants from Range Values

•  Create a table data entry as shown below

•  Navigate to the bar for formulas and type in a formula with your
desired function such as:



=SUM(A2:A6)
•  Highlight the parameter A2:A6 and press the F9 key This changes the
formula to an array constant:



=SUM{1;2;3;4;5}
Implementing Functions with Arrays

•  The SEQUENCE function can be used to generate an array, such as:
=SEQUENCE(5) or {={1;2;3;4 5}}

•  The SUM function sums up the array, such as:



=SUM(LARGE(B3:B9,{1,2,3,4}))
•  The LEN function counts the number of every character in a string array,
such as:



=LEN(C9:C13)
•  The AVERAGE function gives the average number of every character in
a string array, such as:



=AVERAGE(LEN(C9:C13))
Other functions include INDEX, MAX, MATCH, SMALL, ROW,
INDIRECT, TRANSPOSE, etc.

Creating an Array of Serial Integer
The ROW function can be used for this:
{=Row(1:12)}
This formula creates a row array of numbers 1 to 12.



IMPLEMENTING FORMULAS FOR
SINGLE-CELL ARRAYS

Determining Number of Characters in a Range This uses the
SUM and LEN functions.



=SUM(LEN(C9:C13))



Getting the Summation of the Three Lowest Values in an Array



=SUM(SMALL(A1:D10,{1,2,3}))
This formula first gets the values of the lowest three numbers in the array
range and then carries out the summation operation. The formula
=SUM(LARGE(A1:D10,{1,2,3})) sums up the highest three numbers in an
array range.

Calculating Number of Cells Containing Text in a Range Excel uses
the COUNTIF function for this with the following syntax:

=COUNTIF(cell_range, “*”)
The asterisk in the argument denotes text.
E.g =COUNTIF(D7:D15, “*”)



Removing Intermediate Formulas

•  Highlight the cells containing these formulas

• 

Right-click and select the option to Copy or use keys Ctrl + C
•  Make another right-click and select the option to paste only
values



The paste and copy section

of the Home menu can also be used.



Implementing Arrays in Place of Cell

References
After inserting a formula with a cell range argument in the bar for

formulas, you can use the F9 key to change the cell reference to an array.
Summary
Arrays enhance data input because it allows you to enter multiple data

at a time. Two types of arrays exist in Excel, depending on the user’s need,
which is one-dimensional and multidimensional arrays. Functions can also
be included in the formula for arrays to boost data analysis. You can also
transpose an existing array to change its orientation as desired. This chapter
explained the ways you can create, edit, expand and shrink an array. Your
array formulas can also be deleted if no longer needed.





CHAPTER ELEVEN
CREATING ERROR-FREE FORMULAS LOCATING AND
RECTIFYING ERRORS IN YOUR FORMULAS

Sometimes, input formulas may contain errors unknown to the user,
probably due to typing too fast, not being familiar with the appropriate
syntax, inappropriate closing of brackets, etc. When you have a long,
confusing formula, locating the point of error may get difficult. Excel,
however, provides easy ways to locate and rectify errors that may be present
in your formula.

Incomplete Parentheses



Entering a formula such as =B1/(1+B2 and pressing the Enter key
brings up the Excel formula to notify you of the error. The dialogue box
also gives you a suggestion for the rectification, just click the Yes option to
accept.

If the Excel suggestion is not what you intend, select No and then edit
the formula correctly.

Cells Containing Hash Marks
Hash marks are displayed in cells when Excel detects a cell holding

more characters than it can hold. This is known as an overflow.
Correcting this requires you to expand the cell or make the column

wider to accommodate your input.

Another cause of hash marks in cells can also be incorrect cell
formatting. Take, for instance, cells in Excel can take texts of up to 32,000
characters, but formatting a cell to Text reduces this to 255 text characters.
If a cell displays a hash due to the overflow of a Text formatted cell, you
only have to change the cell formatting to General to accommodate over
255 text characters.

Entering date values beyond the acceptable date range in Excel
(1/1/1900 up to 12/31/9999) causes the hash error as well. Clearing Blank
Cells that Hold Values

Cells can hold hidden data which would appear blank; you can clear
these cells following these steps:



•  Navigate to the Data menu and select the Filter option

•  Click on the drop-down arrow in the desired column
•  Deselect all other boxes except the Blanks box

•  Select OK
•  Select the seemingly blank cell and press the Delete key



You can remove the filtering by navigating to the Filter option in the
Data menu
The Special Pasting menu can also be used to clear these types of cells.

Select the option to only paste the values when in this Special menu.



Characters Having

Excess Spaces
The TRIM function can be used to delete excess spaces in characters.

Use the following syntax:
=TRIM(cell_reference)
E.g. =TRIM(A7)



You can

likewise use the Replace and Find dialogue box.
Highlighting Cell Containing Excess Spaces in Its Characters
•  Press the keyboard shortcut keys Ctrl + H to launch the Replace and

Find dialogue box



•  In the Find bar, press the Space bar key two times
•  In the Replace bar, press the Space bar key once
•  Select the option for Replacing All

Solving Formulas Giving an Error
Excel formulas can result in various types of errors, depending on what

causes the error. Examples of such errors and how they can be solved are:
Errors of #DIV/0!
This error is displayed when an attempt is made to divide a number by

zero. This can be corrected by correcting the divisor in your formula to a
non-zero value or a cell reference having an appropriate value.

You can make use of the IFERROR function to determine the result or
message Excel should display if an error should occur.

=IFERROR(A6/D6,“Please enter a valid divisor”)
This formula tells Excel to display the message “Please enter a valid

divisor” if it runs into this error.
Errors of #N/A
This error occurs when Excel cannot find the expected value in the

referenced cell. This error is mostly prone to occur when using functions
such as HLOOKUP, MATCH, or VLOOKUP. It can be corrected by
providing the right cell reference or parameter in the formula.



The IFERROR function can then be used to configure your desired
error message or Excel action.

Errors of #NAME?
Excel gives this error when it cannot identify a function or a cell range.

For example:
=MIN(CC:D7) has an unidentified cell range of CC as a parameter.
=VLOKUP(D3,A3:B7,2,0) has an unidentified function of

VLOKUP as a parameter.
The error can be rectified by providing the correct cell range or

function.
Errors of #NULL!
This error occurs when cell references are separated with a space.



Adding a semicolon or a



comma fixes this error.
Errors of #NUM!
Excel gives this error when a calculation is impossible. For example,

calculating the root of negative numbers, or using the SORT function
inappropriately.

Entering correct inputs or parameters solves this error. Errors of #REF!
This error is thrown if Excel fails to recognize the specified cell

reference. It can occur when referencing cells in deleted worksheets,
deleted columns or rows, etc.

Use valid and correct references to rectify this error. You can clear
numerous #REF! errors using the Replace and Find dialogue box as
shown below:

Errors of #VALUE!
This error occurs when the entered data is not the appropriate type,

probably as a result of cell formatting. For instance, entering a



numeric value in a Text formatted
cells, or entering a text in a formula or function that demands numeric
values.



You can correct this error by inserting the appropriate type of values
where necessary.

The IFERROR function can be used to define your desired error
message or Excel action for major types of Excel errors. You can also
search to view all errors in your formulas using the Special Go To dialogue
box. A press of key F5 and a selection of Special launches this dialogue
box.



Problems with Precedence of

Operators



By default, Excel treats precedence of operators in this order:
A formula containing multiple operators having a similar level of

precedence is handled from the left direction to the right. A simple addition
of parenthesis can change the priority Excel gives to operators. Consider
this example; by default, the multiplication operator is given higher
precedence in this formula:



=A2+B2*C2
Introducing parenthesis in this form =(A2+B2)*C2 changes the order of

precedence to give a different result:

Solving Issue of Formulas not Performing Calculations Three
possible ways exist to fix the issue of Excel formulas not executing
calculations.

1. Ascertaining Calculation Mode



•  Navigate to the Formula menu and select the Option for

Calculations
•  In the drop-down menu options, select the Automatic option if not

selected

1. Confirming your Cell Formatting Option

•  Highlight the cell where you are to have the result of the non-
calculating formula

•  Navigate to the Home menu and select the option for
formatting

•  If it is set to Text, change the setting to Numbers. In Excel, a cell
formatted as a text ignores input formulas.



•  Re-enter your formula in the bar for formulas and press the
Enter

key.

1. Check the Status bar and confirm Excel is not flagging a



Circular Reference.
Circular reference refers to a formula containing a cell reference

parameter that refers to itself. Simply correct the cell reference and initiate
your calculation again.

The Precision of Decimal Issues

• 

Navigate to the File menu
•  Select Options

•  Select the Advanced option from the left menu
•  Select the option to set the precision of decimals as displayed



•  Select OK again when Excel gives a warning

•  Select OK

•  Navigate to the Home menu and then select the precision of decimals
desired.

Solving Errors of Phantom Links
Phantom links can be of this format
=’G:\Company\Solutions\Phantom Links\[Cash Financial

Model.xlsx]IS Flow OF CASH’!$D$5



They are inserted in worksheets as a result of copying data from
external sources or workbooks. Phantom links are simply external links that
reference input in your worksheet.

Phantom links can be deleted via any of the following procedures: 1.
Using the Manager for Names



•  Navigate to the Formula menu and select the option for managing
names

•  In the resulting dialogue box, select the link to be deleted and click on
the Delete option

1. Using the Manager for Rules

•  Navigate to the Home menu and select the option for managing rules
•  In the resulting dialogue box, select the link to be deleted and click on

the Delete option

1. Using the Find Menu

•  Press key F5 or Ctrl + G
•  Select the option for Special and then OK
•  Select Objects in the next menu and click OK



This option highlights all
the objects in your worksheet, both the displayed and hidden ones

•  Select Delete

•  Repeat this procedure if you have numerous sheets. 4. Using the
Replace and Find Dialogue Box

•  Press keys Ctrl + F to launch the Replace and Find dialogue
box

•  Enter any part of the phantom link (refer to the given format above).
Values such as =[ or ! can be used.

•  Check all sections available in the Look drop-down





•  You can then delete the links when found.



IMPLEMENTING TOOLS FOR
AUDITING IN EXCEL

Highlighting Cells of Particular Features

•  Select the particular cell range, row, or column

•  Press the key F5 and then select Special to launch the corresponding
dialogue box.

•  Select the box for any desired criteria or feature that you want to
identify



The TYPE

dialogue box or function can also be used.

•  Prepare a data entry as shown below



•  Navigate to the Formula menu and select the option for additional
functions



• 

Select Information and click on TYPE from the list dropdown
•  This action launches the corresponding dialogue box
•  Select the cell containing the data to be checked and click OK



The TYPE function can also be used directly with the syntax:
=TYPE(cell_reference)
E.g. =TYPE(B4)

Excel returns a set of numbers that denotes the data Type. These
numbers are:

•  1 denotes a numeric data type
•  2 denotes a text data type
•  4 denotes a logical or Boolean data type
•  16 denotes an error
•  64 denotes an array

When checking for array types, the formula syntax does not take the cell
reference as a parameter; the array itself is needed to be entered in the
formula, such as:



{=TYPE{{1,2,3}}}
Viewing Your Formulas

By default, when you select a cell in Excel, the background formula in
the cell can be seen in the bar for formulas. The Formula menu can also be
used following these steps:

•  Highlight the cells containing formula results
•  Navigate to the Formula menu
•  Select the option to Show your Formulas



You can otherwise use keyboard keys Ctrl + ` after highlighting the
cells. The key (`) known as the grave accent key is found above the Tab
key. Another press of these keys hides the formulas.

The FORMULATEXT function can be used to display the formula in
cells adjacent to the data cells.



=FORMULATEXT(D7)
IDENTIFYING RELATIONSHIPS BETWEEN CELLS
Recognizing Precedents

•  Select an empty cell close to your data

•  Navigate to the Formula menu and select the option for Tracing
Precedents in the Auditing Formulas group.



Precedents show the values used for another highlighted value. In the
diagram below, it is shown that all the input Amount was used to get the
Total value.

Recognizing Dependents

•  Select an empty cell close to your data

•  Navigate to the Formula menu and select the option for Tracing
Decedents in the Auditing Formulas group.

Decedents show the values on which another highlighted value depends.
In the diagram below, it is shown that the cost for each person is dependent
on the size of the group.



•  The arrows can be removed by selecting the tab to remove
them.



TRACKING ERROR VALUES
•  Select the cell to be checked for an error

•  Navigate to the Formula menu and select the option for Checking
Errors in the Auditing Formulas group. For instance, to check for circular
reference errors: The Error Tracing option can also be used

•  Selecting this option brings up lines in red on your worksheet.



They are drawn to show the source of the error.
•  The diagram above shows that an error resides in B5 which was

passed to C2, resulting in the error in cell C8. Correcting the value in B5
rectifies the error and the lines become blue

•  Select the option to remove the tracing arrows in the Formula

menu.

•  If an error is traced to another worksheet, Excel shows the trace in
this form:



Evaluating

Formulas

•  Select the cell to be evaluated holding a formula or a formula
result
•  Navigate to the Formula menu and select the option for

Evaluating Formulas in the Auditing Formulas group
•  Click on this option the number of times corresponding to the number

of arguments you have in your formula.



For instance, to evaluate =SUM(A1+B2), click on the Evaluate
option three times
To evaluate =SUM(A1+A2+A3+A4), click on the Evaluate option four

times. However, the expression =SUM(A1:A4) requires a two- time press
of the Evaluate button.

•  Excel then shows the result of the formula after evaluating each part
(argument) of the formula.



Using the

Excel Background Feature for Checking Errors
When the background feature for checking error is turned on, Excel

shows errors as a green colored triangle



Otherwise, the hash errors are displayed:



To turn on this background

feature:

•  Navigate to Option in the File menu

• 

Select Formulas from the left menu
•  Check the box to turn on this error checking feature



•  Select OK

FINDING AND REPLACING CELL VALUES You can search
and replace cell values using the Find dialogue box. The dialogue box

can be launched using keys Ctrl + H. Finding Information

•  Navigate to the Home menu and select the Find and Select tab
•  Select the Find option in the drop-down menu Format Search
•  Navigate to the Replace option in the Find and Select drop-
down



menu

•  Select Options in the dialogue box
•  Click on the Format option in front of the Find box



•  This opens the Format Finding dialogue box
•  Choose the needed formatting and select OK



•  Click on the Format option in front of the Replace box
•  Select the new replacement formatting and select OK



•  Select the option for replacing all corresponding formatting or any
other desired option

•  Select OK and then Close the dialogue box

Performing Spell Checks in Your Worksheet

• 

Navigate to the Review menu and select the Spelling tab
•  This launches the Spelling dialogue box



Keyboard key F7
can be used after highlighting the cells on which the spell checks are to be
done.



IMPLEMENTING AUTOCORRECT IN
YOUR WORKSHEET

•  Navigate to Option in the File menu

•  Select the option for Proofing and then choose Option for AutoCorrect

•  You can insert new AutoCorrect values by selecting the Add

option



•  Edit an AutoCorrect input by selecting it and then clicking on

Replace



•  Select Delete to erase an option from the list



•  You can turn off
AutoCorrect for some instances by deselecting any of these boxes



Summary
Excel provides measures with which you can make your data analysis

and worksheet free of errors, both for texts, numbers, and formulas. This
chapter explained how you can rectify errors such as incomplete
parentheses, hash marks, errors in formulas, etc. Steps



and methods to audit your worksheet using the Auditing Formulas
group in the Formula menu were also discussed. Finding and replacing
values in your worksheet using the corresponding dialogue box was
examined.

Conclusion
Functions and formulas in Excel are very important to save time during

data analysis. The feature of being able to search and carry out calculations
for particular data and cells by referencing them comes in handy when
dealing with large data. The inbuilt functions enable you to write shorter
expressions and carry out similar operations as without them. Good
knowledge of Excel formulas, their functions, and tools for auditing assists
you in having presentable error-free worksheets.





Part 3: PIVOT TABLES &
DASHBOARDS



INTRODUCTION
Excel Pivot tables were introduced in 1994. It has since proved to be a
necessary feature for containing and visualizing important data and
information from the main table. With pivot tables, firms and clients do not
need to go through numerous data before finding necessary points and
drawing crucial conclusions. Pivot tables are needed to be added manually
to worksheets. They are added from the Insert menu in the ribbon tab.
Upon selection of this option, users are presented with the option of either
creating the pivot table in the current worksheet or a new worksheet.

Pivot tables in Excel are subsets of an originally large table, derived
from another table containing large data for easier comprehension and
visualization. It is advised to have an existing table from which Excel
would then create the pivot table. Although pivot tables can also be created
from other data formats such as TXT files, this would however require a
data clean up and conversion. Data from external sources can also serve as
the foundation for pivot tables.

Excel pivot tables are easy to use along with the various functionalities
attached to them. Charts, slicers, summary functions, filters, etc. can all be
added and configured for use with pivot tables.





CHAPTER 18 GETTING FAMILIAR
WITH EXCEL PIVOT TABLES

Pivot tables in Excel are subsets of an originally large table. They are
derived from another table containing large data for easier comprehension
and visualization. Pivot tables usually contain important data and
information from the main table, so that firms do not need to go through
numerous data before finding necessary points.

Microsoft introduced the Pivot tables feature in Excel in 1994 and it has
undergone many improvements such as:

•  Excel version for 1997 came with an upgrade to the Wizard for
PivotTables, features for calculated fields creation, and provision of objects
in the pivot cache for writing macros for the creation and modification of
pivot tables.



•  Charts in pivot tables to graphically represent the data in pivot tables
were introduced in the Excel version for the year 2000.

Also, Oracle Corporation added PIVOT and UNPIVOT to its list of
operators for Oracle Database in the year 2007.



HOW TO CREATE PIVOT TABLES
Pivot tables do not appear automatically, they have to be selected from the
Insert menu in the ribbon tab. On selection of this option, a user is
presented with the option of either creating the pivot table in the current
worksheet or a new worksheet. Note that you must first have an existing
table from which Excel would then create the pivot table. The steps to
inserting a pivot table in your worksheet are explained below:

• 

Select any cell in your prepared table
•  Navigate to the Insert menu and select the option for
PivotTables

in the group for Tables.

•  In the resulting dialogue box:
-  Select the full cell range of the existing table

-  Choose whether the pivot table should be created in the current
worksheet or a new worksheet

-  Select the box for analyzing more than one table if applicable



•  Select OK

•  The Pane for fields in Pivot tables appears next. You decide how you
want the table to be formed in this pane. For example, to view the number
of each exported product:

-  Drag Product to the area for Rows
-  Drag Amount to the area for Values
-  Drag Countries to the area for Filters



This creates a result as shown

below:



Here, you can easily point out how
well every product is being exported.

Performing Basic Operations in Your Pivot Tables 1. Sorting

•  Highlight one of the cells in the column for Sum Amount
•  Make a right-click and select the Sort option
•  Choose from any of the provided options



This creates a result

as shown below:

1. Filtering

Select the filter drop-down icon. The available filter option is Country
because that was what we placed in the area for filters when the pivot table
was created.



1. Changing How Your Data is

Summarized
Excel summarizes data in pivot tables by count or sum by default. You

can however change this by following these steps:

•  Highlight one of the cells in the column for Sum Amount
•  Make a right-click and select the option for settings for field
values

•  Select how you want your data to be calculated in the dialogue box
that appears.



•  Select OK



COMPONENTS OF
PIVOT

TABLES
The components of a pivot table are made up of Fields. These fields are

dragged into these components or layouts to determine the foundation on
which users decide how their created pivot tables would appear. Pivot fields
are made up of the following parts:

1. Filters

Filters determine the basis on which the pivot table would be created.
They are applied to the complete table. For instance, dragging Country to
the area for Filter in the previous example gave a summary according to the
countries in the original table. A filter drop-down icon is usually present to
select certain filter options based on Country.

1. Columns



Columns are filters that are applied to only the columns present in the
original table. They are not applied to the whole table as in Filters. They
divide the pivot data into sections.

1. Rows

Rows provide a means of grouping the data in your original table. Fields
placed in the area for rows are the basis by which your pivot data would be
grouped. For example, we placed Products in Rows in the previous
example and we see the resulting table showing Sum Amount based on
products. Rows are the entities by which fields are measured or grouped.

1. Values

These components usually hold numerical fields that can be employed
when carrying out various calculations. However, if a field containing texts
is placed in this component, it is displayed in the table as a Count. Values
are the measured entity in Pivot tables. Pivot tables are found in
applications such as:

•  Spreadsheets: Microsoft Excel, Apache POI, Google Sheets,
etc.

•  Databases: Microsoft SQL Server, PostgreSQL, Microsoft Access,
MariaDB, Oracle Database, etc.

•  Web: a framework in Ajax known as ZK allows you to embed pivot
tables when creating applications for the web.

•  Programming Languages: Python has the Pandas toolkit and R

provides a meta-package known as Tidyverse. Summary
Pivot tables provide a quick way to analyze large tables to easily

visualize results and then draw educated conclusions. They are extracted
from originally large tables. Pivot tables are made up of components that
determine how they are formed and the information they display. This
chapter explained how pivot tables can be created and the necessary basic
operations that can be carried out on them.





CHAPTER 19- DESIGNING SIMPLE
PIVOT TABLES WITH CHARTS FIELD
SETTINGS FOR NUMBER SUMMARY

Adding fields to the area for Values in pivot tables makes available eleven
possible summary options for your field. These summary options are
similar to functions that can be used in everyday worksheets, however with
slight differences. Available summary options for Values include:

•  Sum
•  Count



•  Average
•  Max
•  Min
•  Product
•  Count Numbers
•  StdDev
•  StdDevp
•  Var
•  Varp

You can switch between these
summary options by following these steps:

•  Highlight any of the cells in the field placed in Values
•  Make a right-click and select the option for settings for field
values

•  Select how you want your data to be calculated in the dialogue box
that appears.

The Sum Summary Function
This function adds up all the data of the field placed in Values. Sum

summary is similar to using the conventional SUM function in your
worksheet. If fields containing numerical values are placed in the area for



Values, Excel automatically assigns the Sum summary to such field unless
it is changed by the user. Empty cells and cells containing texts are usually
ignored when using this summary option.



When you have more than one field in your area for Values, you can
avoid the task of manually changing the summary option used in each field
by using macros. The following code can be copied to a module in your
workbook. You can launch the code module editor by pressing keys Alt +
F11.

Sub SumAllValueFields() Dim pt As PivotTable Dim pf As PivotField
Dim ws As Worksheet

Set ws = ActiveSheet
Set pt = ws.PivotTables(1) Application.ScreenUpdating = False
pt.ManualUpdate = True
For Each pf In pt.DataFields pf.Function = xlSum Next pf
pt.ManualUpdate = False
Application.ScreenUpdating = True Set pf = Nothing
Set pt = Nothing Set ws = Nothing
End Sub
The Count Summary Function
This summary function is chosen by default for pivot tables in Excel

when fields containing texts are placed in Values. The Count summary
function counts errors, texts, and also numbers. The function does not count
empty cells and it follows the COUNTA function in regular worksheets.
Take this data table as an example:



The entry tells us the product Pen was ordered twice, but when the field
Qty was placed in the area for Values, it displays a count of 1, due to the
presence of an empty cell for one of the Pen orders. This can be rectified by
removing Qty from the area for Values and then placing the field Product
in this component. Excel then counts the texts and gives an accurate count
of 2.

The Average Summary Function

The Average option sums up all the data in the
field placed in Values and divides this sum by the number of present data.
This option is similar to the usual AVERAGE function used in worksheets.
Empty cells and cells containing texts are not considered when this option
is chosen.



The result given by the pivot table would require formatting so that
every data correspond to equal decimal places.

•  Select and make a right-click on any of the cells in the area for

Values



•  Select the option to configure the settings of the field

•  In the resulting dialogue box, select the tab for formatting
numbers



•  In the dialogue box for formatting numbers that come up, make
necessary adjustments



•  Click on OK

The pivot table then displays the Average values
in uniform decimal places.



The Max Summary Option

The Max option gives the maximum data in the field placed in Values.
It is similar to the MAX function used in worksheets. Blank cells are
usually ignored when using this summary option.

The Min Summary Function
The Min option gives the maximum data in the field placed in Values.

It is similar to the MIN function used in worksheets. Blank cells are usually
ignored when using this summary option.



The Product Summary Function

This summary function calculates the product of the values in the field
placed in Values. It is similar to the PRODUCT function used in
worksheets. Although the Product option finds less application when
dealing with pivot tables extracted from a large table with large data, it
requires a bit of cell formatting to enable Excel to accommodate the product
results. Excel assigns the Scientific number format as default when dealing
with such large numbers, this can however be changed to the Number
format. Note that Excel would only display numbers up to a precision of
the 15th significant number, after which zeros are displayed.



The Count Numbers

Summary Function
This summary function counts all numbers present in the field placed in

Values. Similar results are gotten when you use the COUNT function in
your worksheet. Errors, empty cells, and texts are not considered in this
summary function.

Difference between Count Numbers and Count
The data below shows the product and its ordered quantity. The

highlighted cell has been formatted to Text and the column Qty was added
twice to the area for Values. The result is shown below: Column B shows
the result for the Count Numbers summary function and column C the
result for the Count summary function. Column B shows a result of 2 for
Paper because one of the data has



been formatted to text so the Count Numbers option ignores it. Pen
shows a result of 1 because one of the data is an empty cell which is not
counted. Column B however shows a result of 3 for Paper because it uses
the Count summary function that considers numbers, as well as texts. Pen
shows 1 just as Count Numbers because Count also ignores data with
empty cells.

The StdDev and StdDevp Summary Function
The StdDev summary function calculates the standard deviation of all

data present in the field placed in Values. Similar results are gotten when
you use the STDEV.S function in your worksheet.

Standard deviation is the value by which data differ from the total
average value of the present data. It is used when just a part of a distribution
is being considered.

StdDevp, is also a measure of standard deviation, but it is used when
the total distribution or population is being considered. Similar results are
gotten when you use the STDEV.P function in your worksheet.



The Var and Varp Summary

Function
The Var option calculates the variance of all data present in the field

placed in Values. Similar results are gotten when you use the VAR.S
function in your worksheet. It is used when just a part of a distribution is
being considered.

Varp, is also a measure of variance, but it is used when the total
distribution or population is being considered. Similar results are gotten
when you use the VAR.P function in your worksheet. Follow these steps to
manually calculate variance and standard deviation:

•  Find the total average of all your present data
•  Subtract each data from the calculated total average

•  Find the square of the result gotten from step 2 and add them up This
result is your variance

•  Find the square root of the variance to get the standard deviation of
your data



DRILLING
DOWN

DATA IN PIVOT TABLES
Drilling down data in an Excel pivot table can be likened to peeling off

layers of a hierarchy until the simplest data is obtained. Its a technique used
for obtaining the list of data is made up of. Drilling down is not possible for
simple data without numerous levels, i.e. data is made up of no other data.
This process is made easier with Quick Explore which is available in the
newer versions of Microsoft Excel. Follow these steps to drill down data in
your pivot tables:

•  Select any item present in a field on your pivot table

• 

Select the icon for Quick Explore that comes up
•  This opens up the Explore dialogue box.
•  Select the item to be drilled and then click on the drilling down



option
•  Excel then displays a list of data with which the selected item is made

up of.
This process can be followed continuously until the needed data is

obtained.



DRILLING UP DATA IN PIVOT
TABLES

This process is in direct opposition to drilling down. Here, you choose a
better-summarized version of a group of data. You can use the Undo option
in the Quick Access menu or shortcut keys Ctrl +

Z. The Quick Explore menu can also be used following these steps:
•  Select any item present in a field on your pivot table to be drilled up

•  Select the icon for Quick Explore that comes up
•  This opens up the Explore dialogue box.

• 

Select the item to be drilled and then click on the drilling up
option

•  Excel then displays a summary of the list of data of the selected item.
This process can be followed continuously until the needed data is

obtained.



INCLUDING MORE ROWS OR
CATEGORIES IN YOUR PIVOT

TABLES



You can add multiple fields to the Rows, Values, Columns, or Filters
categories in your pivot tables. However, make sure you do not add
numerous to prevent the pivot table from being complex.

Also, the order in which fields are added to each category affects how
the pivot table is rendered. Follow these steps to include additional fields in
your pivot table categories:

•  Click on any cell in your pivot table to launch the Field Pane for
PivotTables.

• 

Select and drag any field to the Columns or Rows area.

The pivot table then gets updated according to the newly included fields in
each category. A pivot table having both Rows and Columns fields is a
Two-dimensional pivot table.



EXPANDING AND COLLAPSING A
PIVOT TABLE HEADING

When you add multiple fields in the pivot table categories, Excel includes a
collapsible and an expansion button at the top-level data with which you
can decide how much of the data is to be displayed at a time. A click on this
button collapses and expands the available data in the selected heading.



ADDING
BASIC CHARTS TO YOUR PIVOT TABLES

Pivot charts are used to graphically represent the data that can also be
represented using pivot tables. While pivot tables may be cumbersome or
difficult to understand due to the presence of numerous data, pivot charts
give needed information at a simple glance. To create pivot charts:

•  Highlight any cell in your usual worksheet table

• 



Navigate to the Insert menu and select the option for
PivotCharts

•  Choose the range of the cells of your pivot table in the resulting dialogue
box



• 

Click on Ok

Excel then inserts a chart such as this to graphically summarize your table
for easier visualization. Pivot charts can also be created from existing pivot
tables following these steps:

•  Highlight any cell in your pivot table
•  Navigate to the Tools for PivotTables option and select
Analyze
•  Choose the option for PivotCharts
•  Choose a chart option

•  Click on Ok Summary
Pivot tables give various options for how you summarize your data.

Although Excel uses either the Sum or Count summary option by default,
this can be changed following the steps explained in this chapter. If you also
wish to obtain the simplest data an item is made up of, the drilling down
technique can be used following the Quick Explore menu. This chapter
also discussed how multiple fields can be added in pivot table categories to
create two-dimensional pivot tables and how pivot charts can be included in
your worksheet.





CHAPTER THREE
CONFIGURING PIVOT TABLES TO DISPLAY PERCENTAGES

Percentages can be displayed in Excel pivot tables using the Show
Value As option which can be accessed by either making a right- click on a
cell in the pivot table or using the Settings for Field Values dialogue box.
The possible percentage calculations for pivot tables are as follows:



1. The Grand Total

Percentage
This percentage shows the comparison of each data to the total data.

The Grand Total Percentage can be obtained following these steps:
The example used contains the Item field in Rows, Region in Column

area, and Units in the area for Values. To calculate the percentage of the
sales in each region when compared to the Grand Total sales for every
Item:

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Grand Total Percentage



The pivot table fields changes to
reflect the configuration.



1. Column Total Percentage



The example used contains the Item field in Rows, Region in Column
area, and Units in the area for Values. The following steps describe how to
configure pivot tables to display the percentage sales for every single item
in each column for Region:

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Column Total Percentage

The pivot table fields changes to
reflect the configuration.



1. Row Total Percentage The following steps describe how to configure
pivot tables to display the percentage regional sales for items in a row:

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Row Total Percentage

The pivot table fields changes to
reflect the configuration.



The example used contains the Item field in Rows, Region in Column
area, and Units in the area for Values.

1. Percentage Of

This percentage calculation configuration allows you to compare every
value to specific data. The example used contains the Item field in Rows,
Region in Column area, and Units in the area for Values. Two applications
of this percentage configuration are examined.

-  Regional Percentage



This percentage considers the comparison of the sales of each item in
every region to the total sales of the item in the Central region.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Percentage Of

This launches a dialogue box where you decide how the pivot table
calculates this percentage.

•  Place Region in the Field bar and Central in the Item bar
•  Select OK

The pivot table fields changes to reflect the configuration. For instance,
the highlighted cells show sales of 12 pieces of furniture in the Central
region and sales of 25 pieces of furniture in the East. When the percentage
of the Eastern region is then calculated against the Central region, it was
found to be 208%.

-  Item Percentage

This percentage considers the comparison of the sales of each item to
the sales of Blinders in a similar region.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Percentage Of

This launches a dialogue box where you decide how the pivot table
calculates this percentage.



•  Place Item in the Field bar and Blinders in the Item bar
•  Select OK

The pivot table fields changes to reflect the configuration.

1. Parent Percentage

•  This option enables you to select a field basis for your
calculation.
•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Parent Percentage



This launches a dialogue box where you decide how the pivot table
calculates this percentage.

•  Choose a field base from the drop-down list
•  Select OK



The pivot table fields

changes to reflect the configuration.

1. Row Parent Percentage

The example used contains the Color field in Rows, Month in Column
area, and Units in the area for Values. This percentage option is used when
the field representing the parent is placed in the Rows category.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Row Parent Percentage

The pivot table fields changes to reflect the configuration. The number
of sales of Binders in January was 195, out of which 51% were Black.



1. Column Parent

Percentage
This percentage option is used when the field representing the parent is

placed in the Columns category. The example used contains the



Color field in Rows, Month in Column area, and Units in the area for
Values.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Column Parent Percentage

The pivot table fields changes to reflect the configuration. The number
of Brown items sold in January was 40, out of which 38% were Desks.



1. “Difference From”

in Pivot Tables
This calculation is used for subtracting a value from another.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Difference From

This launches a dialogue box where you decide how the pivot table
calculates this result.

•  Place Date in the Field bar and select (previous) in the Item bar. This
means the pivot table would subtract individual sales of the week from the
sales of the previous week.

•  Select OK



The pivot table fields changes to reflect the configuration.



1. Percentage Difference

From
This example has the Item field in Rows, Date in Column area with

respect to Year, and Total in the area for Values. The steps below calculate
the percentage of the sales of the present year when compared to the sales
of the previous year.

•  Make a right-click on a cell in the Total field
•  Select the option for the Settings of Fields

In the resulting dialogue box, enter a suitable name for the calculation
field

•  Select Percentage Difference From in the drop-down list for how
data is shown

•  Place Year in the Field bar and select (previous) in the Item
bar.
•  Select OK

The pivot table fields changes to reflect the configuration.



10. Running Total In This
calculates the running total for every region with respect to dates. This
example has the Date field in Rows, Region in Column area with respect
to Year, and Units in the area for Values.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Running Total In



This launches a dialogue box where you decide how the pivot table
calculates this result.

•  Place Date in the Field bar and select OK

The pivot table fields changes to reflect the configuration.



11. Percentage Running

Total In
This calculates the division of the present amount for the Running

Total by the Grand Total.

•  Make a right-click on a cell in the Units field
•  Select the option for configuring how values are shown
•  Select the option for Percentage Running Total In

This launches a dialogue box where you decide how the pivot table
calculates this result.

•  Place Date in the Field bar and select OK

The pivot table fields changes to reflect the configuration.

12. Rank
This option arranges data from highest to smallest or vice versa.

•  Make a right-click on any cell in the field to be ranked
•  Select the option for configuring how values are shown
•  Select any of the ranking options as needed



This launches a dialogue
box where you decide how the pivot table calculates this result.

•  Place Region in the Field bar and select OK



The pivot table

fields changes to reflect the configuration.



13. Index

This calculates the weight of a cell in comparison to the total row,
column, and Grand Total. It is not the same as the percentage of grand total.
The index shows the effect each item has with respect to its row and
column.

•  Make a right-click on any cell in the area for Values
•  Select the option for configuring how values are shown
•  Select the Index option



The pivot table fields changes
to reflect the configuration.



The following key points are to be noted when dealing with the Index:
•  If every value in the row and column is of equal and similar

importance, all the values would have an index value of 1.
•  If an item has an index below 1, it is then of low importance in that

row and column when compared to other present items
•  If an item has an index above 1, it is then of higher importance in that

row and column when compared to other present items.
The formula for manually calculating Index is as follows: Index =

(Value of Item in the Cell * Grand Total of Rows and Columns) /
(Grand Total of Rows * Grand Total of Columns)



REMOVAL OF CUSTOM
CALCULATIONS IN PIVOT TABLES

•  Select the drop-down icon in the field for Data

•  Deselect any of the selected fields to remove them from the custom
calculation.



Summary

Percentages are displayed in pivot tables using the option to configure
how values are shown. Many percentage calculations are possible in Excel
pivot tables which were explained and described in this chapter, alongside
how they can be implemented and also removed.





CHAPTER FOUR
CONFIGURING PIVOT TABLES TO DISPLAY AVERAGES

After setting up your pivot table:

•  Select and make a right-click on any of the cells in the area for

Values

•  Select the option to configure how your values are summarized

• 

Select the option for Average

An alternative procedure is as follows:

•  Click on the drop-down icon beside the field placed in the area
for

Values

•  Select the option to configure settings for the field



•  In the resulting dialogue box, select Average from the list of available
options for summarizing values

•  Click on OK



The result given by the pivot table would require formatting so that
every data correspond to equal decimal places.

•  Select and make a right-click on any of the cells in the area for

Values



• 

Select the option to configure the settings of the field
•  In the resulting dialogue box, select the tab for formatting
numbers

•  In the dialogue box for formatting numbers that come up, make necessary
adjustments



•  Click on OK

The pivot table then displays the Average values in uniform decimal
places.



CREATING MULTIPLE FIELDS IN
THE VALUE AREA

•  First, create a data entry and select the option for inserting pivot tables
For this example:

•  Drag the field, Country to the area for Rows
•  Drag the field, Amount to the area for Values twice



The resulting pivot table is as

follows:
To configure the second column for Amount to show Percentages
and not to just be a duplicate of the preceding column:



•  Select and make a right-click on any cell in this second column
for

Amount Sum

•  Select the option to configure the settings of the field



•  Change the name of the column in the Name bar to an appropriate
label such as Percentage

•  Select the tab to configure how values are shown

• 

Select the option for Grand Total Percentage
•  Click on OK

The resulting pivot table is as follows:



CREATING
MULTIPLE FIELDS IN THE FILTERS

AREA
•  First, create a data entry and select the option for inserting pivot tables

For this example:

•  Drag the field, ID for Orders to the area for Rows
•  Drag the field, Amount to the area for Values
•  Drag the fields Product and Country to the area for Filters



The resulting pivot table is as

follows:



•  Use the filter icon present beside these fields to control what is
displayed on your pivot table



UPDATING PIVOT TABLES
Pivot tables require an update or a refresh because changes are not being
reflected as you update the data in the source table. When you make
changes in your source data, there are two options to be chosen from to
make Excel update your pivot tables accordingly:

1. Refreshing the pivot table
2. Changing your source data



REFRESHING THE PIVOT TABLE
•  Select any cell in the pivot table and make a right-click
•  Select the Refresh option

Excel then updates your pivot table to reflect the data changes.



CHANGING YOUR SOURCE DATA
•  Select any cell in the pivot table



•  Navigate to the Analyze menu and select the option for changing the
pivot table source data.



Excel

then updates your pivot table to reflect the data changes.



CREATING FREQUENCY
DISTRIBUTION WITH EXCEL PIVOT

TABLES
•  First, create a data entry such as shown below:

•  Select the option for inserting pivot tables For this example:

•  Drag the field, Amount to the area for Rows
•  Drag the field, Amount, or another desired field to the area for

Values



•  Select and make a right-click on any cell in the column for

Amount Sum

•  Select the option to configure the settings of the field



• 

Select Count as the summarizing function for your data



•  Click on OK
•  Select and make a right-click on any cell in the column for
Label

• 

Select the option for Group
•  In the Grouping dialogue box, configure the following:
-  The Starting bar is set to 1
-  The Ending bar is set to 10000
-  The By bar is set to 1000



Note that these bars can hold any value of your choice

•  Click on OK

A frequency distribution table is created as shown below:

A chart can be inserted to better
visualize this distribution for comparison:

•  Highlight any cell in the pivot table

•  Navigate to the Analyze menu and select the PivotChart option from
the Tools section

•  Click on OK in the resulting dialogue box The resulting chart is
shown below:



Summary



Fields in pivot tables can be configured to display averages in place of
the total sum. Using the pane for configuring settings for fields or the
dialogue box for configuring how your values are summarized can both be
used. Pivot tables also require a refresh or an update when a change is made
in its source data. This chapter further explained how you can add multiple
fields in the Filters area, the area for Values, alongside how to create a
frequency distribution table with pivot tables and also include a
corresponding PivotChart.





CHAPTER FIVE
EXCEL PIVOT TABLE SLICERS AND COMPLEX FILTERING

Slicers enable easy and quick filtering of pivot tables. They show all
available values from a specific column in your table, with each of these
values shown as distinct buttons in the slicer pane. Various slicers can also
be connected to numerous pivot tables to get better analysis results. Follow
these steps to add slicers to your pivot tables:

• 

Create a pivot table such as shown below:

The pivot table was created as follows:

-  The field Product was dragged to the area for Rows
-  The field Amount was dragged to the area for Values
-  The field Country was dragged to the area for Filters



•  Insert a pivot table slicer following these steps:
•  Select a cell in the pivot table

•  Navigate to the Analyze menu and select the option for Inserting a
Slicer from the Tools section

•  Select any box from the available options in the resulting dialogue
box. Here, we choose Country



•  Select the OK button

•  Choose any of the available Country shown to enable the pivot table
to display the most exported product to the chosen Country

To insert a second slicer:

•  Select a cell in the pivot table

•  Navigate to the Analyze menu and select the option for Inserting a
Slicer from the Tools section



•  Select any box from the available options in the resulting dialogue
box. Here, we choose Product



•  Select the OK button

•  Navigate to the Options menu and select a Style for your slicers in
the Group for Slicer Styles to differentiate the slicers



The result is

shown below:



•  In the newly added Product slicer, click on the icon for selecting
multiple options at the top of the slicer pane

•  Highlight multiple options for Product

•  Holding down the Ctrl key and selecting multiple Product options
can be used in place of clicking the icon for selecting multiple options
(Multi-select)

Connecting Slicers to another Pivot Table
•  From the previously inserted slicers, highlight the first slicer, i.e. the

Country slicer
•  Navigate to the Options menu and select the option for Reporting

Connections from the Slicers section



• 

Select the box for the other pivot table in the resulting dialogue
box
•  Select OK
•  Repeat these steps for the Product slicer
•  Use the two slicers on both pivot tables

Slicer filters can be cleared using the filter icon at the top of the slicer pane



Differences between Slicers and Filters

1. Slicers are dynamic and can be changed from their visible pane, unlike
filters that require editing the settings of the fields of your pivot table.

2. Slicers are not fixed to a cell, they can be changed and moved as
desired. Filters are however fixed to a cell. 3. Filters cannot be
connected to numerous pivot tables, unlike slicers that support this
feature.

1. Filters are easily automated and manipulated with VBA modules with
simple codes. Slicers on the other hand require advanced codes to be
manipulated.



CREATING PIVOT CHARTS THAT
ARE DYNAMIC WITH SLICERS

Dynamic pivot charts enable you to select the particular chart to be
displayed from a single chart. This chart, though shown as one, can be
made to show different charts by selecting available chart option buttons.

Follow these steps to create dynamic pivot charts with slicers:

•  Highlight a cell in the pivot chart and navigate to the Options

menu to insert a PivotChart from the Charts section



•  Enter the cell range for your pivot chart in the resulting dialogue box.
Also select for the chart to be created in a new worksheet

•  Go to the Insert menu and select the option for Slicers

•  Select any desired dimension or item for your slicer

•  Configure the chart to add colors and styles as needed



TIMELINE SLICERS
These add a graphical visualization when you use them. Timelines are

mostly used with date-related fields. They make it easy to filter data by a
range of days, months, years, quarters, etc. These dates are shown
represented with a horizontal bar spanning from previous dates to current
dates. To insert timelines in your pivot tables:



•  Highlight the pivot table to which the timeline would be added
•  Go to the tab for Analyzing Pivot Tables

• 

Select the option to Insert a Timeline

The pane for editing field settings can also be used to insert a timeline in
your pivot table as shown below:

•  Select any available field of your choice

•  Make a right-click on the field to which the timeline slicer is to be
added

Using Timelines
The grouping option for a timeline can be changed by clicking on the

drop-down icon for Grouping Dates
•  Single timeline periods can be selected by clicking on the particular

period.
•  Select multiple timeline periods by clicking on the first period and

then dragging it down to the end of the desired period.
•  Selected timeline periods can be expanded or reduced using the

handles for the timeline.
•  Clear the selected timeline periods with the icon for filter present at

the top of the timeline pane. Keyboard keys Alt + C can be used while



clicking on the timeline periods to be cleared.



Hiding and Showing Timelines or Slicers

•  Highlight the timeline or slicer to be hidden or shown
•  Navigate to the tab for Timeline or Slicers
•  From the Arrange pane, click on the Selection menu

•  You can hide or show every timeline or slicer by selecting the
corresponding button at the top of the Selection window

•  Hide or show individual timeline or slicer by clicking on the
Eye

icon beside the object

Changing the Caption for Timelines or Slicers
Timeline or slicer captions are the names attached and written at the top

of their panes. They can be changed using the Timeline or Slicer menu.



ADVANCED
FILTERING OF PIVOT TABLES



Implementation of advanced filters in your pivot tables helps to
safeguard your original data, choose particular fields as output, and also
gives values as result.

Advanced Filtering Example
Using the dataset shown below, it would be observed that some entries

were made multiple times. Advanced filtering can be used to extract all
unique data in another location while leaving the original dataset
untouched.

•  Highlight all the data in the data set, as well as the headers

•  Navigate to the Data menu and select Advanced from the Sort and
Filter tab

•  This selection launches the Advanced Filters dialogue box
•  Select the option to copy the filter results to a new location

•  Select your Range for List to contain the cells of your original data
as well as its headers

•  Leave the Range for Criteria bar empty

•  Specify where the filter results should be displayed in your worksheet
in the Copy bar

• 

Select the box to only copy distinct records
•  Click on OK

The result is as shown below:



Summary
Slicers in Excel pivot tables provide a flexible and more comfortable

way to filter table values. They provide multiple filter options within easy
reach and more than one slicer can be created at once while you connect
them to other pivot tables. Timelines also show periods with a horizontal
bar that can be easily used to decide the data to be displayed according to
the selected timeline period. This chapter also explained how the advanced
filtering technique helps to keep your original data intact while filtering
operations are carried out on the data.





CHAPTER SIX
GETTING FAMILIAR WITH DASHBOARDS

Dashboards in Excel hold tables and charts that are made up of data.
They are created so that decisions can be easier made at a glance with the
concise way it presents data.

Creating Dashboards in Excel
When creating dashboards for data visualization, the following points

must first be considered:

•  Why is the dashboard being created? What purpose would it
serve?
•  What type of data would be dashboard contain?
•  For whom is the dashboard being created?
•  Would the dashboard require a regular update?



After successfully providing answers to these questions, you can then
decide on a suitable approach to which the dashboard would be created.
Also, consider the version of Excel your client uses to prevent the non-
compatibility of some features.

Acquiring Data for Excel Dashboards
Client data can come in various formats. Data in Excel format are easier

to use as they can be implemented directly. Other data formats such as Text
or CSV would require conversion to Excel format before you can use them.
You would also need to standardize the data after the necessary
conversation.

Data standardization involves cleaning up the data to remove blank
spaces, duplicates, errors, etc. The data might also require restructurings,
such as placing the data in a table or a pivot table.

Structuring Your Dashboards
It is considered good practice to structure the workbook in which your

dashboard would be created as follows:

1. A Worksheet for Data

This worksheet will hold your standardized and restructured data. Your
data can be more than one worksheet, depending on how large your raw
data is.

1. A Worksheet for Calculations

This worksheet would hold all your required calculations to avoid
crowding the data worksheet(s). Multiple sheets can be used for
calculations as well.

1. The Dashboard Sheet

This is usually a single
sheet. It is the sheet where the dashboard would reside.



Notable Functions to be Considered when Creating Dashboards

•  The SUMPRODUCT function
•  The MATCH or INDEX functions
•  The VLOOKUP function
•  The IFERROR function
•  The TEXT function
•  The ROW and COLUMN functions



Interactive and Dynamic Tools for Dashboards

•  Scroll Bars: These can be used to see additional data.

•  Check Boxes: Selection or deselection of checkboxes updates what is
displayed on the dashboard. They help to make your dashboard dynamic.

•  Drop-down Lists: They are also used to update dashboard displays.
They can be used in place of or with checkboxes.

Tips for Creating Dashboards

•  Avoid overcrowding your dashboards
•  Avoid formulas that reduce the efficiency of calculations
•  Remove unneeded data

•  Ensure your charts are numbered, labeled, and sectioned for easy
reference and navigation

•  Rows can be hidden to prevent unwanted navigation

•  Freeze important rows and columns for them to constantly remain
visible

•  Provide a guide to the dashboard if it is a complex dashboard. This
guide can be written on a separate sheet. ADDING NUMEROUS PIVOT
TABLES TO YOUR WORKSHEET

Two or more pivot tables can be used for analyzing data in multiple
ways. Using the record below as an example:



Two pivot tables can be created from this data; the first pivot table
would analyze the sales according to the type of gadgets, while the second
pivot table would analyze the sales according to stores.

To create the first pivot table for analyzing the sales according to the
type of gadgets:



•  Highlight a cell in the data source
•  Navigate to the Insert menu and select the Tables option
•  Choose the tab for Recommended Tables
•  Select your desired layout from the resulting window and select



OK
This action inserts one of the pivot tables in your worksheet
•  Select any cell in this table to bring up the window for configuring the

fields of the pivot table

•  Here you can drag and drop fields into the areas for Rows,
Values,

or Columns.
To insert the second pivot table for analyzing the sales according to

stores:
•  Select a blank cell in your worksheet that is far from the previously

created pivot table

• 

Navigate to the Insert menu and select PivotTable
•  In the resulting dialogue box:
•  Select the range of cells holding your data source



•  Select the option for the pivot table to be created in the same worksheet

•  Select OK

This action inserts the second pivot table in your worksheet
•  Select any cell in this table to bring up the window for configuring the

fields of the pivot table



The result is shown below:





FORMATTING OPERATIONS ON
DASHBOARDS

Dashboard formatting aids visualization as it helps to configure how data
appears and is arranged. Conditional formatting is the best technique to be
applied when formatting your dashboards.

Highlighting Specific Cells
Consider the data below; follow these steps to arrange the cell data for

Total Amount in a particular order:

•  Select the Total column
•  Navigate to the Home menu and select Conditional
Formatting

from the group for Styles



•  Select the option to specify highlight rules from the dropdown menu

• 

Select the Greater Than option from the next list that appears
•  Specify the condition to highlight cells with values more than

1000000 in the resulting dialogue box
•  Select the highlight color in the next box from the available drop-

down options

•  Select OK

The result is of this formatting is shown below:



The Top
or Bottom Rules



This formatting highlight cells that any of the following conditions:
•  10 Top Items: This formatting option would highlight the 10 top

items having the highest values in the data.
•  Top 10 Percent: This formatting option would highlight the top 10

percent items having the highest percentage in the selected data range.
•  10 Bottom Items: This formatting option would highlight the 10

bottom items having the lowest values in the selected data range.
•  Bottom 10 Percent: This formatting option would highlight the

bottom 10 percent items having the lowest percentage in the selected data
range.

•  Above Average: This formatting option would highlight all items
with values above the calculated average of the selected data range.

•  Below Average: This formatting option would highlight all items
with values below the calculated average of the selected data range.

However, suppose you wish to highlight the top 5 percent data in your
entry:

•  Select the Total column
•  Navigate to the Home menu and select Conditional
Formatting

from the group for Styles
•  Select the option to specify Top or Bottom rules from the drop- down

menu



•  Select the option for Top 10 Percent from the next list that
appears

•  Specify the condition to highlight cells with top 5 percent values in
the resulting dialogue box

•  Select the highlight color in the next box from the available drop-
down options



•  Select OK

The result is of this formatting is shown
below:



Other formatting options that can be implemented on your dashboard
include:

• 

Data bars



• 

Color scales
•  Icons, etc.

You can also specify your formatting rules by selecting the option to
Customize Rules. Additional formatting options can likewise be accessed
using the More Rules option.

INSERTING CHARTS IN YOUR DASHBOARDS While in the
dashboard worksheet, navigate to the Insert menu and select any chart

of your choice

•  Make a right-click on the inserted chart and enter your data
range



• 

Configure the Series and Category fields as desired and click
OK
•  Add a title or label to your chart following these steps:
-  Select the chart and navigate to the Design menu
-  Select the option to insert elements in your charts

This opens a drop-down menu from
which various elements can be selected to be added to your chart.



Summary

Dashboards are built on data and charts. They are created for better data
visualization to enhance easier comprehension and results. This chapter
explained why adding multiple pivot tables to your worksheet enables the
analysis of data in multiple forms. How you can insert more than one pivot
table was also explained. Dashboard



formatting that configures how data is displayed was also considered,
alongside how you can add charts to your dashboard.





CHAPTER SEVEN
INSERTING PERFORMANCE SYMBOLS AND SLICERS TO
DASHBOARDS SLICERS

After adding charts to your dashboard, you can then add slicers to
further create a dynamic dashboard that can be filtered from a slicer pane.

Highlight the PivotChart
•  Navigate to the Analyze menu and select the option for Inserting

Slicers from the Filter section

• 

You can then select any of the fields available in the slicer pane
•  Select OK

This selection brings up further options with respect to the previously
chosen option from which your dashboard can then be filtered.



Changing the Color of Slicers

•  Highlight the slicer
•  Navigate to the Tools for Slicers menu and click on Options

• 

Select the tab Style for Slicers

Here you can select a Light or Dark theme for your slicers. You can also
customize your slicer theme by selecting the option for adding New Style
for Slicers.

Adding Multiple Columns to Slicer Pane
Excel slicers usually have one column with a scroll bar added when the

slicer item exceeds what can be displayed at once. To avoid



scrolling up and down to see additional slicer items, you can insert an
additional column in the slicer pane.

•  Highlight the slicer
•  Navigate to the Tools for Slicers menu and click on Options
•  Select the Buttons option

•  Edit the value for columns to 2 or any choice number The result is
shown below:

This display does not show the complete name
of the items in the slicer, to rectify this:

•  Highlight the slicer
•  Navigate to the Tools for Slicers menu and click on Options

From here, adjust the Width and Height of the slicer buttons and the
slicer pane. Note that the size of the slicer pane can be adjusted from the
dashboard by selecting the edges of the pane and dragging it to the desired
size. However, to adjust the size of the slicer buttons, you can only use the
Options menu.



Removing Headings for Slicers

•  Make a right-click on the slicer
•  Select the option to adjust the Settings of the Slicer



•  You can change the header of the slicer in the resulting dialogue box
or deselect the box for displaying the header



•  Select OK

Customizing How Items are arranged in the Slicer Pane



Slicer items are usually arranged in ascending order for text and from
older to current for dates or numbers. You can however change this default
arrangement to use your sorting rules as follows:

•  Make a right-click on the slicer
•  Select the option to adjust the Settings of the Slicer

•  When the dialogue box for the Settings of the Slicer is launched, you
can adjust how the slicer items are arranged from the sorting options

•  Select OK when done

Removing Items with Empty Data from the Slicer Pane
Several items in the slicer pane may have no data related to them from

the pivot table, these items can then be removed or hidden from display on
the slicer pane.

•  Make a right-click on the slicer
•  Select the option to adjust the Settings of the Slicer

•  When the dialogue box for the Settings of the Slicer is launched,
select to hide these items with no data associated with them.





ADDING SYMBOLS FOR
PERFORMANCE TO YOUR

DASHBOARDS
Symbols, arrows, and additional indicators are used in Excel dashboards to
aid visualization. They graphically show the direction of data from applied
conditional formatting. Set of Icons are used to insert symbols for
performance in dashboards. These icons consist of the following
classification:

•  Directional icons
•  Shape icons
•  Indicator icons
•  Rating icons



To add these icons:

•  Select the data that the icons would represent
•  Navigate to the Home menu and select Conditional
Formatting

from the Styles section

•  Select Icons from the drop-down menu



•  Choose any of the icon groups

Summary
This chapter explained how you can insert slicers in your dashboards,

edit the styles of the slicer, adjust the size of the slicer and its buttons, and
also change its sorting order. Symbols for performance such as directional
arrows, shape icons, rating icons, etc. are added to dashboards for graphical
representation of your data to enhance comprehension and accurate decision
making.





CHAPTER EIGHT
REFRESHING YOUR PIVOT TABLES AND DASHBOARD DATA

Refreshing from the Quick Menu
Pivot tables and data in your dashboards are refreshed to keep them up

to date with your data source.

•  Select any of your data cells and make a right-click

•  Select the option to Refresh the table or data from the launched menu



•  Keyboard keys ALT + F5 can also be used after selecting a data cell
to initiate a refresh.

Putting the data source in an Excel table format enables a simple refresh
action on pivot tables or dashboard data to update data changes. Even the
addition of new columns or rows in the source table data would also be
reflected on the pivot table when refreshed.

Refreshing Pivot Tables by Changing the Source Data

•  Select a data cell in the pivot table or dashboard

•  Navigate to the Analyze menu and select the option to edit the source
data from the Data section

This selection launches the corresponding dialogue box where you
update and specify the table cell range, including the additional columns,
rows, or data.

•  Select OK when done.

When Excel tables are used to create pivot tables, the procedure of
changing the source data need not be followed to update or refresh the pivot
table. In this case, the Refresh option would suffice.



These two methods still have their shortcomings. They require you to
manually refresh or update your pivot tables and dashboard data whenever
there is a change in the data source. You can however use the automatic
refresh and table update approach for your pivot tables and dashboards
using an Excel VBA code. The VBA code written below can be modified to
suit your workbook:



Private Sub Worksheet_Change(ByVal Target As Range)
Worksheets(“Sheet3”).PivotTables(“PivotTable2”).PivotCache.R efresh

End Sub
Sheet3 and PivotTable 2 in this code can be modified to correspond

with how your workbook is structured.

To use this code:

•  Press keyboard keys Alt + F11 to launch the VB Code Editor

•  Select the sheet containing the pivot table to be automatically updated
from the left menu

•  Copy and paste the code above in the code module on the right. Here
you can make all necessary modifications.

You can now exit the VB editor module and all pivot table and
dashboard data reflects an automatic update and refresh when you edit the
source data.



Summary
Pivot tables and data on your dashboard are refreshed and updated to

reflect changes or the addition of rows and columns in the data



source. It is advised to put your data source in Excel table format and
then create your pivot tables from this data. The VBA code module can
likewise be used to initiate an automatic update whenever you change any
data or insert new columns and rows in the source Excel table.





CHAPTER NINE
SECURING YOUR DASHBOARD DATA Hiding the Source Data of
Your Pivot Tables

Sending or sharing a pivot table with the source data attached makes it
possible for those shared with to access the source table and make
modifications. Deleting the source data sheet is still not enough protection
from third parties editing the source data as it can still be recreated.

A good option to prevent this is to disable the option for saving the
pivot table source data. This can be done from the PivotTable Options
dialogue box. Note however that this would make clients unable to make
changes to the pivot table or even refresh it.

Finding the Source Data of Your Pivot Tables

•  Highlight a cell in the pivot table
•  Navigate to the Analyze/Options menu

• 

Select the option to edit the source data from the Data section

•  In the resulting dialogue box, you can see the source Excel table or cell
range in the Range/Table box



PROTECTING
EXCEL



DASHBOARDS AND WORKSHEETS
You can protect your dashboards and worksheets from unauthorized

modifications by adding passwords or encryption.

•  Navigate to the File menu and select Info
•  Click on the option to Protect your Workbook and select the

Password Encryption button

•  Type in a password in the provided box and select the OK
button
•  Enter this password again for confirmation and select the OK

button
Navigating to the Review menu and selecting the option to Protect the

Worksheet or the Workbook also protects your pivot table worksheet and
dashboard.

Separating Sources of Data



When handling large data that comprises records from multiple regions,
or sectors; data from each region can be separated with pivot tables added
to each separate data. Doing this and including passwords to these
individual worksheets would prevent access to the full source data while
providing effective pivot tables for every region with its data attached.

Creating Static Pivot Tables



This involves using the Special Pasting options. Creating static pivot
tables allows you to only paste values and results in the tables, making it
impossible for users to make changes to the layout of the pivot tables. Static
pivot tables can also be designed for separate data sources as follows:

•  Select the name of a region from the Filter section
•  Highlight the pivot table and make a right-click

•  Select Copy from the launched menu or use keyboard keys Ctrl + C
after selecting the table

•  Open another worksheet or workbook and make a rightclick on the
cell where the pivot table would be passed

•  Select the option for Special Pasting in the launched menu
•  Select Values and then select OK

You can then format the copied table as desired.



HIDING ITEMS IN EXCEL PIVOT
TABLES

Columns and rows can be temporarily hidden in pivot tables. Selecting the
drop-down icon of the column or row item can be used to deselect items to
be hidden. However, this can be tedious if the data is not properly arranged
and when handling large data. An alternative and easier method are to use
the Filter menu.

•  Select an item or multiple items in the pivot table and make a right-
click

•  Choose the option to hide the items you selected



SHOWING SELECTED ITEMS IN
EXCEL PIVOT TABLES

Just as you can selectively hide multiple columns or rows from view in your
pivot table, likewise you can choose to only show the items you select.
While this can be done by selecting the dropdown icon of the column or
row item to select items to be shown, this can be time-



consuming if the data is not properly arranged and in cases of large data.
An alternative and easier method are to use the Filter menu.

•  Select an item or multiple items in the pivot table and make a right-
click

•  Choose the option to only show or keep the items you selected

Summary
Protecting the data source of your pivot tables, dashboard data, and

worksheets is essential in Excel. It prevents unwanted modification of the
pivot tables or data source. This chapter explained how you can add a
password to your worksheet, separately create pivot tables for distinct
regions, create static pivot tables, and also hide the data source of your
tables. You can also choose to hide or display selected data in your pivot
table using the Filter menu.





CHAPTER TEN
PUTTING PIVOT TABLE DATA IN GROUPS

In cases of large data having certain similarities, it may be necessary to
put them into groups for easy accessibility. Putting your data in a group also
helps remove the repetition of records, thereby reducing the amount of data.
Excel allows you to put Number, Date, and Text fields into a group and
specify the grouping interval.



AUTOMATIC GROUPING OF DATES
IN EXCEL

Later versions of Excel starting from Excel 2016 puts date entries into
groups immediately they are entered as a field in a pivot table. This
automatic grouping for dates can however be disabled and undone. The
disabling feature is only made available in Excel 2016 and recent versions;
earlier and all versions only allow you to undo the automatic date group.



Disabling the Automatic Grouping for Date Feature in Excel 2016
and Recent Versions

Note that this action would have effects on all Excel workbooks, not
just the current workbook as this action affects the Excel application itself.

•  Navigate to File and select Options
•  From the left menu, select the Data option

•  From the resulting options on the right, select the Disable box for the
automatic grouping of dates in pivot tables

•  Select OK to apply the change



UNDOING AUTOMATIC GROUPING
FOR DATES IN ALL VERSIONS OF

EXCEL
Using Keyboard Shortcut Keys

•  First, make an entry of a date field in your pivot table

•  As soon Excel automatically puts the dates in a group, use keyboard
key Ctrl + Z to immediately undo the grouping

This reverts the data to its original single entries.
Using the Ungroup Option

•  First, make an entry of a date field in your pivot table

•  As soon Excel automatically puts the dates in a group, make a right-
click on the grouped data

•  Select the Ungroup option

This reverts the data to its original single entries.



PUTTING DATE RECORDS IN
GROUPS

Many predefined options or intervals exist in Excel for putting date records
into groups, these include:



•  Seconds
•  Hours
•  Days
•  Months
•  Quarters
•  Years

To put date field records into groups:
•  Select a cell containing a date field data in your pivot table and make

a right-click

• 

Select Group from the resulting menu
•  This action launches the Grouping dialogue box

•  Put in a Starting date in the provided box and an Ending date in the
corresponding box

•  In the By box, choose a time or period by which your date field data
will be grouped

•  Select OK



Putting Date Records in Week Groups
•  Select a cell containing a date field data in your pivot table and make

a right-click

•  Select Group from the resulting menu
•  This action launches the Grouping dialogue box

•  Put in a Starting date in the provided box and an Ending date in the
corresponding box

•  In the By box, choose Day as the interval by which your date field
data will be grouped

•  Above the OK button, enter 7 in the box for Days Number With the
Days Number box, you can enter any number by which your dates would
be grouped. Ensure that you first select Day as your interval in the By box.

Changing the Starting and Ending Date of Excel Date Groups
•  Select a cell containing a date field data in your pivot table and make

a right-click

•  Select Group from the resulting menu
•  This action launches the Grouping dialogue box
•  Deselect the boxes for an automatic Starting or Ending date

•  Enter your desired dates in the corresponding boxes Typing in a date
in the Starting or Ending date box also immediately deselects the boxes
for automatic Starting or Ending date.



PUTTING NUMERICAL DATA INTO
GROUPS

•  Select a cell containing a date field data in your pivot table and make a
right-click

•  Select Group from the resulting menu
•  This action launches the Grouping dialogue box

•  Put in a Starting number in the provided box and an Ending number
in the corresponding box with respect to the least and highest number in
your data

•  In the By box, enter a number interval of your choice by which the
data would be grouped

•  Select OK



PUTTING TEXT DATA INTO GROUPS
Although the Grouping dialogue box cannot be used to put text field data
into groups, you can however manually put these data into groups by
following these steps:



•  Highlight the text data to be grouped
•  Make a right-click on the data and select the Group option

This action automatically adds
a new field group to the list of fields. To edit this name to one of your
choices:

•  Select the cell heading having the name to be edited

• 

Type in a new name

Adding Items to the Group

•  Highlight the items in the newly created group

•  Press down the Ctrl key and select the additional data from the pivot
table with your mouse

•  Make a right-click on these selected items and choose Group in the
resulting menu

This adds the new data in the highlighted group. This action might
require you to perform the rename operation again if previously done.

Putting Multi-selected Data in a Group
•  Highlight the data or press down the Ctrl while selecting the data

with your mouse

•  Make a right-click and select Group from the resulting menu



•  When in the Grouping dialogue box, put in a Starting value in the
provided box and an Ending value in the corresponding box



•  In the By box, choose a time or period by which your data will be
grouped if dealing with date-related data. For numerical data, enter a
numeric value for intervals

•  Select OK

This puts only the selected item in a group.
Assigning Names to Groups

•  Highlight the group to be named

•  Navigate to the Analyze menu and select the option to configure the
Settings of the Field

•  Select Custom Name and edit it to your choice Disbanding Data in
a Group

•  Select any item in the group to be disbanded and make a right-
click
•  Select the Ungroup option from the resulting menu



POSSIBLE
ISSUES WITH DATA GROUPING

When attempting to put data into groups and Excel throws an error
message of being unable to carry out the grouping action, this error may be
as a result of the model of the data. This issue stems from when a pivot
table is being created. Endeavor to deselect the Data Model box when
creating your pivot tables

Processing)
to avoid creating an based Pivot Table.
OLAP (Online Analytical
This would make some functionalities or editing possibilities impossible

in your pivot table.



This error message can also arise as a result of an attempt to group data
of different formats. For example, grouping a Number and Text data. Also,
remember that numbers can be formatted into texts in Excel. Rectifying the
issue requires you to format or convert the data to be grouped into similar
formats.



THE COUNT SUMMARY FUNCTION
FOR GROUPING DATA IN PIVOT

TABLES
Consider an Excel table with the following data shown below; A pivot table
can be used to put the data into groups with the Count summary function.

•  Create a pivot table with the fields placed in the following areas as
shown

•  Configure the field for Names using the dialogue box for Setting
Field Values

•  Change the name of the field in the Custom box
•  Select the tab for Summarizing Values of the Fields and
choose

Count



Summary



Grouping the data or records in pivot tables makes it easier for you to
locate them and work with them. Data grouping promotes data analysis and
result findings. Text, number, and date data fields can be put into groups
through different steps as explained in this chapter. An attempt to group
data of different formats results in an error that would require converting
these records into an identical format. The Count summary function also
groups data by counting the number of times the record is made.





CHAPTER ELEVEN
CREATING CALCULATED FIELDS IN YOUR PIVOT TABLES

Calculated Fields vs Calculated Items
Calculated fields denote other fields in the pivot table while calculated

items denote other items in the pivot table. Calculated items usually become
one of the items in the pivot table, and they can be calculated using the
summation of items in a similar field. They are displayed with other items
in the area for Columns or Rows when configuring pivot tables. However,
they are not added to the pivot table list for fields. Calculated items come
with the following restrictions:

•  Fields containing calculated items cannot be added in the area
for

Filters
•  Fields containing calculated items cannot be added multiple times in

the area for Values.
Calculated fields on the other hand usually become one of the fields in

the pivot table, and are used in the pivot table to carry out calculations on
other fields. They can likewise be calculated using the summation of fields.
They are displayed with other fields in the area for Values when
configuring pivot tables and they are added in the pivot table list for fields.

Inserting Simple Calculated Items
In the example below, to create a Calculated Item for Sold items that

would include all the available status of Orders:



•  Select any cell containing data in the pivot table
•  Navigate to the Analyze menu under the tools tab for Pivot
Table

•  Select the drop-down option for Fields, Sets, and Items from the
group for Calculations

•  Click on the option for Calculated Items

In the resulting dialogue box:

•  Enter a name for the calculated item
•  Enter your summation formula to include all the field items
except



Canceled



•  Select the Add option when done

The resulting pivot table shows all the field items replaced with the
Sold calculated item



Inserting Simple

Calculated Fields
Using the pivot table data below:



•  Select any cell containing data in the pivot table
•  Navigate to the Analyze menu under the tools tab for Pivot
Table

•  Select the drop-down option for Fields, Sets, and Items from the
group for Calculations

•  Click on the option for Calculated Fields



In the resulting dialogue box:

•  Enter a name for the calculated field

•  Enter a formula for the calculated field. The listed fields shown in the
dialogue box can also be selected by doubleclicking on them



•  Select the Add option when done

The resulting pivot table is then rendered to show the result of the
calculated field.

This field also gets added to the list of fields for your pivot table.



LISTING ALL FORMULAS IN A PIVOT
TABLE

•  Highlight any cell in the pivot table
•  Navigate to the Analyze menu under the tools tab for Pivot
Table

•  Select the drop-down option for Fields, Sets, and Items from the group
for Calculations

•  Click on the option to List your Formulas

Excel immediately adds a new worksheet in your workbook on this
selection. This new worksheet shows a list of all formulas in the pivot table.



DELETING
AND MODIFYING CALCULATED

FIELDS AND ITEMS
•  Select any cell containing data in the pivot table
•  Navigate to the Analyze menu under the tools tab for Pivot
Table

•  Select the drop-down option for Fields, Sets, and Items from the group
for Calculations

•  Click on the option for Calculated Fields or Calculated Items
•  In the resulting dialogue box, select the drop-down icon beside
the

Name box to access the list of created calculated items or fields



•  Select the calculated field or item to be deleted or modified



For modification operation, edit the formula for the calculated field or
item in the Formula box and then select the Modify button to save and
effect your changes.

To delete the calculated item or field, select the Delete button after
selecting the calculated field or item to be deleted.



EDITING
HOW FORMULA ERROR MESSAGES

ARE DISPLAYED
Just as in normal worksheets, errors occur in pivot tables and can be
configured to show a certain value or message when they occur. You can as
well completely hide them.

Configuring How Errors of #DIV/0! are Displayed

•  Consider the pivot table below with the following errors:



•  To configure how Excel displays these errors:
•  Highlight any of the pivot table data cells and make a rightclick

• 

Select the tab to access Options for the pivot table
•  In the Options dialogue box, navigate to the Layout menu
•  Select the box for configuring how error values are shown
•  Type in a Space to hide the error



•  Select OK

Configuring How Errors of Blank Cells are Displayed

•  Highlight any of the pivot table data cells and make a rightclick
•  Select the tab to access Options for the pivot table
•  In the Options dialogue box, navigate to the Layout menu
•  Select the box for configuring how blank cells are displayed





•  Select OK

Hiding Blank Cells in Pivot Tables

•  Select the drop-down icon beside the Labels for Rows
•  Deselect the box for Blank

•  Select OK to save the changes

It is advised that before you configure how errors are displayed in your
pivot tables, you should first crosscheck your source data and formulas.



ADDING LOGIC FIELDS TO YOUR
PIVOT TABLES

Logic fields can be added to your pivot tables using calculated fields. Logic
fields use formulas with functions such as THEN, IF, etc.

Using the pivot table data below:

•  Select any cell containing data in the pivot table
•  Navigate to the Analyze menu under the tools tab for Pivot
Table

•  Select the drop-down option for Fields, Sets, and Items from the
group for Calculations

•  Click on the option for Calculated Fields

In the resulting dialogue box:

•  Enter a name for the calculated field
•  Enter a logic formula for the calculated field



•  Select the Add option when done

Summary
Excel pivot tables allow you to add calculated fields and items that use

values from your pivot data for their calculation. These calculated items or
fields can be edited and deleted as explained in this chapter. Pivot tables
also give you the flexibility of configuring how errors in the table are
displayed using the Options menu for the pivot table. Calculation errors
and blank cells can be either hidden or configured to show a certain
message of your choice.





CHAPTER TWELVE
USING EXTERNAL FILES FOR CREATING PIVOT TABLES

Pivot tables can be created from imported or external files. They can
serve as the data source of your pivot tables. Data can be imported from the
following sources for your pivot table:

•  A separate Excel workbook
•  Microsoft Access database
•  Microsoft SQL Server
•  Analysis Services
•  Windows Azure Marketplace
•  OData Data Feed

Importing Data from a Separate Excel Workbook
•  In the workbook where the pivot table is to be created, navigate to the

Insert menu

• 

Select Tables and then the PivotTable option

•  In the PivotTable Creation dialogue box, select the option for the pivot
table to be created from an external source of connection

•  Click on the button to Choose a Connection



• 

Select the option to Browse for additional sources

•  This opens up your computer’s File Explorer. From here, you can
navigate to open required folders to select the source Excel workbook

•  Click on Open when selected



•  Select the appropriate table option when the dialogue box for

Selecting Table comes up

•  Select OK to close this dialogue box
•  Select OK to close the PivotTable Creation dialogue box
•  Place fields accordingly in their corresponding areas

The pivot table is then ready from this external data source.
Importing Data from Microsoft Access



•  In the workbook where the pivot table is to be created, navigate to the
Data menu

•  Click on the option for Getting External Data



• 

Select Access from the available external sources of data

•  This opens up your computer’s File Explorer. From here, you can
navigate to open required Access database folders to select the source
Access file

•  Click on Open when selected
•  Select the Report option for the pivot table in the Data Import

dialogue box

•  Select OK



• 

Place fields accordingly in their corresponding areas

The pivot table is then ready from this external data source. To use data
from sources such as:

•  Microsoft SQL Server
•  Analysis Services
•  Windows Azure Marketplace
•  OData Data Feed

•  Navigate to the Data menu and click on the option for Getting
External Data

•  Select the option to get data From additional sources



This selection shows these external locations which can then be selected
and their corresponding dialogue boxes followed.



CREATING PIVOT TABLES FROM
IMPORTED TEXT FILES

•  In the workbook where the pivot table is to be created, navigate to the
Data menu

•  Click on the option for creating the pivot table from a Text file in the
Getting External Data menu group

• 

Select OK in the resulting Microsoft Security dialogue box

•  This opens up your computer’s File Explorer. From here, you can
navigate to open required folders to select the source Text file



•  Click on Import when selected

• 

In the Import Wizard for Text, select the option for Delimited
•  Click Next



•  In the next window, select the delimiter in your text file and
click

Next

•  Select Finish





•  When in the Data Import dialogue box, select the option for the
imported data to be created in the currently opened worksheet

•  Select OK

This action completes the importation process of the text file, leaving
the pivot table to be created.

•  Navigate to the Insert menu and select PivotTable

•  When in the PivotTable Creation dialogue box, select the option for
the pivot table to be created in the currently opened worksheet.

•  Place fields accordingly in their corresponding areas The pivot table
is then ready from this external text data source.



CREATING PIVOT TABLES FROM
NUMEROUS DATA SOURCES OR

WORKBOOKS
This creation process requires Power Query. Ensure this add-on is installed
in your Microsoft Excel application version.

•  In the workbook where the pivot table is to be created, navigate to the
Data menu

•  Select the option for Getting Transformation and the New
Query



• 

Select the tab for creating From a File and then From a Folder

•  In the Folder dialogue box, browse and select the folder containing all
the files from which the pivot table would be created

•  Select OK when done
•  In the window for Combining Files, click on the Combine
button



and select the Combine and Edit option
•  Next, select the worksheet where all the data would be inserted and

click OK



This action modifies the multiple data files in the Editor for Power
Query as shown below:



This data however needs to be formatted and prepared for use in a pivot
table creation. For example, observe the column named Source.name in the
illustration above that shows the source file of each data. This column is
required to be removed.

•  Make a right-click on the Source.name column and select

the option for Splitting the Column on the resulting menu

•  Select Delimiter from the next menu



•  When in the corresponding dialogue box:
-  Choose Custom as the delimiter option
-  Type in the “-” character as the delimiter
-  Select the box for the leftmost delimiter option





-  Select OK to exit the dialogue box

The result of this split and delimiter operation is shown below
•  You can now remove the next column having zone.xlsx data in it by

right-clicking on the column and selecting the Remove option

•  Give the first column a new name by right-clicking on the column and
selecting the Rename option



•  To make the first character of that data in the newly named column
capitalized:

•  Select the column and make a right-click

•  Select the Transform option and select the option for Capitalizing
Each Word



This data from
multiple files is now ready to be used to create a pivot table.

•  Navigate to the ribbon menu and select the Close and Load option to
close the Editor for Power Query

To insert a corresponding pivot table :

•  Navigate to the Insert menu and select PivotTable

•  When in the PivotTable Creation dialogue box, select the option for
the pivot table to be created in the currently opened worksheet.

•  Place fields accordingly in their corresponding areas The pivot table
is then ready from this external text data source.

Refreshing Pivot Tables created from Power Query require you to use
the Refresh button on the Data menu. This would initiate a refresh and
update action on both the Query (File Source) and the PivotTable.



Points to Note When Creating Pivot Tables from Multiple File
Sources



•  Ensure all the files from which the pivot table would be created is in
one folder

•  Ensure all the files are in identical format
•  Ensure the name of each file or worksheet is identical

•  Ensure each file does not contain errors. The option for Skipping
Error Files can be used if errors are found when combining the files.

•  Ensure no workbook containing the worksheets to be combined is
renamed.

Summary
Excel allows you to create pivot tables from external sources that you

can import into your worksheet. Workbooks in your computer’s File
Explorer, files from Microsoft Access, or any database can all be imported
after securing a connection to them. Microsoft Excel also has the feature of
creating pivot tables from external Text files and multiple file sources or
workbooks using the Editor for Power Query.





CHAPTER THIRTEEN
RECTIFYING DUPLICATE VALUE ENTRIES IN EXCEL PIVOT
TABLES

Handling large data can result in data entries being duplicated in the
data source. Duplicate data can be found and rectified in Excel pivot tables.

Finding and Rectifying Duplicate Data by Selecting the Data

Consider the table shown below with duplicate data entries:

•  Create a pivot table using this data by navigating to the Insert

menu and selecting PivotTable



•  When in the PivotTable Creation dialogue box, select the option for
the pivot table to be created in the currently opened worksheet.

•  Place fields accordingly in their corresponding areas as shown: To
locate the duplicate data entries in the table:

•  Highlight the pivot table
•  Navigate to the Home menu and select Conditional
Formatting

•  In the drop-down menu, select the option for Highlighting Rule of
Cells

• 

Select the Duplicating Values option

This launches the Duplicate dialogue box. In this dialogue box:

•  Select the first drop-down arrow and choose Duplicate

•  Select the second drop-down menu and configure the color with
which the duplicate cells would be highlighted

•  Select OK

Excel then highlights the cells having duplicate data entries



To rectify this duplicate entry:

•  Click on the Filter icon beside Labels for Rows and
•  Deselect the duplicate field

Note that this procedure would completely remove the field from the
pivot table.

Rectifying Duplicate Data from the Data Source
Another reason duplicate entries are seen in pivot tables is as a result of

a single data having different formatting options. For example, data is
entered as a number in one cell and as a text in another cell.

This can be rectified using the Text to Column setting.

•  Highlight your data source
•  Navigate to the Data menu and select the Text to Column
option
•  Choose Delimited as the type of data



•  Select Finish

•  On your pivot table, make a right-click on the table header and select
the Refresh option

This action then removes and consolidates all duplicate data entries.
Locating and Rectifying Duplicate Data Using the LEN Function
The LEN function finds the number or length of characters entered in

its argument. Looking at the pivot table example below, it would be
observed that the record for the Boston region appears three times.



Using the LEN function to check if these data are similar, it was noticed
that the result given by the LEN formula differs for each entry. Recall that
the LEN function counts spaces as characters. To locate which of these data
has spaces as its extra character would



require cleaning up the data source as explained in the previous section.
You can also manually remove the excess space characters by erasing them
in the source data. The filter drop-down menu in the labels for rows does
not take spaces into account, so the Boston record appears as one in this
list.

For large data, manually deleting these excess space characters may be
time-consuming. The following steps provide an easier way out:

•  First, filter the Excel source data table to show the records having
duplicate entries

•  Add a new column and name it appropriately as the column
header

•  In the cell below this new header, type in BOSTON with no extra
space character

•  Enter this data to the last row containing data by dragging down the
cell fill handle

•  Go to your pivot table, make a right-click on the table header and
select the Refresh option

•  Delete the initial field for City in the pivot table by making a right-
click on the table header and selecting the Remove option

•  Replace this removed field with the new column created in the data
source table

Locating and Rectifying Duplicate Data Using the TRIM Function
The TRIM function removes excess space characters either at the end

or in-between data entries. Using the Excel table below:
•  First, filter the Excel source data table to show the records having

duplicate entries



•  Add a new column and name it appropriately as the column
header
•  In the cell below this new header, type in the formula syntax



=TRIM(cell_reference)
•  Enter this formula to the last row containing data by dragging down

the cell fill handle
•  Go to your pivot table, make a right-click on the table header and

select the Refresh option
•  Delete the initial field for City in the pivot table by making a right-

click on the table header and selecting the Remove option

•  Replace this removed
field with the new column created in the data source table



Rectifying Duplicate Data Using the Option for Removing
Duplicates

•  Select the data with duplicate entries

•  Navigate to the Data menu and select the option for Removing
Duplicates



This launches the

corresponding dialogue. In this dialogue box:

• 

Select the column(s) having the duplicate data entries
•  Select OK

Excel then returns a report message of the number of duplicate data
removed. Select OK to exit the message box.

Using the
COUNTIF Function for Locating Cells with Duplicate Data

•  For the data below, create a new column with an appropriate heading

•  Enter the following formula syntax in the cell below this
heading

=COUNTIF(cell_range, count_criteria)>1



•  This formula would return TRUE for cells having values more than a
count of 1. Note that the count_criteria argument used has a duplicate
entry



The formula returns results as shown below

The filter option can then be used to deselect
the duplicate values.

Summary
Duplicate data entries can make pivot table data unnecessarily large.

These can be located and rectified using the methods explained in this
chapter. Certain functions such as the LEN, COUNTIF, and TRIM
functions for locating duplicate entries. Rectification of these duplicate data
sometimes needs to be done from the data source and then refresh the pivot
table. The Filters, Removing Duplicates dialogue box, and Conditional
Formatting menu are used for removing duplicate data.





CHAPTER FOURTEEN
TROUBLESHOOTING AND RESOLVING COMMON

ERRORS IN PIVOT TABLES Troubleshooting Field Name Errors

The error of a field name not being a valid error message appears when
creating or refreshing pivot tables. The error occurs as a result of a wrong
organization of the data source, for instance, if some



columns have no heading, it results in a field name error. Try any of the
following procedures to fix the error:

•  When creating pivot tables, in the PivotTable Creation dialogue box,
ensure not to include blank cells or columns in the Table Range box

•  In the data source from which the pivot table is created, check for
hidden columns. If there are, include a heading to these columns

•  Check for cells that are merged and separate them, then give each
separated cell a heading

•  Click on each column heading in the data source and check its content
in the formula bar. Column headings may be longer than their allocated cell
which may cause an overlap on another column heading.

Troubleshooting Overlapping Issues
This error message occurs when you have multiple pivot tables on one

worksheet. If there are not adequate empty cells to accommodate these
pivot tables, they then overlap and Excel throws an overlap error message.
Fixing this error involves finding and locating the overlapping pivot table,
but in cases of large data where numerous pivot tables have been created,
locating the overlapping pivot table causing the problem may be difficult. In
such cases, a macro can be used for getting a list of all created pivot tables
in the workbook, along with their cell range or location, and their data
sources.



Troubleshooting Duplicate Text Entries in Pivot Tables
These errors can be located and corrected using functions such as LEN,

TRIM, and COUNTIF. Highlight cells containing duplicate text data
entries and then delete them manually or filter them from view. More on
solving this error were explained in Chapter Thirteen.

Troubleshooting Duplicate Number Entries in Pivot Tables
Duplicate number entries can be rectified using the ROUND function to

configure numbers into similar decimal places. Using the Excel table
below:

•  First, filter the Excel source data table to show the records

having duplicate entries

•  Add a new column and name it appropriately as the column
header
•  In the cell below this new header, type in the formula syntax

=ROUND(cell_reference, decimal_places)



•  Enter this formula to the last row containing data by dragging down
the cell fill handle

•  Go to your pivot table, make a right-click on the table header and
select the Refresh option

•  Delete the initial field in the pivot table by making a rightclick on the
table header and selecting the Remove option

•  Replace this removed field with the new column created in the data
source table

Troubleshooting Refreshing Errors in Pivot Tables
Although pivot tables do not refresh automatically, you can, however,

set your pivot tables to refresh when you open the workbook they are saved
in.

•  Select any cell in the pivot table; navigate to the Options

menu from the Tools for PivotTable tab

• 

Select the drop-down menu for PivotTable and select Options
•  In the Options dialogue box, select the Data menu
•  Select the box for refreshing the pivot table on opening the



workbook file

•  Select OK to save the changes

Troubleshooting Refresh Actions Disrupting the PivotTable Layout
•  Select any cell in the pivot table; navigate to the Options menu from

the Tools for PivotTable tab

•  Select the drop-down menu for PivotTable and select Options
•  In the Options dialogue box, select the Layout menu

• 

Select the box for preserving the table format on refresh
•  Select OK to save the changes

Troubleshooting Pivot Tables not Displaying Data

•  Select any cell in the pivot table and make a right-click
•  Select the option for editing the Settings of the Field for the
table
•  Select the Layout and Print menu in the resulting dialogue
box



•  Select the box for displaying items without data
•  Select OK to save the changes

Troubleshooting the Sum of Values Malfunction
The presence of empty cells in the selected data field makes Excel

consider the field as a text field, therefore it uses Count as the summary
function. Check your data source of empty cells within the said field and
edit accordingly. Refresh your pivot table afterward.

Cells formatted as texts, though containing numbers are also a cause of
the Sum summary function not functioning. Check your data source and
format the field to numbers. Refresh your pivot table afterward.

Automatically Refreshing Excel Pivot Tables after a Set Time When
your pivot table is connected to external data, you can set the pivot table to
refresh itself after a set time.

•  Select the pivot table and navigate to the Data menu
•  Select Properties in the Connections menu group

•  This action launches the Properties of the Connection dialogue box
•  Select the option for the pivot table to be refreshed at a specified time

•  Enter a number value for minutes or use the down or up buttons



•  Select OK to apply changes

Summary
However easy it may be to use Excel pivot tables, there are times errors

are encountered. This chapter discussed how you can troubleshoot common
errors in pivot tables. Errors of the name field, duplicate errors, the sum of
value malfunctioning, pivot table refresh errors, etc. were examined. Pivot
tables connected to an external data source can be set to refresh at a specific
time in the Connections dialogue box to keep the table constantly updated.
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CONCLUSION
Though Excel pivot tables and dashboards are robust and packed with
functionalities, they are easy to navigate and use. Pivot tables alongside
dashboards help include and display further data with features not present in
the usual Excel tables from which they are created. With filters, summary
functions, and slicers, users can create dynamic dashboards that show only
selected data. Security measures are also made available for your pivot
tables, dashboards, and data sources.
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